Bug 69025 - Other: Letter Wizard: missing combobox for country in printed items
Summary: Other: Letter Wizard: missing combobox for country in printed items
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.2.0 target:4.1.4
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-09-06 11:01 UTC by Stanislav Horacek
Modified: 2013-12-18 13:32 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot of the dialog since 4.0 (top) and in 3.6 (bottom) (22.81 KB, image/png)
2013-09-06 11:01 UTC, Stanislav Horacek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Horacek 2013-09-06 11:01:21 UTC
Created attachment 85320 [details]
screenshot of the dialog since 4.0 (top) and in 3.6 (bottom)

Problem description: 

Steps to reproduce:
1. Choose File - Wizards - Letter.
2. Go to step 3. Printed items.

Current behavior:
You see text "Use a typical letter format for this country:" and no combobox for country selection.

Expected behavior:
Combobox should be displayed.
              
Operating System: All
Version: 4.0.0.3 release
Last worked in: 3.6.7.2 rc
Comment 1 Julien Nabet 2013-09-07 06:17:21 UTC
On pc Debian x86-64 with master sources updated yesterday and with 4.1 sources updated 1 week ago, + brand new LO profile, I could reproduce this.
Comment 2 Julien Nabet 2013-09-07 06:19:19 UTC
I noticed these logs:
warn:legacy.osl:12979:1:framework/source/fwi/threadhelp/transactionmanager.cxx:299: ASSERT:
	TransactionManager...
	"Owner instance not right initialized yet. Call was rejected! Normaly it's an algorithm error ... wrong usin of class!"

warn:legacy.osl:12979:1:framework/source/fwi/threadhelp/transactionmanager.cxx:299: ASSERT:
	TransactionManager...
	"Owner instance not right initialized yet. Call was rejected! Normaly it's an algorithm error ... wrong usin of class!"

warn:legacy.tools:13139:1:vcl/source/window/window.cxx:4667: Window::~Window: inconsistency in top window chain!

Caolán: UI+vcl problem, one for you?

(I increment the importance since it's an UI regression confirmed)
Comment 3 Caolán McNamara 2013-09-09 13:52:53 UTC
I'd guess it got lose on conversion from java to python ?
Comment 4 Xisco Faulí 2013-09-09 14:00:55 UTC
This was removed before converting letter wizard to python, when the code was changed to translate the templates at runtime -> http://cgit.freedesktop.org/libreoffice/core/commit/?id=1b7c88ab4d6aaa79c484bcb179e5b2f296654462

IMHO, i'll close this bug.
Comment 5 Stanislav Horacek 2013-09-09 14:20:53 UTC
OK, if the language option was removed, then the confusing text "Use a typical letter format for this country:" should be also removed.
Comment 6 Xisco Faulí 2013-09-09 14:34:14 UTC
Yes, you're right, it should be gone too. I'll take care of it.
Thanks for reporting it.
Comment 7 Commit Notification 2013-11-18 20:47:52 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1f7ddf3bbca4433089117ddddd1aaec838554ea3

fdo#69025 Remove unused text



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2013-11-19 11:22:39 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e0d9d5bb52ff1f2fc3efcc204ccb0e1c524182ed&h=libreoffice-4-1

fdo#69025 Remove unused text


It will be available in LibreOffice 4.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2013-11-20 10:02:19 UTC
Stanislav Horacek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=b6b1a6c7e1ccd857414ba11a126129c5cd390ec6

fdo#69025 remove country option from Letter Wizard



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.