Download it now!
Bug 69084 - TABLE: Crash when deleting top rows of this document
Summary: TABLE: Crash when deleting top rows of this document
Status: RESOLVED DUPLICATE of bug 70358
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.5.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-08 05:05 UTC by jddcef
Modified: 2015-09-03 18:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
A document that reproduces this issue every single time. (16.92 KB, application/vnd.oasis.opendocument.text)
2013-09-08 05:05 UTC, jddcef
Details
bt with symbols on master sources (12.36 KB, text/plain)
2013-09-11 20:39 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jddcef 2013-09-08 05:05:38 UTC
Created attachment 85417 [details]
A document that reproduces this issue every single time.

Problem description: 
When deleting the two rows at the top using Right click -> Row -> Delete, one at a time, it always crashes Writer on the second delete.

Steps to reproduce:
1. Right click the empty space in the first row -> Row -> Delete
2. Right click the empty space in the second row -> Row -> Delete
3. Everything crashes with a recovery message etc.

Current behavior:
Crash and recover attempt.

Expected behavior:
No crash.
              

I tried a 4.0.x version and it also happens in there as well as 4.1.1. final
Operating System: Windows 8
Version: 4.1.1.2 rc
Comment 1 Thomas van der Meulen 2013-09-08 07:11:03 UTC
Thank you for your bug report, I can reproduce this bug running Version: 4.1.2.1
Build ID: bf15ac65c2167fb1ef3daf3710609d4a4c369a9
and Version 4.0.5.2 (Build ID: 5464147a081647a250913f19c0715bca595af2f)
on Mac osx 10.8.4.
Comment 2 Julien Nabet 2013-09-11 20:39:23 UTC
Created attachment 85668 [details]
bt with symbols on master sources

On pc Debian x86-64 with master sources updated today + brand new LO profile, I reproduced the crash.
Comment 3 Julien Nabet 2013-09-11 20:50:12 UTC
This patch removes the crash but the result is quite weird since the text disappears. (it reappears if I click on undo)
diff --git a/sw/source/core/layout/wsfrm.cxx b/sw/source/core/layout/wsfrm.cxx
index 13fc678..0ed3400 100644
--- a/sw/source/core/layout/wsfrm.cxx
+++ b/sw/source/core/layout/wsfrm.cxx
@@ -2607,9 +2607,13 @@ SwTwips SwLayoutFrm::ShrinkFrm( SwTwips nDist, sal_Bool bTst, sal_Bool bInfo )
         {
             _InvalidateAll();
             InvalidatePage( pPage );
-            const SvxGraphicPosition ePos = GetFmt()->GetBackground().GetGraphicPos();
-            if ( GPOS_NONE != ePos && GPOS_TILED != ePos )
-                SetCompletePaint();
+            const SwFrmFmt *pFmt = GetFmt();
+            if (pFmt)
+            {
+                const SvxGraphicPosition ePos = pFmt->GetBackground().GetGraphicPos();
+                if ( GPOS_NONE != ePos && GPOS_TILED != ePos )
+                    SetCompletePaint();
+            }
         }
 
         if ( !(GetType() & 0x1823) ) //Tab, Row, FtnCont, Root, Page

Michael: one for you?
Comment 4 Caolán McNamara 2013-10-31 10:28:11 UTC
I believe we have a table in a table, so when you delete the "outer" second row, then the main text is inside a table hosted in that row, so it disappears

*** This bug has been marked as a duplicate of bug 70358 ***
Comment 5 jddcef 2015-09-02 21:40:06 UTC
Still happens on LO 5.0.1.2 release on Windows 8.1 x64, even though some "related bug" was closed.  Crash.
Comment 6 Julien Nabet 2015-09-03 18:29:12 UTC
Please, don't reopen this one but the other one, tdf#70358.

*** This bug has been marked as a duplicate of bug 70358 ***