Bug 69086 - Export PNG saves to wrong resolution
Summary: Export PNG saves to wrong resolution
Status: RESOLVED DUPLICATE of bug 67477
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86 (IA32) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-09-08 07:42 UTC by Derek Keats
Modified: 2013-09-21 22:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Derek Keats 2013-09-08 07:42:44 UTC
When you select the file size from the export dialogue in Draw, the file size is ignored on save. This is a serious flaw for people like me who use Draw every day and export to PNG for inclusion in documents. 

STEPS TO REPLICATE:
1. Create a new file and add - say - some text to it.
2. From the file menu, select Export, then file type PNG from the popup dialogue. Give it a name and save.
3. In the dialogue that appears next, choose width & height. Make it big so you can see, say 5000 Px wide. 

RESULT: 
In my example instead of saving it 500px wide, it saved it 841 px wide, which is even less than the default that it is set to.

EXPECTED:
Is would save at the size and resolution I chose.

VERSION: 
Version: 4.1.1.2
Build ID: 410m0(Build:2)
The same bug was in the previous version from the LO PPA.
Comment 1 tommy27 2013-09-21 21:52:16 UTC
bug confirmed with 4.1.0 and 4.1.1 final releases under Win7 4bit.
works fine with 4.0.5 final.

looking at the .png output it seems that 4.0.5 saves the background of the Draw page and the text, while 4.1.x saves just the text with no background so this may explain the pixel size difference
Comment 2 tommy27 2013-09-21 22:00:51 UTC

*** This bug has been marked as a duplicate of bug 67477 ***