Download it now!
Bug 69163 - FILEOPEN: Can't open MS Excel .xml file
Summary: FILEOPEN: Can't open MS Excel .xml file
Status: RESOLVED DUPLICATE of bug 63756
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.6 release
Hardware: Other Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-10 04:35 UTC by Ruslan Fatakhov
Modified: 2013-12-17 08:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
MS excel xml file - report from Oracle (29.82 KB, application/x-7z-compressed)
2013-09-10 04:35 UTC, Ruslan Fatakhov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ruslan Fatakhov 2013-09-10 04:35:09 UTC
Created attachment 85528 [details]
MS excel xml file - report from Oracle

Problem description: 
I've a report from Oracle in MS excel xml format. I try open it with LO Calc 4.1.1.2 for winXP, but i get error.

It problem was fixed for LO Calc v.4.0 for Linux.

Steps to reproduce:
1. Clic two time at xml file
2. ....
3. ....

Current behavior:
LO Calc get error "Error input/output"

Expected behavior:

              
Operating System: Windows XP
Version: 4.1.1.2 rc
Comment 1 tommy27 2013-09-10 05:50:22 UTC
tested under Win7 64bit

same "Error input/output" error message with LibO 4.1.1, 4.0.4, 3.6.7, 3.5.7
blank spreadsheet opened in LibO 3.4.6
file opens correctly in LibO 3.3.3 and AOO 4.0.0 opens .xml file.

status --> NEW  
version --> 3.4.6 (I did not test with 3.3.4 --> 3.4.5 releases though)
adding regression keyword and Calc expert to CC list.
Comment 2 Eike Rathke 2013-09-10 09:37:14 UTC

*** This bug has been marked as a duplicate of bug 67699 ***
Comment 3 Maxim Monastirsky 2013-09-10 13:08:27 UTC
It's not a duplicate of bug 67699, because the latter is a regression of 4.1, while the current bug reproducible with 3.4 too. Also bug 67699 already fixed in master (and 4.1.2), while the current bug still reproducible. Tested with 4.2.0.0.alpha0+ Build ID: a8865e5df62b5f33aa769d459b9823eb5b110d4b TinderBox: Win-x86@6-debug, Branch:master, Time: 2013-09-03_14:36:22
Comment 4 Maxim Monastirsky 2013-09-10 13:15:57 UTC
The appropriate status is 'NEW', since it was closed by mistake. Also raising priority since user can't open the document at all. Also removing 'regression' keyword, as it's an old bug (see https://wiki.documentfoundation.org/QA/BugTriage#Additional_Useful_.28Optional.29_Steps)
Comment 5 Urmas 2013-09-10 13:57:25 UTC

*** This bug has been marked as a duplicate of bug 63756 ***