Download it now!
Bug 69218 - PDF: Crash during pdf export
Summary: PDF: Crash during pdf export
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other Mac OS X (All)
: highest blocker
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
: 69393 69412 69473 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-11 10:38 UTC by bernd.dongus
Modified: 2013-09-21 06:19 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
idee5 template with "//" as text crashing the pdf export (29.15 KB, application/vnd.oasis.opendocument.presentation)
2013-09-11 22:28 UTC, bernd.dongus
Details
export to pdf crash trace (69.67 KB, text/plain)
2013-09-17 10:44 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bernd.dongus 2013-09-11 10:38:40 UTC
Problem description: 

Steps to reproduce:
1. Export to PDF
2. Hit "OK-Button"
3. Select a directory and file
4. Hit Save

Current behavior:
Impress stops with this exception:

Process:         soffice [11193]
Path:            /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier:      org.libreoffice.script
Version:         4.1.1.2 (???)
Code Type:       X86 (Native)
Parent Process:  launchd [232]
User ID:         501

Date/Time:       2013-09-11 12:21:00.690 +0200
OS Version:      Mac OS X 10.8.4 (12E55)
Report Version:  10

Interval Since Last Report:          33318 sec
Crashes Since Last Report:           2
Per-App Crashes Since Last Report:   2
Anonymous UUID:                      4D880CE5-E74A-5852-7639-17C7B8F664FB

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x000000007473346e

VM Regions Near 0x7473346e:
    MALLOC_TINY            0000000024f00000-0000000025000000 [ 1024K] rw-/rwx SM=PRV  
--> 
    __TEXT                 000000008febc000-000000008feef000 [  204K] r-x/rwx SM=COW  /usr/lib/dyld

Application Specific Information:
objc_msgSend() selector name: release


Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libobjc.A.dylib               	0x9a415a8b objc_msgSend + 27
1   com.apple.CoreFoundation      	0x9356131b CFRelease + 171
2   libvcllo.dylib                	0x01a57162 CTTextStyle::~CTTextStyle() + 50
3   libvcllo.dylib                	0x01a5a2cd AquaSalGraphics::SetFont(FontSelectPattern*, int) + 29
4   libvcllo.dylib                	0x0189c643 OutputDevice::ImplInitFont() const + 147
5   libvcllo.dylib                	0x018aab61 OutputDevice::ImplLayout(rtl::OUString const&, long, long, Point const&, long, long const*, bool) const + 705
6   libvcllo.dylib                	0x0191ad02 vcl::PDFWriterImpl::drawTextArray(Point const&, String const&, long const*, unsigned short, unsigned short, bool) + 114
7   libvcllo.dylib                	0x018eca90 vcl::PDFWriter::DrawTextArray(Point const&, String const&, long const*, unsigned short, unsigned short) + 64
8   libvcllo.dylib                	0x018f1e8c vcl::PDFWriterImpl::playMetafile(GDIMetaFile const&, vcl::PDFExtOutDevData*, vcl::PDFWriter::PlayMetafileContext const&, VirtualDevice*) + 5116
9   libvcllo.dylib                	0x018f2268 vcl::PDFWriterImpl::playMetafile(GDIMetaFile const&, vcl::PDFExtOutDevData*, vcl::PDFWriter::PlayMetafileContext const&, VirtualDevice*) + 6104
10  libvcllo.dylib                	0x018ebf20 vcl::PDFWriter::PlayMetafile(GDIMetaFile const&, vcl::PDFWriter::PlayMetafileContext const&, vcl::PDFExtOutDevData*) + 48
11  libpdffilterlo.dylib          	0x1d978d65 PDFExport::ImplExportPage(vcl::PDFWriter&, vcl::PDFExtOutDevData&, GDIMetaFile const&) + 565
12  libpdffilterlo.dylib          	0x1d97b21c PDFExport::ExportSelection(vcl::PDFWriter&, com::sun::star::uno::Reference<com::sun::star::view::XRenderable>&, com::sun::star::uno::Any const&, StringRangeEnumerator const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>&, long) + 3356
13  libpdffilterlo.dylib          	0x1d97dfb0 PDFExport::Export(rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 10192
14  libpdffilterlo.dylib          	0x1d989035 PDFFilter::implExport(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 4693
15  libpdffilterlo.dylib          	0x1d989917 PDFFilter::filter(com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 87
16  libsfxlo.dylib                	0x0070876a SfxObjectShell::ExportTo(SfxMedium&) + 3674
17  libsfxlo.dylib                	0x0070f792 SfxObjectShell::SaveTo_Impl(SfxMedium&, SfxItemSet const*) + 6962
18  libsfxlo.dylib                	0x00712ad7 SfxObjectShell::PreDoSaveAs_Impl(String const&, String const&, SfxItemSet*) + 935
19  libsfxlo.dylib                	0x007134f2 SfxObjectShell::CommonSaveAs_Impl(INetURLObject const&, String const&, SfxItemSet*) + 2082
20  libsfxlo.dylib                	0x006fb2f3 SfxObjectShell::APISaveAs_Impl(String const&, SfxItemSet*) + 531
21  libsfxlo.dylib                	0x0073f2ca SfxBaseModel::impl_store(rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&, unsigned char) + 2042
22  libsfxlo.dylib                	0x00749ab6 SfxBaseModel::storeToURL(rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 278
23  libsfxlo.dylib                	0x006dea11 SfxStoringHelper::GUIStoreModel(com::sun::star::uno::Reference<com::sun::star::frame::XModel>, rtl::OUString const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue>&, unsigned char, rtl::OUString, unsigned short) + 4065
24  libsfxlo.dylib                	0x006fcb49 SfxObjectShell::ExecFile_Impl(SfxRequest&) + 5369
25  libsfxlo.dylib                	0x0082c3a8 SfxDispatcher::Call_Impl(SfxShell&, SfxSlot const&, SfxRequest&, unsigned char) + 360
26  libsfxlo.dylib                	0x00595183 SfxBindings::Execute_Impl(SfxRequest&, SfxSlot const*, SfxShell*) + 99
27  libsfxlo.dylib                	0x005cc5b5 SfxDispatchController_Impl::dispatch(com::sun::star::util::URL const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&, com::sun::star::uno::Reference<com::sun::star::frame::XDispatchResultListener> const&) + 4021
28  libsfxlo.dylib                	0x005cd635 SfxOfficeDispatch::dispatch(com::sun::star::util::URL const&, com::sun::star::uno::Sequence<com::sun::star::beans::PropertyValue> const&) + 341
29  libfwklo.dylib                	0x0f962964 framework::GenericToolbarController::ExecuteHdl_Impl(framework::GenericToolbarController*, framework::ExecuteInfo*) + 52
30  libvcllo.dylib                	0x01a55acd ImplWindowFrameProc(Window*, SalFrame*, unsigned short, void const*) + 6333
31  libvcllo.dylib                	0x01a629d8 AquaSalInstance::Yield(bool, bool) + 312
32  libvcllo.dylib                	0x01723d94 Application::Yield(bool) + 84
33  libvcllo.dylib                	0x01723e4c Application::Execute() + 60
34  libsofficeapp.dylib           	0x0006f29a desktop::Desktop::Main() + 7642
35  libvcllo.dylib                	0x0172a1f2 ImplSVMain() + 226
36  libvcllo.dylib                	0x01a61a21 AquaSalInstance::handleAppDefinedEvent(NSEvent*) + 129
37  libvcllo.dylib                	0x01a9dcfb -[VCL_NSApplication sendEvent:] + 315
38  com.apple.AppKit              	0x97e9f62c -[NSApplication run] + 951
39  com.apple.AppKit              	0x97e425f6 NSApplicationMain + 1053
40  libvcllo.dylib                	0x01a622e7 ImplSVMainHook(int*) + 343
41  libvcllo.dylib                	0x0172a22a SVMain() + 26
42  libsofficeapp.dylib           	0x0009d765 soffice_main + 325
43  org.libreoffice.script        	0x00001f4e main + 30
44  org.libreoffice.script        	0x00001f25 start + 53

Expected behavior:
Create a PDF of my presentation.
Operating System: Mac OS X
Version: 4.1.1.2 release
Comment 1 Julien Nabet 2013-09-11 19:45:21 UTC
bernd:
- do you reproduce this with any file, in particular with a brand new file just containing the word "test" for example? (without formatting, charts, image, etc.)
- did you install any specific font?
Comment 2 bernd.dongus 2013-09-11 22:28:01 UTC
Created attachment 85670 [details]
idee5 template with "//" as text crashing the pdf export
Comment 3 bernd.dongus 2013-09-11 22:29:44 UTC
Having done some tests I were able to reduce it to the attached file.
Creating a new file without formatting and "//" as text works as expected.

I use Century Gothic and Georgia. Web safe fonts. Nothing fancy.
Comment 4 Alex Thurgood 2013-09-17 10:44:21 UTC
Confirming, enclosing crashtrace

All of these bugs appear to have the same CF/coretext release threads.


Alex
Comment 5 Alex Thurgood 2013-09-17 10:44:57 UTC
Created attachment 85965 [details]
export to pdf crash trace
Comment 6 Alex Thurgood 2013-09-17 10:45:19 UTC
regression over 4.0.5
Comment 7 Alex Thurgood 2013-09-17 10:45:38 UTC
Nominating as blocker
Comment 8 Alex Thurgood 2013-09-17 10:46:50 UTC
*** Bug 69412 has been marked as a duplicate of this bug. ***
Comment 9 Alex Thurgood 2013-09-17 10:47:15 UTC
*** Bug 69393 has been marked as a duplicate of this bug. ***
Comment 10 Alex Thurgood 2013-09-17 11:03:39 UTC
I can not reproduce the crash on my master 4.2 build
Comment 11 Alex Thurgood 2013-09-17 11:07:18 UTC
Tested with ODP from this bug, and ODT from bug 69412, and LO no longer crashes on PDF export with my 4.2 master build.
Comment 12 Alex Thurgood 2013-09-17 11:31:59 UTC
Setting as WORKSFORME on master, but no idea whether the fix (which at present is unidentifiable) has been backported to the next release version of LO.


Alex
Comment 13 Alex Thurgood 2013-09-17 15:36:54 UTC
*** Bug 69473 has been marked as a duplicate of this bug. ***
Comment 14 Cor Nouws 2013-09-17 18:36:02 UTC
I tested the attachment from bug 69393 in 4.1.1.2 on Ubuntu and was fine there.