Download it now!
Bug 69279 - Crashes on "Save As..." dialog
Summary: Crashes on "Save As..." dialog
Status: RESOLVED DUPLICATE of bug 69002
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: x86 (IA32) Linux (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-12 16:50 UTC by emilio.recio
Modified: 2013-10-10 21:51 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
crash log report (26.85 KB, text/x-log)
2013-09-16 15:26 UTC, emilio.recio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description emilio.recio 2013-09-12 16:50:19 UTC
Don't know quite where this goes, but:
1) open an xls file in calc
2) file -> save as...
3) hover over the dialog box's shortcuts

I have smb:// and sftp:// shortcuts in the dialog box. I have various mounted filesystems (webdav, luks, etc). I am NOT accessing or even attempting to save to any of the mounted filesystems or shortcuts. 

No other application exhibits a crash when saving as. Need to get this resolved asap for work, so switching to alternative app for now. Please help!!
Comment 1 emilio.recio 2013-09-12 17:00:13 UTC
Note, that the same happens on the Open dialog if you already have a document open. I cannot reproduce issue with open dialog if there are no documents open.
Comment 2 tommy27 2013-09-13 03:00:06 UTC
have u tried upgrading to 4.1.1.2?
Comment 3 Julien Nabet 2013-09-13 22:05:51 UTC
Emilio: in addition to what Tommy27 indicated, could you try to retrieve an useful backtrace by following this link? (https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#GNU.2FLinux:_How_to_get_a_backtrace)
Comment 4 emilio.recio 2013-09-16 15:25:39 UTC
So I installed the gdb package and ran the backtrace... it has been attached to this bug report. However, the terminal output is as follows the moment I went "File -> Open..." with no files open:


[exr003@pcsdw29 Downloads]$ oocalc --backtrace 
GNU gdb (GDB) Fedora (7.6-34.fc19)
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/lib/libreoffice/program/soffice.bin...Reading symbols from /usr/lib/libreoffice/program/soffice.bin...(no debugging symbols found)...done.
(no debugging symbols found)...done.
log will be saved as gdbtrace.log, this will take some time, patience...
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x4200038
QWidget::repaint: Recursive repaint detected
Comment 5 emilio.recio 2013-09-16 15:26:35 UTC
Created attachment 85918 [details]
crash log report
Comment 6 emilio.recio 2013-09-16 15:42:37 UTC
Please note, that I unmounted all of my "non-traditional" filesystems (wdfs, sshfs, etc) to no avail. File -> Open crashes too with no file open. It has previously been on "Save As..." as well when you already had a file open.
Comment 7 emilio.recio 2013-09-16 15:48:03 UTC
It also seems to be when I put my mouse into the file listings. If I have my mouse anywhere else it stays up. For example, when I move my mouse into the toolbar area, or the OK/Cancel, or filename area it doesn't crash. However, it's repeatable if I move the mouse over either the a) directory listing area or b) the shortcuts to the left. That's why I thought it may have been a mounted filesystem issue; with everything unmounted, I can't possibly figure out what it is.
Comment 8 Julien Nabet 2013-09-16 19:54:48 UTC
Thank you Emilio for your feedback, I put it as NEW.

Lubos: one for you? (bt shows kde4 + qt part).
Comment 9 emilio.recio 2013-09-23 14:35:19 UTC
What's the status of this request? I haven't been able to use libreoffice for three weeks or so. Downloading open office for now.
Comment 10 Julien Nabet 2013-09-23 19:28:08 UTC
Michael: I put you in cc just in case you've already seen this kind of error before.
Comment 11 Michael Meeks 2013-09-24 12:28:57 UTC
Hmm - I guess we need some Qt / KDE guy with the time to look into this sort of stuff; no idea if Lubos has the time & interest ? :-)
Comment 12 Andy 2013-09-25 14:53:13 UTC
I have been frequently experiencing this bug also, since upgrading to LO 4.1.1.2  Fine previously (4.0.2.?).  
Running KDE/LO under Kubuntu Raring with latest updates applied.  No KDE updates in the meantime? So appears to be LO related.

Running Ext4 on the HDD so nothing wierd there.  HDD is the only system mounted at the time.

Am using Writer when it happens (Calc for Emilio).
Occurred in the last case when I had *only* pressed the "Save As" button. So you do not even have to move the mouse in the KDE file dialog listings (as per Emilio).

GDB gives the same error:
"Program received signal SIGSEGV, Segmentation fault.
0xaf15a807 in QTransform::type() const () from /usr/lib/i386-linux-
gnu/libQtGui.so.4"

Running LO from the terminal outputs similar Op Code issues 
"X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 42 (X_SetInputFocus)
  Resource id:  0x5e02b43"

In the same LO session, terminal also gave this error a few times (might be related/useful?):
"/org/freedesktop/UDisks2/drives/WDC_WD7500BPKT_00PK4T0_WD_WXD1A11V3246" : 
property "Device" does not exist".  

Makes using LO dangerous as you cannot Save As files reliably.

Andy
Comment 13 emilio.recio 2013-09-26 14:04:28 UTC
* Just upgraded and it still exists in 4.1.1.2 btw
Comment 14 Julien Nabet 2013-09-26 14:08:45 UTC
Andy, Emilio: Thank you for the feedback. Following your last comments, I increase the importance.
Comment 15 Maxim Monastirsky 2013-10-10 21:51:03 UTC
Symptoms & backtrace look very similar to what we already have at Bug 69002, so closing as a duplicate.

*** This bug has been marked as a duplicate of bug 69002 ***