Download it now!
Bug 69337 - MAILMERGE: setting server connection failed
Summary: MAILMERGE: setting server connection failed
Status: RESOLVED DUPLICATE of bug 70196
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-13 20:45 UTC by Ferry Toth
Modified: 2013-10-19 17:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ferry Toth 2013-09-13 20:45:55 UTC
Sending an emailmerge I arrive at the final step, actually send out the mail. After clicking on Send documents nothing happens. This is not a duplicate of #58703. I have been happily sending emailmerges until I upgraded to Raring  (so with LibO < 4).

I think it is also not #66761, patches should have already been applied to the PPA acc. comment 19.

Now I have grabbed LibO 4.1.1.2 from the Libreoffice PPA.

The following might help trace the problem. When checking smtp server settings (In Tools - Options - Writer - Standard Letter (or so I have -nl menu's) I get:

LibreOffice kan geen verbinding met de server voor uitgaande e-mail maken. Controleer uw systeeminstellingen en de instellingen in LibreOffice. Controleer de servernaam, de poort en de instellingen voor beveiligde verbindingen
--
<type 'exceptions.AttributeError'>: 'exceptions.ImportError' object has no attribute 'with_traceback', traceback follows
  /usr/lib/python2.7/dist-packages/uno.py:334 in function _uno_import() ["%s (or '%s.%s' is unknown)" % (py_import_exc, name, x)]
  /usr/lib/python2.7/pickle.py:88 in function <module>() [from org.python.core import PyStringMap]
  /usr/lib/python2.7/dist-packages/uno.py:268 in function _uno_import() [return _g_delegatee( name, *optargs, **kwargs )]
  /usr/lib/python2.7/subprocess.py:432 in function <module>() [import pickle]
  /usr/lib/python2.7/dist-packages/uno.py:268 in function _uno_import() [return _g_delegatee( name, *optargs, **kwargs )]
  /usr/lib/python2.7/imaplib.py:25 in function <module>() [import binascii, errno, random, re, socket, subprocess, sys, time]
  /usr/lib/python2.7/dist-packages/uno.py:268 in function _uno_import() [return _g_delegatee( name, *optargs, **kwargs )]
  /usr/lib/libreoffice/program/mailmerge.py:50 in function <module>() [import sys, smtplib, imaplib, poplib]
  /usr/lib/python2.7/dist-packages/uno.py:268 in function _uno_import() [return _g_delegatee( name, *optargs, **kwargs )]
  /usr/lib/libreoffice/program/pythonloader.py:114 in function getModuleFromUrl() [mod =  __import__( dependent )]
  /usr/lib/libreoffice/program/pythonloader.py:136 in function activate() [mod = self.getModuleFromUrl( locationUrl )]
Comment 1 Cor Nouws 2013-09-13 22:37:53 UTC
Hi Ferry,

I have no trouble mailing from Writer mail merge with 4.1.1.2 from Ubuntu, once I managed to enter the right settings, including server verification.

Regards,
Cor
Comment 2 Cor Nouws 2013-09-13 22:39:10 UTC
(Change summary a bit, though I don't have the problem over here ...)
Comment 3 Ferry Toth 2013-09-13 22:50:07 UTC
Cor, I know how to set the server settings, it has worked well until I upgraded from LibO 3.6 to 4.1.1.

My smtp server does not support SSL/TLS nor requires login/pw.

So,actually this is simplest case. There is nothing to set.

I have another smtp server, that does require login and supports only TLS. That gave the same error.

Note that when clicking Send Documents there is no error message. Just *nothing* happens.

The error is only shown when testing the smtp server.
Comment 4 Cor Nouws 2013-09-14 10:42:57 UTC
(In reply to comment #3)
> Cor, I know how to set the server settings, \

That's what I guess yes ;)
Then there must be something specific to the 64 bits version?
I run 32 bits on Linux.
Comment 5 Ferry Toth 2013-09-14 11:17:54 UTC
Or a packaging/dependancy problem? I have raring + kde backports ppa + libreoffice ppa. python is from raring.
Comment 6 Ferry Toth 2013-09-14 12:17:41 UTC
On my laptop (i386) with LibO from raring (4.0.2) there is no error when testing the smtp connection.

So, either 64bit problem, packaging/dependancy error in PPA or regression from 4.0.2 -> 4.1.1.2?
Comment 7 Ferry Toth 2013-09-14 12:41:50 UTC
Found this:

python3-uno needs to be pulled in, which will remove python-uno.

Then testing the smtp server will pass.

Now I will go test emailmerge again and report back.
Comment 8 Ferry Toth 2013-09-14 13:19:04 UTC
Yes, pulling in python3-uno solves the reported problem.

Tried to report this on launchpad in the libreoffice ppa but that doesn't seem to be possible.

What is the right way to report this to the libreoffice packaging team?
Comment 9 Cor Nouws 2013-09-14 19:26:41 UTC
Hi Ferry,

(In reply to comment #8)
> Yes, pulling in python3-uno solves the reported problem.

thanks for finding out!

> Tried to report this on launchpad in the libreoffice ppa but that doesn't
> seem to be possible.
> 
> What is the right way to report this to the libreoffice packaging team?

I mailed to the QA-list to ask.
Comment 10 ape 2013-09-15 13:05:06 UTC
If I understand the English description of the bug, then:

It seems to me that this is the problem of Ubuntu.
 Most likely, the removal of LibO_ubuntu produced an incomplete without deleting the settings. Therefore, the LibO_TDF searches to Python’s path in the /usr/lib/.. directory but not in /opt folder.

LibO_TDF-4.1.1.2 works without this error in Lubuntu-13.04 32/64 bit.
Comment 11 Cor Nouws 2013-09-15 14:44:22 UTC
@ferry

(In reply to comment #9)

> I mailed to the QA-list to ask.

http://lists.freedesktop.org/archives/libreoffice-qa/2013-September/005253.html
Comment 12 Ferry Toth 2013-09-15 20:31:20 UTC
(In reply to comment #10)

I don't think so. I got LibO from the Ubuntu PPA. This is not Ubuntu. It is built by the Libreoffice packaging team, who are neither Libreoffice nor Ubuntu (although may be the same people).

In this case it is actually correct to get python from /usr/lib, and I have both 2.7 and 3.3.

It seems like python-uno wants to call 2.7, but for some reason that crashes, while python3-uno calls 3.3 and that functions.

Question is: is there a bug in the python-uno code that crashes python 2.7 (upstream bug) or is it intended to use python 3.3, in which case python3-uno should have replaced python-uno (dependancy problem).

In the meanwhile manually installing python3-uno with synaptics solves the problem for me.
Comment 13 ape 2013-09-16 04:53:02 UTC
(In reply to comment #12)
> (In reply to comment #10)
> 
> I don't think so. I got LibO from the Ubuntu PPA. This is not Ubuntu. It is
> built by the Libreoffice packaging team, who are neither Libreoffice nor
> Ubuntu (although may be the same people).
> 
 
You are installing Ubuntu LibreOffice packages from the Canonical’s site into ‘usr’-folder.
 If you have installed the packages of The Document Foundation, installation folder would be ‘/opt/..’. Python is placed here: /opt/${ORIGIN}/program/python-core-3.3.0/.. , so there are no problems.
 So, this is Canonical’s problem, I think.
--
ape
Comment 14 Ferry Toth 2013-09-16 09:30:37 UTC
(In reply to comment #13)

> > I don't think so. I got LibO from the Ubuntu PPA. This is not Ubuntu. It is
> > built by the Libreoffice packaging team, who are neither Libreoffice nor
> > Ubuntu (although may be the same people).
> > 
>  
> You are installing Ubuntu LibreOffice packages from the Canonical’s site
> into ‘usr’-folder.
>  If you have installed the packages of The Document Foundation, installation
> folder would be ‘/opt/..’. Python is placed here:
> /opt/${ORIGIN}/program/python-core-3.3.0/.. , so there are no problems.
>  So, this is Canonical’s problem, I think.

The PPA doesn't and shouldn't build python. The packagers seem to have enabled python 2 support in the current build, possibly for Ubuntu Precise.

python-uno and python3-uno are built from LibO sources afaik. It looks like python 2 support is not working well. I am guessing this is a bug in LibO.

In any case it will not be Canonical's problem. Packages in PPA's are not supported by them.

The purpose of the PPA is to be able to participate in LibO testing early (during RC stages), see https://launchpad.net/~libreoffice/+archive/ppa. Obviously this testing can reveal bugs in code that is not enabled and built in LibO's own binaries.
Comment 15 Rene Engelhard 2013-10-06 14:45:43 UTC
yeah, the ImportErrror is because python2 support got broken between 4.1.0 and 4.1.1, see also http://bugs.debian.org/725401.

No idea, though, what the "real" issue except that ImportError is.
Comment 16 Rene Engelhard 2013-10-06 14:47:17 UTC
oops, http://bugs.debian.org/725491...
Comment 17 Julien Nabet 2013-10-19 17:02:51 UTC
Considering the bt, it seems the same error ("object has no attribute 'with_traceback'") than fdo#70196. Moreover fdo#70196 has been fixed (for daily build on master branch + future 4.1.3 and 4.0.7)

Now if you still get the error with one of these future versions, don't hesitate to reopen this tracker.

About release plan, you can take a look here:
https://wiki.documentfoundation.org/ReleasePlan#4.1_release
and here
https://wiki.documentfoundation.org/ReleasePlan#4.0_release

*** This bug has been marked as a duplicate of bug 70196 ***