Bug Hunting Session
Bug 69482 - FORMULAEDITOR: Please shorten some expressions
Summary: FORMULAEDITOR: Please shorten some expressions
Status: RESOLVED DUPLICATE of bug 78187
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Formula-Editor
  Show dependency treegraph
 
Reported: 2013-09-17 18:22 UTC by Ray-Ven
Modified: 2016-10-29 19:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ray-Ven 2013-09-17 18:22:32 UTC
I love the LO Forumla editor!
I use it every day in math lessons to write formulas while talking! In my case, short expressions are necessary to speed up formula editing.
(I'm not sure if this is the right place for wishes - if yes, I'd be happy to make 3 out of this one, if necessary)

Problem description: 
could you please make brackets automatically be scaleable? why differ between ( and left(, or is for example "right rline" really necessary? Wouldn't be rline enough? Or how about just mline for all lines (we could use {mline x mline} for example. This is just one expression which makes me curious - there are a lot more!

Another thing I would love to have is a "operatorline with spaces" (I use ~~~"|" atm) which is necessary to put explainations behind a formula. Example: 4x-2=0 ~~~"|" +2 newline 4x=2 

An often wanted thing: Alignment along = Symbol, i know, I'd prefer an orientation along a custom string. (in my case alignment along ~~~"|" would often be helpfull) I know about the "workaround" with matrixes - but this is really horrible

Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

              
Operating System: All
Version: unspecified
Comment 1 tommy27 2013-09-21 21:37:34 UTC
feature request. set status to NEW.
Comment 2 Owen Genat (retired) 2013-11-13 04:24:49 UTC
(In reply to comment #0)
> Alignment along = Symbol, i know, I'd prefer an
> orientation along a custom string. (in my case alignment along ~~~"|" would
> often be helpfull) I know about the "workaround" with matrixes - but this is
> really horrible

You probably need to open a separate bug for an enhancement to add a comment expression (that is displayed in the resulting formula) to Math. I just wanted to point out that it is easier to use the stack+align commands rather than the matrix command to obtain a required alignment workaround e.g.,

stack { 
alignl { 4x - 2 = 0 } ~~~"|" + 2 # 
alignl { 4x = 2 } 
} 

or

stack { 
alignr { 4x - 2 = 0 ~~~"|" + 2 } # 
alignr { 4x = 2 phantom { ~~~"|" + 2 } } 
} 

The second is still inelegant, due to the need for identically sized comments. Anyway, hope that helps.
Comment 3 V Stuart Foote 2016-10-29 19:13:20 UTC

*** This bug has been marked as a duplicate of bug 78187 ***