Bug 69489 - FILEOPEN Spreadsheet in sxc format does not open correctly: Formulas do not appear as such
Summary: FILEOPEN Spreadsheet in sxc format does not open correctly: Formulas do not ...
Status: RESOLVED DUPLICATE of bug 74979
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-17 20:14 UTC by Dale Worley
Modified: 2014-02-15 21:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Spreadsheet to be opened (31.19 KB, application/vnd.sun.xml.calc)
2013-09-17 20:14 UTC, Dale Worley
Details
Working sxc file with formula (7.08 KB, application/vnd.sun.xml.calc)
2013-11-15 23:23 UTC, Joel Madero
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dale Worley 2013-09-17 20:14:24 UTC
Created attachment 86015 [details]
Spreadsheet to be opened

Open the attached spreadsheet file R.sxc.

The cells containing formulas (in particular, D3) do not appear as formulas.  E.g., D3 appears as "ooow:=[.D2]-[.B3]".

Another peculiarity:

Following the instructions in the bottom entry on http://ask.libreoffice.org/en/question/8957/calc-cells-not-calculating-at-all/, I edited the .sxc file by adding the attribute office:class="spreadsheet" to the office:document-content element in the content.xml file and re-zipped the .sxc file.  Libreoffice could then open the file and display the formulas correctly.  I then saved it as an .sxc file under a new name.  But I could not then open the newly created .sxc file -- the formulas appeared in the same peculiar way as described above.  Examining the contained content.xml file, it did not contain the office:class attribute.

Another peculiarity:

I opened an .sxc file created by a considerably older version of OpenOffice.  Libreoffice displayed the formulas correctly.  Examining the contained content.xml file, it contained the office:class attribute.

The version of Libreoffice I am using to open the .sxc file:
libreoffice-calc-4.1.1.2-4.fc19.x86_64  (and associated RPMs as fetched by yum)

The version of Libreoffice used to create the .sxc file:
libreoffice-calc-3.4.6.2-1.fc16.i686

The Linux version (Fedora 19):
Linux hobgoblin.ariadne.com 3.10.11-200.fc19.x86_64 #1 SMP Mon Sep 9 13:03:01 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Joel Madero 2013-11-15 23:23:02 UTC
Is this attached file a file that you opened and then saved and then reopened? I think we need a file that actually hasn't been saved on a new release of libreoffice

Attached you'll find a simple sheet that I created in LibreOffice 3.5alpha0 and it opens fine (just a single formula =1+1 in cell A1

marking as NEEDINFO. Please attach a document that has not been resaved. With the other method you used (XML edits) did you try saving as a ods instead?

Once you provide another sheet and answer the question mark as UNCONFIRMED and we'll investigate


Thanks!
Comment 2 Joel Madero 2013-11-15 23:23:41 UTC
Created attachment 89294 [details]
Working sxc file with formula
Comment 3 Björn Michaelsen 2014-02-15 21:17:43 UTC

*** This bug has been marked as a duplicate of bug 74979 ***