Bug 69498 - EDITING: Promoting/Demoting Bullets/Numbering Levels
Summary: EDITING: Promoting/Demoting Bullets/Numbering Levels
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-17 22:50 UTC by actionmystique
Modified: 2013-12-11 18:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Expected Behaviour (28.39 KB, image/jpeg)
2013-09-17 22:50 UTC, actionmystique
Details

Note You need to log in before you can comment on or make changes to this bug.
Description actionmystique 2013-09-17 22:50:47 UTC
Created attachment 86028 [details]
Expected Behaviour

Problem description: 
The symbols "Arrow to the Right" and "Arrow to the Left" does not promote or demote any level of any kind; they just move the bullet/numbering to the right or to the left.


              
Operating System: Windows 7
Version: 4.1.1.2 release
Comment 1 Dominique Boutry 2013-10-18 10:05:37 UTC
Tentative explanation :

There are 2 kinds of numbering :
- for the document outline ; labelled "Outline and numbering" (not certified, I use a French version...)
- in the styles, labelled "numerotation style" (along with "bulleted" style)
You are supposed to avoid using both on the same component to get a desired effect.

THe first usage deal with the document outline :
- set by the "Tools > Chapter numbering"
- affect only so-called "headers" comonents (the content of a chapter may be moved along with its header, it never see its style automaticaly changed due to outline manipulations)
- interaction with paragraph style : a reminder of level and style in the "Outline & numbering" tab (you should always keep the value to "outline numbering", i.e. avoid direct formatting on headers in that tab ; you can use "outline level" to create your own supplementary header components, taken into account by the navigator)
- the right place to manage the outline is the navigator ; it shows the appropriate promote/demote buttons

The buttons you show in attachment 86028 [details] deal with the second usage. This second usage is characterized by :
- lay-out limited to the component and all immediatly following components with the same list style,
- Using this buttons on headers results in an inextricable state

To summarize, the symbols "Arrow to the Right" and "Arrow to the Left" you showed promote or demote an internal local level within the local "numbered/bulleted" list, switching appropriatly initial number/bullet (the default list styles with bullets keep the same bullet for each level, resulting to an impression that it is a simple horizontal move.

In my opinion, rather complex schema but Not A Bug.
Comment 2 Jean-Baptiste Faure 2013-11-17 20:31:17 UTC
@reporter:
Please, could you describe step by step what you do to experience this behavior?
Without clear and detailed description and context, it is impossible to investigate further.

Best regards. JBF
Comment 3 Dominique Boutry 2013-12-07 11:49:26 UTC
(In reply to comment #2)
> @reporter:
> Please, could you describe step by step what you do to experience this
> behavior?
> Without clear and detailed description and context, it is impossible to
> investigate further.
> 
> Best regards. JBF

The remark above is general and relevant.
Regarding the present case, I propose to close it in RESOLVED-NOTABUG.
Comment 4 Jean-Baptiste Faure 2013-12-11 18:45:22 UTC
(In reply to comment #3)
> [...]
> Regarding the present case, I propose to close it in RESOLVED-NOTABUG.

I agree.

Best regards. JBF