Bug 69500 - CONFIGURATION: Toolbars not saved in document
Summary: CONFIGURATION: Toolbars not saved in document
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other All
: high major
Assignee: Andras Timar
URL:
Whiteboard: BSA target:4.2.0 target:4.1.4
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2013-09-17 23:09 UTC by Olivier Hallot
Modified: 2015-12-17 07:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A test file with 3 little macros, which must be linked in a new toolbar saved in the document. (25.45 KB, application/vnd.oasis.opendocument.text)
2013-09-17 23:09 UTC, Olivier Hallot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2013-09-17 23:09:12 UTC
Created attachment 86030 [details]
A test file with 3 little macros, which must be linked in a new toolbar saved in the document.

Problem description: 

On creating a new toolbar with buttons refereing to macros in a libreary, the toolbar is lost after saving and reopening the file.


Steps to reproduce:
1. Create a new file, save with a name
2. Create a simple macro in a new library, inside the file.
3. Create a new toolbar and link to the macros of the file (Customization-> Toolbar -> New...)
4). Test that macro is invoked by toolbar. It should 
4. Save document, close, open again.

Current behavior:

Toolbar is lost after reopening the file

Expected behavior:

Toolbar should always be available with the document. 

It look like the toolbar is not saved in the ODT file
              
Operating System: All
Version: 4.1.1.2 release
Comment 1 Olivier Hallot 2013-09-17 23:24:18 UTC
Tested in 4.0.5 and it works.

So the bug blossomed in 4.1 branch
Comment 2 Jorendc 2013-10-13 22:39:11 UTC
Thanks for your clear bug report Olivier :)!

Reproducible, tested using Mac OSX 10.8.5 with LibreOffice 4.1.2.3.

(In reply to comment #1)
> Tested in 4.0.5 and it works.
> 
> So the bug blossomed in 4.1 branch

So a regression -> marking as such. (not able to test right now).

Kind regards,
Joren
Comment 3 Tibor Kovács 2013-11-17 07:50:28 UTC
I can not modify my custom toolbars in my Calc documents (created in LO3.6.4).
I can not delete, or add any items for them, because LO4.1.3.2 can not save the changes into the file.

This function works fine in AOO4.0.1.
Comment 4 Commit Notification 2013-11-18 12:31:51 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d4fa4c7b386157a7b313bacda0aa0b09ff40f5af

fdo#69500: Revert "fix bug #60700 - de-crutify ODF files"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2013-11-21 10:33:28 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=42f4261f835ad4ff7d98126cc7fb3be84dc76126&h=libreoffice-4-1

fdo#69500: Revert "fix bug #60700 - de-crutify ODF files"


It will be available in LibreOffice 4.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Robinson Tryon (qubit) 2015-12-17 07:31:55 UTC
Migrating Whiteboard tags to Keywords: (bibisectrequest)
[NinjaEdit]