Bug 69517 - LibreOfficeDev-4.2.0.0 (Win-x86@39) cannot start under Windows XP
Summary: LibreOfficeDev-4.2.0.0 (Win-x86@39) cannot start under Windows XP
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2013-09-18 09:50 UTC by ape
Modified: 2013-10-04 15:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ape 2013-09-18 09:50:03 UTC
Windows XP 64-bit Edition
Win-x86@39/master~2013-09-18_08.18.05_LibreOfficeDev_4.2.0.0.alpha0_Win_x86.msi:
 Vendor=tinderbox
 MsiProductVersion=4.2.0.0.alpha0
 ProductCode={E814501C-32CE-4958-A93A-24AFB27F3364}
 buildid=125769a4a15cf6f4b9ef9d0e757ac55bd9e26509
--
LibreOfficeDev-4.2.0.0 cannot start.
Error message:
 soffice.exe - Entry Point Not Found
  The procedure entry point GetTickCount64 could not be located in the dynamic link library KERNEL32.dll.
--
 It turns out that in 32-bit library is searching for 64-bit entry point procedure.
 This is a critical error, because the new ‘Win-x86@6-debug’ daily builds don't publish from September 6.
Comment 1 Maxim Monastirsky 2013-09-19 19:38:29 UTC
GetTickCount64 function available only in Windows Vista and up. Source: http://msdn.microsoft.com/en-us/library/windows/apps/ms724411(v=vs.85).aspx
Comment 2 ape 2013-09-20 06:31:22 UTC
(In reply to comment #1)
> GetTickCount64 function available only in Windows Vista and up.
--
Thanks,
 But there is no information on the exclusion of Windows XP from the list of supported operating systems. Therefore, I confirm the status "critical" for this bug.
 Most likely the error is caused by building a package on a computer with Windows-7/8.
Comment 3 Maxim Monastirsky 2013-09-20 07:35:51 UTC
(In reply to comment #2)
>  But there is no information on the exclusion of Windows XP from the list of
> supported operating systems. Therefore, I confirm the status "critical" for
> this bug.
From what I understand, the list of supported platforms is for released versions, not for daily builds.

>  Most likely the error is caused by building a package on a computer with
> Windows-7/8.
Probably It was caused by using Windows SDK 8, which doesn't support building for WinXP. See http://msdn.microsoft.com/en-us/library/windows/desktop/hh852363.aspx#Requirements
Comment 4 ape 2013-09-20 09:55:38 UTC
(In reply to comment #3)
> From what I understand, the list of supported platforms is for released
> versions, not for daily builds.
--

Maxim,
 the question about the operating system arises whenever there is no log assembly. The Win-x86@39 does not contain such the file (build-name_build_info.txt). I have to guess what is the reason for the failure start.
--
ape
Comment 5 Maxim Monastirsky 2013-09-20 10:58:55 UTC
(In reply to comment #4)
> The Win-x86@39 does not contain such the file (build-name_build_info.txt).
Something like http://tinderbox.libreoffice.org/cgi-bin/gunzip.cgi?tree=MASTER&full-log=1379673601.13747?
Comment 6 Maxim Monastirsky 2013-09-20 11:17:19 UTC
(In reply to comment #5)
> http://tinderbox.libreoffice.org/cgi-bin/gunzip.cgi?tree=MASTER&full-
> log=1379673601.13747?
As you can see from that log (line 34), it uses Visual C++ 2012, which comes with SDK 8.0 according to http://blogs.msdn.com/b/chuckw/archive/2012/08/15/visual-studio-2012-and-windows-8-0-sdk-rtm-are-now-available.aspx.

Also according to http://blogs.msdn.com/b/vcblog/archive/2012/10/08/10357555.aspx, Visual Studio 2012 Update 1 contains a repacked version of previous SDK (7.1) which can be used with VC 2012 to target WinXP.
Comment 7 ape 2013-09-20 14:55:23 UTC
Maxim, thank You.

Kendy…
History and Memory suggests to me that NT-5.1\2 did not have a chance of success. We'll have to wait for the beta.

ape
Comment 8 ape 2013-09-22 02:44:00 UTC
@Maxim, Kendy:

Sorry, that's my confusion.
 I found the Assembly log file, which specifies to use MSVCR-2012u1. The LibreOfficeDev-4.2.0.0_ Win-x86@39 runs on Windows XP 32\64-bit after installing MSVCR-2012 update3.
 So is FIXED.
--
ape
Comment 9 V Stuart Foote 2013-10-02 15:46:11 UTC
@Kendy,

A bit late, but got around today to doing an /A administrative install of TB 39 Windows build of master onto a 32-bit Windows XP sp3

Version: 4.2.0.0.alpha0+
Build ID: 0d0d3a0540dad2d0f417e21df1183dfc33964357
TinderBox: Win-x86@39, Branch:master, Time: 2013-09-30_23:58:26

I'd installed the Microsoft Visual C++ 2012 Redistributable (x86), 11.0.60610.1, signed June 10 2013.

But on launch I am receiving error:

soffice.exe - Entry Point Not Found

The procedure entry point GetTickCount64 could not be located in the dynamic link library KERNEL32.dll


Looks to be the same issue as OP, but on 32-bit XP. So question if the TB 39 build system has the Visual Studio Update 3 apparently needed to support Windows XP builds, and if the _WIN32_WINNT declaration is set correctly?  Should we be able to run this on 32-bit Windows XP? If so what C++ runtime is needed if not the Visual C++ Redistributable for Visual Studio 2012 Update 3 available at:

http://www.microsoft.com/en-us/download/details.aspx?id=30679
Comment 10 Tor Lillqvist 2013-10-02 18:11:17 UTC
Is it really worth it to have a bug open for something that is not an error in the source code, and not an error in an official build, but just a suboptimal configuration of a tinderbox? Where do we promise that tinderbox builds would be usable on XP?
Comment 11 V Stuart Foote 2013-10-02 18:21:11 UTC
Markus provides a hint on building in a note to the Dev list.

http://nabble.documentfoundation.org/Making-VS2012-builds-usable-with-XP-tc4076077.html

need to build with "--with-windows-sdk=7.1A" flag

Looking at the full build logs suggests that is not yet happening for the TB 39 builds of master.
Comment 12 V Stuart Foote 2013-10-02 18:30:06 UTC
(In reply to comment #10)
> Is it really worth it to have a bug open for something that is not an error
> in the source code, and not an error in an official build, but just a
> suboptimal configuration of a tinderbox?

Sorry but if the "fix" is as simple as a compiler flag (or a compiler version upgrade), then tracking the issue in BZ certainly is appropriate and in the best interest of the project. This is especially true for the Windows and OS X builds where substantive QA and UX feedback will only occur if the project infrastructure provides functional TB builds for testing.

While it is common place for folks on Linux to roll their own--not at all so for the Windows or OS X user community.
Comment 13 Pedro 2013-10-02 21:51:50 UTC
(In reply to comment #10)
> Where do we promise that tinderbox
> builds would be usable on XP?

Nowhere. But it is frequently asked to QA people to start testing Master builds as soon as possible in order to report bugs early in development.

Of course if TDF prefers to ignore Windows XP or exclude it from early testing it just needs to say so.
Comment 14 ape 2013-10-03 09:09:53 UTC
@: Pedro; V Stuart Foote

  I changed the status to "fixed" because the TDF has not defined any member of the Community (for example, Luboš or Fridrich) having a computer with the necessary configuration, as one of the builders of the MSI package.
  I think that we have no right to demand that the volunteers replaced programs on their computers in order to satisfy our interests.

Best regards, ape
Comment 15 V Stuart Foote 2013-10-03 12:49:11 UTC
@ape,  you neglected to actually set the issue to fixed.

But that aside, TB 39 is TDF owned hardware issued/loaned to Kendy for TinderBox build needs. Maintaining it is a volunteer effort as always--which he's done with finesse. 

Also, a read of the TB Status page and logs ( http://tinderbox.libreoffice.org/MASTER/status.html ) shows today's posted 2013-10-03 7:14 TB 39 build was not built with the "--with-windows-sdk=7.1A" compile flag;  but the 2013-10-03 10:51 build was. Meaning that later today or tomorrow at the latest we will know if the issue has been fully resolved with a working build for 32-bit Windows XP.

When available we can check out the build and then correctly close this incident.

Stuart
Comment 16 V Stuart Foote 2013-10-04 12:38:13 UTC
On Windows XP sp3 32-bit as guest OS in VMWare Workstation

Version: 4.2.0.0.alpha0+
Build ID: 050248fea53adb6a14b649c5f84dd69a8faff997
TinderBox: Win-x86@39, Branch:master, Time: 2013-10-04_08:16:05

This TB 39 build of master installs and runs without issue.

Setting Resolved Fixed.
Comment 17 ape 2013-10-04 15:41:26 UTC
LibO-Dev_4.2.0.0.alpha0+ (ID: 050248fea53adb6a14b649c5f84dd69a8faff997, TinderBox: Win-x86@39, Time: 2013-10-04_08:16:05) started on Windows XP 64-bit sp2 (last update).