Bug Hunting Session
Bug 69586 - UI SIDEBAR: when image anchored as character wrap content panel displays corrupted icons
Summary: UI SIDEBAR: when image anchored as character wrap content panel displays corr...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-Properties-Wrap
  Show dependency treegraph
 
Reported: 2013-09-19 18:31 UTC by Arnaud Versini
Modified: 2016-10-24 17:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sidebar UI (33.98 KB, image/png)
2013-09-19 18:31 UTC, Arnaud Versini
Details
Weird sidebar (33.98 KB, image/png)
2013-09-19 18:33 UTC, Arnaud Versini
Details
Good looking sidebar (33.96 KB, image/png)
2013-09-19 18:38 UTC, Arnaud Versini
Details
Sidbar wrap icons from writer in lo4.3.0.1 (99.86 KB, image/jpeg)
2014-06-30 12:57 UTC, V Stuart Foote
Details
Sidbar wrap icons from writer in lodev 4.4.0alpha+ 20140626 (104.00 KB, image/jpeg)
2014-06-30 12:59 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Arnaud Versini 2013-09-19 18:31:50 UTC
Created attachment 86155 [details]
Sidebar UI

Steps to reproduce :

Activate the sidebar
Insert an image
Set anchoring to character
Select the image, go to properties in the Wrap group

Expected behavior :
Understandable desactivated tools or no wrap group

Result :
Useless and non understandable icons
Comment 1 Arnaud Versini 2013-09-19 18:33:16 UTC
Created attachment 86156 [details]
Weird sidebar
Comment 2 Arnaud Versini 2013-09-19 18:38:21 UTC
Created attachment 86157 [details]
Good looking sidebar
Comment 3 Joel Madero 2013-09-19 18:40:50 UTC
Probably not a big deal but confirmed.

Trivial - seems unlikely this is having any affect on workflow or very little if it does


Thanks for the report and attachments :)
Comment 4 Adolfo Jayme 2013-09-21 22:20:58 UTC
The icons look weird as a result of LibreOffice’s automatic “tinting” of disabled toolbar items, which doesn’t work well.
Comment 5 V Stuart Foote 2014-06-13 18:04:01 UTC
Not sure when this was corrected, but setting resolved works for me 
on Windows 7 sp1, 64-bit en-US with
Version: 4.3.0.0.beta2
Build ID: a06aa316117a6ff0f05c697c82831c227812d810

Please reopen if still an issue.
Comment 6 Adolfo Jayme 2014-06-30 08:28:37 UTC
@V Stuart: Not sure why you closed this. It is still reproducible in 4.3.
Comment 7 V Stuart Foote 2014-06-30 12:57:34 UTC
Created attachment 102014 [details]
Sidbar wrap icons from writer in lo4.3.0.1

Adolfo, *,

In Windows 7 sp1, 64-bit en-US with writer and inserted image
Version: 4.3.0.1 with sifr icons
Build ID: 67f5430184326974072b65403ef1d9d934fc4481

also in a current build of master
Version: 4.4.0.0.alpha0+ with tango icons
Build ID: a532e2bba1a2400925e5930d20ab6fd573171085
TinderBox: Win-x86@39, Branch:master, Time: 2014-06-26_00:23:42

in both builds with Sidebar open, and an image selected, icons in the Wrap panel appear correct.

So, appears to be correct on Windows builds. Your OS?
Comment 8 V Stuart Foote 2014-06-30 12:59:20 UTC
Created attachment 102015 [details]
Sidbar wrap icons from writer in lodev 4.4.0alpha+ 20140626

also seems correct in current master on Windows 7 sp1, 64-bit.
Comment 9 V Stuart Foote 2014-06-30 13:13:22 UTC
Looked at this a bit more.

On both, the "weirdness" only occurs when the inserted image is re-anchored "as character". If anchored to page, to paragraph or to character it retains the correct wrap icons.

Only if anchored "as character" the Wrap panel deactivates (correctly) but shifts icons.
Comment 10 V Stuart Foote 2014-11-04 19:10:04 UTC
QA housekeeping, setting back to NEW -- apparently valid, but never taken by a Dev.
Comment 11 Gordo 2015-06-07 12:12:57 UTC
The shifting icons are no longer an issue.  Only in Tango do the icons have the horizontal lines missing when they are disabled.

Windows Vista 64
Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Comment 12 V Stuart Foote 2015-06-07 13:00:34 UTC
Icon corruption remains and issue for 5.1/master on Windows 7 sp1, 64-bit en-US with

Version: 5.1.0.0.alpha1+
Build ID: 21a6b99748db8a970ef7dc90d40e07901135b89a
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-03_05:45:39
Locale: en-US (en_US)

But only affects the "Tango" and "Tango (automatic)" icon set. Selecting Breeze, Galaxy, Oxygen or Sifr shows correctly formed "disabled" wrap setting icons.
Comment 13 QA Administrators 2016-09-20 09:45:53 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.1.5 or 5.2.1  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20160920