Bug 69644 - FILEOPEN: Writer opens DOCX with cells already deleted from table
Summary: FILEOPEN: Writer opens DOCX with cells already deleted from table
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.2.0
Keywords:
: 69657 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-09-21 14:37 UTC by Adam CloudOn
Modified: 2020-08-31 05:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
DOCX containing a table with deleted cells (19.89 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-09-21 14:37 UTC, Adam CloudOn
Details
DOCX exported by LO with no deleted cells (5.37 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-09-21 14:38 UTC, Adam CloudOn
Details
Screenshot comparison between original DOCX and exported DOCX (56.47 KB, image/png)
2013-09-21 14:38 UTC, Adam CloudOn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam CloudOn 2013-09-21 14:37:41 UTC
Created attachment 86247 [details]
DOCX containing a table with deleted cells

Problem description: 
When loading the attached DOCX into LO and exporting back to DOCX - the deleted cells in the original DOCX's table become 'merged' cells in the exported DOCX.

Steps to reproduce:
1. Load the attached DOCX in LO
2. Save as NEW.DOCX
3. Load the NEW.DOCX in Word
4. Table contains no deleted cells

Current behavior:
LO exports the table with no deleted cells (deleted cells are turned to merged cells in the table).

Expected behavior:
LO should export the table with the deleted cells.
              
Operating System: All
Version: 4.2.0.0.alpha0+ Master
Comment 1 Adam CloudOn 2013-09-21 14:38:19 UTC
Created attachment 86248 [details]
DOCX exported by LO with no deleted cells
Comment 2 Adam CloudOn 2013-09-21 14:38:55 UTC
Created attachment 86249 [details]
Screenshot comparison between original DOCX and exported DOCX
Comment 3 Thomas van der Meulen 2013-09-29 07:09:27 UTC
Thank you for your bug report,
I can reproduce this bug running LibreOffice: 
Version: 4.2.0.0.alpha0+
Build ID: 164b6ce7b27c0a9ec19019e7b078b9f8f382007d
TinderBox: Win-x86@39, Branch:master, Time: 2013-09-28_16:39:4
And Mircosoft Word 2007
Comment 4 Commit Notification 2013-11-05 15:34:41 UTC
Adam Co committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=57c54792781cc9befe3a65a97b37fa85f89da0ae

fdo#69644 - fix docx export of wrong number and width of columns



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Timur 2014-12-02 08:18:43 UTC
This doesn't seem fixed, tested with LO 4.4.0.
Also not Filesave problem, but rather Fileopen problem, because LO opens wrong, as shown in the screenshot.
Comment 6 Timur 2015-08-17 11:03:44 UTC
I change title from "FILESAVE: DOCX Export loses deleted cells from table (table now has no deleted cells)" to "FILEOPEN: Writer opens DOCX with cells already deleted from table".
Comment 7 QA Administrators 2016-09-20 10:26:18 UTC Comment hidden (obsolete)
Comment 8 Telesto 2016-12-03 17:18:13 UTC
Tested with:
Version: 5.4.0.0.alpha0+
Build ID: 33f5bc54aaa7fe7aa9335726e30f9c349155e04d
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-12-01_23:21:05
Locale: nl-NL (nl_NL); Calc: CL
Comment 9 Timur 2017-10-03 15:52:26 UTC
*** Bug 69657 has been marked as a duplicate of this bug. ***