Download it now!
Bug 69843 - One cannot enter a whole column as a range
Summary: One cannot enter a whole column as a range
Status: RESOLVED DUPLICATE of bug 44419
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.2.2 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-26 10:25 UTC by kaesezeh
Modified: 2013-11-09 16:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kaesezeh 2013-09-26 10:25:07 UTC
This is the problem:

- enter some numbers into cells A1:A5
- go into C1 and enter
=SUM(

- and then try to make click on the "A" in the column header, which you can't but which used to be possible.

This is quite annoying because it means if you want to add more values into A6:A10 and have the sum in C1 updated, you must enter a specific larger range into C1 - you can't just specify 'the whole column however far down it is', which would be the intuitive thing to do.

Even more counterintuitively: if you create a Pivot table by

- highlighting multiple columns by clicking on the column headers
- then clicking: Data: Pivot Table: Create

then the Select Source window says "Highlight Selection", which is after all the whole column, but then the Pivot table data range in the next window is really only until the bottommost data point (say, C22) so when you add new data and refresh the Pivot Table, new stuff one may have entered is not included even though I created the Pivot table from the selection, which was the whole column.
Comment 1 m.a.riosv 2013-09-26 22:27:41 UTC
Hi kaesezeh, thanks for reporting.

It is how it works, not a bug.

If you like it will be implemented change the importance from normal to enhancement, and change the title in accordance. If you do so I will change the status to new.
Comment 2 kaesezeh 2013-09-27 11:27:13 UTC
I am not sure I understand how this is not a bug. The user tell Calc to use a particular range for a Pivot table, which happens to be range involving whole columns, but Calc doesn't use that range but downsizes it on its own - how is that not a bug?
Comment 3 m.a.riosv 2013-09-27 14:10:30 UTC
Maybe I am in an error, but I think it is designed to work in this way.
Comment 4 kaesezeh 2013-10-02 17:41:10 UTC
I agree that it is designed to work that way, but the design is faulty: if the user specifies a range when setting up the pivot table, then the user wants THAT range to be used -- he does not want Calc ignoring the user's range selection and generate one on its own (without even so much as a warning, mind you) that is hundreds of thousands of cells smaller!
Comment 5 m.a.riosv 2013-10-03 00:41:13 UTC
Maybe a bug for you but not for others.

And I think it is possible to modify and set up the range editing the PT layout.

Comment #1
Comment 6 ign_christian 2013-11-08 09:23:40 UTC
Hello Kaesezeh, I guess what you wanted has been requested in Bug 44419. Please mark this as duplicate if you think so.
Comment 7 kaesezeh 2013-11-09 16:18:10 UTC

*** This bug has been marked as a duplicate of bug 44419 ***