Bug Hunting Session
Bug 69968 - FORMATTING font width wrong in impress for long lines
Summary: FORMATTING font width wrong in impress for long lines
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-09-30 14:56 UTC by Piotr Luszczek
Modified: 2015-07-19 23:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
wrong text width in two identical lines which are part of one long line (52.17 KB, image/png)
2013-09-30 14:56 UTC, Piotr Luszczek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Luszczek 2013-09-30 14:56:58 UTC
Created attachment 86852 [details]
wrong text width in two identical lines which are part of one long line

Problem description: cursor position is wrong for long lines in LibreOffice Impress 4.1.2 on Mac OS X Mtn. Lion

Steps to reproduce:
1. Create empty Presentation in Impress.
2. Change Layout to "Title, Content".
3. In the "Content" frame start typing a long sentence until the line gets broken and continue typing. Preferably, you should type the same thing as before so you see two lines (one above the other) with the exact same text.
4. The cursor position and text width in the line above is wrong.
5. The displayed fonts are narrower than the selection made by text cursor.
6. Selecting text in the first line does not correspond to the letters.
It is the worst at the end of the first line. Text cursor is in the middle
of letters.


Expected behavior: text cursor should be on either side of a letter. Selection
should not cut letters in half.



Workaround:
1. Go to the end of the first line where the line is broken.
2. Insert manual line break (Shift+Enter).
3. If both lines contain the same text, they should be equal size now

I have this bug even if:
1. I change the sans serif font (Arial, Cambria, Candara, Corbel, Helvetica, ...)
2. I change to mono-space font (Andale Mono, Courier, Anonymous Pro, ...)
3. I wipe my configuration files from ~/Library
4. Change LO from 4.0 to 4.1.2 and any version in between


The bug even occurs in LO Formula editor: as you type in the formula text in
the bottom input text area, the fixed-width fonts get wrong width for long lines. Inserting manual page break (Shift-Enter) fixes the problem.

I don't have any fonts (Libertine, Source Pro, ...) installed by LO
(I didn't remove any fonts after LO installation).
The only fonts I use are from Apple or Microsoft or it's Anonymous Pro.

There is a related bug (# 69879):

https://bugs.freedesktop.org/show_bug.cgi?id=69879
Comment 1 Vossman 2014-03-19 15:55:06 UTC
This appears to be a problem with only OpenType fonts, I switched to a TrueType font and no longer experience this problem. Can someone confirm?
Comment 2 Piotr Luszczek 2014-03-19 18:42:11 UTC
(In reply to comment #1)
> This appears to be a problem with only OpenType fonts, I switched to a
> TrueType font and no longer experience this problem. Can someone confirm?

I just tested it again with LibreOffice Impress 4.2 on Mac OS X Mtn. Lion.
The problem is for both TTF (Constantia, Helvetica, DejaVu Sans) and OTF (Apple Gothic Neo, ...) fonts.

The other suites must be using something different. Apache OOo 4.1 Beta puts the cursor in the right place. And so does Neo Office 3.3 which also shows many more variants for a single font (Helvetica Light, Bold, UltraLight, ...). It seems to me that it is unique to LO-specific code. But I don't have experience with the code base.
Comment 3 Vossman 2014-03-19 21:40:14 UTC
OTF fonts are still a problem for me on 4.2.3.1, Mac OS X 10.9
Comment 4 jl.lesieur 2014-06-09 08:30:37 UTC
I can reproduce this with 4.2.4.2 on mac os x mountain lion with font "Arial"
Comment 5 QA Administrators 2015-07-18 17:43:25 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-07-18
Comment 6 Piotr Luszczek 2015-07-19 23:05:46 UTC
This is fixed in 4.4 (I'm using 4.4.4.3 right now on Mac OS X 10.11 El Capitan Beta 3 but 10.10 Yosemite worked just as well)