Bug Hunting Session
Bug 69998 - can't save files with a webdav URL (HTTPS, 502 bad gateway)
Summary: can't save files with a webdav URL (HTTPS, 502 bad gateway)
Status: RESOLVED DUPLICATE of bug 102499
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA needsWebDAV
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-01 12:58 UTC by Vieri
Modified: 2017-10-17 08:23 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
LibreOffice error message (27.70 KB, image/png)
2014-04-24 13:14 UTC, Johnny Haugen Sørgård
Details
Libreoffice 4.2.6.3 + webdav (74.77 KB, image/png)
2014-09-20 20:53 UTC, l0co
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vieri 2013-10-01 12:58:21 UTC
Problem description: 
LibreOffice can open a webdav url (odt file) but can't save it (same name/location).

Steps to reproduce:
1. open file from console, eg. soffice.exe -o https://myserver.com/webdavdir/file.odt
2. document is opened correctly (can modify it)
3. press the save button or File->Save (not SaveAs)

Current behavior:

error: 502 Bad Gateway

Expected behavior:

should save remote file without error messages
              
Operating System: Windows 7
Version: 4.1.1.2 release
Comment 1 l0co 2013-11-13 12:23:50 UTC
For Libre Office 4.1.3.2 there's more regression, we even can't open proper https:// webdav link. Libre Office displays only 400 Bad Request. The link is 100% appropriate and can be opened otherwise. The link contains %20 chars and this might be a problem about which I read elsewhere.
Comment 2 Johnny Haugen Sørgård 2014-04-24 13:14:44 UTC
Created attachment 97900 [details]
LibreOffice error message
Comment 3 Johnny Haugen Sørgård 2014-04-24 13:15:38 UTC
Probably same issue with IBM Domino server with webdav. Happens  when document is read from server over https.

Attached is errormessage from LibreOffice when opening document from webdavs
Comment 4 l0co 2014-09-20 20:53:15 UTC
Created attachment 106586 [details]
Libreoffice 4.2.6.3 + webdav

In 4.2.3.6 there's still more regression, since now I even cannot open standard http link, which works for wget and openoffice 3.2.1 without any problems.
Comment 5 tommy27 2014-11-26 20:15:18 UTC
it seems it has been confirmed by other users in 4.2.6.3

please retest with 4.3.4.1 and give feedback
Comment 6 QA Administrators 2017-03-06 15:52:51 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2017-10-17 08:23:20 UTC
I guess this can be closed as duplicate of bug 102499

*** This bug has been marked as a duplicate of bug 102499 ***