Download it now!
Bug 70018 - FORMATTING: very bad formatting: Copying table into section with two columns
Summary: FORMATTING: very bad formatting: Copying table into section with two columns
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.5.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-01 23:35 UTC by Chris
Modified: 2015-06-21 13:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of bad formatted section (8.92 KB, application/vnd.oasis.opendocument.text)
2013-10-01 23:35 UTC, Chris
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris 2013-10-01 23:35:06 UTC
Created attachment 86940 [details]
Example of bad formatted section

Problem description: 

Steps to reproduce:
1. Create new writer document
2. Click on Insert>Section>Columns, choose 2 columns and click on Insert
3. Insert any table after the section. (Click on Table>Insert>Table and insert)
4. Copy the table
5. Paste into the section

Current behavior:
The sections size grows to the next page and the table is duplicated twice. The rest of page one is empty and can't be edited.

Expected behavior:
no strange formatting
Operating System: Windows 7
Version: 4.0.5.2 release
Comment 1 Dominique Boutry 2013-10-11 08:08:27 UTC
LO has rules to govern different situations :
1/ where to split horizontally a zone of content, in order to break correctly between pages and sections ; in the present case, the 2x2 table can be broken between the 2 lines, thanks to the settings in the table properties,
2/ when to split horizontally ; general rule is : if there is not enough place until the end of the page or until the end of the section column (without setting "columns of equalized length") in page ; if the split gives the best equalization of all the section columns of the page (with setting "columns of equalized length"),
3/ where to position the parts, in case of an effective split : at the top of the next page or section
4/ what to do if a part of a splitted content overflows also at its new place in top of the page/section : an abrupt trimming at the bottom.

In the case of the present Bugzilla file, we can see the application of some of the above rules (suggested modification for a better understanding : fill the 4 cells with a/b/c/d before copying) :
a/ the first positionning of the pasted material seems computed with the initial length of the section columns ; just before the "paste", the table doesn't fit in the current 1st column height ; even its first row alone doesn't fit too. This results in nothing in page 1/column 1, the first row abruptly trimmed at the top of the page 1/column 2, the impossibility to insert any text at the bottom of the page 1/columns 1 and 2, an unexpected empty row at the beginning of page 2/column 1 the and the remaining of the table in page 2/column 2,
b/ however, after the above positionning, LO notes that it has made a page break, so it adjusts the lenght of the page 1/columns 1 and 2 to the page length : this results to the incomprehensible final lay-out,
c/ note that a small adjusment of page lengh resets all contents to its correct place.

What is patently false :
- the initial placement made before the application of rules to lenghten sections (I guess that the correction is tricky, with a kind of iterative criteria "where is the better equalisation between the different possible splitting points, knowing that the section lengh may vary within limits"),
- the insertion of the empty row at the top of page 2/section 1.
Comment 2 Dominique Boutry 2014-03-30 08:05:03 UTC
My bug analysis is still valid for LibO 4.2.2.1.
Comment 3 Joel Madero 2015-05-02 15:44:05 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 4 Buovjaga 2015-06-21 13:01:46 UTC
(In reply to Chris from comment #0)
> Created attachment 86940 [details]
> Example of bad formatted section
> 
> Problem description: 
> 
> Steps to reproduce:
> 1. Create new writer document
> 2. Click on Insert>Section>Columns, choose 2 columns and click on Insert
> 3. Insert any table after the section. (Click on Table>Insert>Table and
> insert)
> 4. Copy the table
> 5. Paste into the section
> 
> Current behavior:
> The sections size grows to the next page and the table is duplicated twice.
> The rest of page one is empty and can't be edited.

Not reproduced from scratch and the attached document does not look like the description. Closing as WFM. Set back to NEW, if there is still a problem.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)