Download it now!
Bug 70043 - soffice.bin - Entry Point Not Found
Summary: soffice.bin - Entry Point Not Found
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2013-10-02 17:47 UTC by Dan Alexson
Modified: 2015-12-15 10:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Zipped Screenshots (242.02 KB, application/zip)
2013-10-02 17:47 UTC, Dan Alexson
Details
when I try to start openOffice, only this dialog comes up (15.88 KB, image/png)
2014-08-25 14:54 UTC, Andrej
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Alexson 2013-10-02 17:47:47 UTC
Created attachment 86979 [details]
Zipped Screenshots

Problem description:

"soffice.bin - Entry Point Not Found
The procedure entry point initRegistry_Api could not be located in the dynamic link library reg.dll." error message on opening of any of the LibreOffice apps.

Windows 7 SP1, JRE 7u40 and LibreOffice 4.1.1.2

Steps to reproduce:
1. Try to open any of the LibreOffice apps

Current behavior:

Trying to open any of the LibreOffice apps results in the above mentioned error message, after which, LibreOffice stops working.

Expected behavior:

Opened LibreOffice app loads and works as expected.
Operating System: Windows 7
Version: 4.1.1.2 release
Last worked in: 4.1.0.4 release
Comment 1 Robinson Tryon (qubit) 2013-10-16 04:09:58 UTC
Change 'regression' -> 'PossibleRegression' until we have independent confirmation.
Comment 2 Robinson Tryon (qubit) 2013-10-16 04:23:15 UTC
Hi Dan,

Thanks for the bug report. I've tried doing a little digging, but haven't found any other reports that match yours.

Please try the latest build of LibreOffice (4.1.2+) and let us know if you're still seeing the same error:
https://www.libreoffice.org/download/

Thanks!

---

Tor: Is reg.dll something that we build or something provided by Windows? Any idea what's going wrong here?
Comment 3 Dan Alexson 2013-10-20 16:26:04 UTC
Hi!

A few days ago I've upgraded my OS to Windows 8. I've installed the same version of JRE (7u40) and LibreOffice(4.1), and there it was working. Unfortunately ATM I can't go back to Windows 7 and check if the problem is fixed in the new version.

And if there are no other similar reports then I suppose this error message will remain a mystery... Unless, of course, the origins of the dll file are determined, together with the ways of preventing such (even theoretical) malfunctions.

Thanks for the help. LibreOffice is the best :)
Comment 4 Dan Alexson 2013-10-20 16:39:08 UTC
EDIT: LibreOffice 4.1.1.2, I meant.
Comment 5 QA Administrators 2014-06-01 21:30:13 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 6 QA Administrators 2014-07-08 17:17:58 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO
Comment 7 Andrej 2014-08-25 14:53:17 UTC
Hello
No matter what LibreOffice I try to open (writer,calc,impress), it gives me the same window (as picture "soffice.bin - Entry Point Not Found" shows).

I am afraid that I do not know how you could reproduce the problem. I am using LibreOffice for years (before OpenOffice) and I newer have this issue before. I do not know how to open the LibreOffice at all now. Yesterday all worked fine, had the computer in hibernate at night, as many times before, but now, LibreOffice wont start. Will let you know, if it will, once I will restart the computer. I am using Windows ultimate 64bit. LibreOffice version 4.2.5.2. Have not install or did anything else of the sort with the computer lately.


This is the text on the dialog:
---------------------------
soffice.bin - Entry Point Not Found
---------------------------
The procedure entry point ?IsRect@Wallpaper@@QBEEXZ could not be located in the dynamic link library vcllo.dll. 
---------------------------
OK   
---------------------------
Comment 8 Andrej 2014-08-25 14:54:57 UTC
Created attachment 105241 [details]
when I try to start openOffice, only this dialog comes up
Comment 9 Andrej 2014-08-25 14:56:05 UTC
I meant "when I try to start LibreOffice, only this dialog comes up" in previous comment, not "...openOffice..."
Comment 10 Andrej 2014-08-25 18:17:53 UTC
I did not yet restarted computer, but 3 hours later LibreOffice works again as nothing has happened.
Comment 11 tommy27 2014-10-17 10:15:13 UTC
so is the bug still happening with current LibO releases?
Comment 12 Andrej 2014-10-17 11:27:18 UTC
I am not experience this kind of issues any more.
Comment 13 tommy27 2014-10-17 11:31:04 UTC
Ok. RESOLVED WORKSFORME.

@Dan Alexson
feel free to revert if you have different results
Comment 14 Robinson Tryon (qubit) 2015-12-15 10:53:38 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]