Download it now!
Bug 70075 - FILEOPEN: FILEOPEN: DOCX Import of vertical text-box imports wrong vertical alignment of text inside text-box
Summary: FILEOPEN: FILEOPEN: DOCX Import of vertical text-box imports wrong vertical a...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:docx
Depends on:
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2013-10-03 14:00 UTC by Adam CloudOn
Modified: 2019-10-03 14:53 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
DOCX containing vertical text-box with text aligned to the middle (23.22 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-10-03 14:00 UTC, Adam CloudOn
Details
Screenshot comparison between MS Word and LibreOffice (80.59 KB, image/png)
2013-10-03 14:30 UTC, Adam CloudOn
Details
comparison docx in MS Word 2007 to LO Writer 5.0.1.2 (162.62 KB, application/vnd.oasis.opendocument.text)
2015-10-14 17:10 UTC, Hannes
Details
Screenshot of the document in Word 2013 and Writer (120.60 KB, image/png)
2019-10-03 14:38 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam CloudOn 2013-10-03 14:00:40 UTC
Created attachment 87031 [details]
DOCX containing vertical text-box with text aligned to the middle

Problem description: 
When you load a DOCX that contains a vertical text-box, LO renders the text inside the text-box to be aligned to the bottom of the text-box, even though in the original DOCX the text is aligned to the middle of the text-box.

Also - there is an extra new-line inside the text-box that should not be there.

Steps to reproduce:
1. Load attached DOCX in LO
2. Text inside vertical text-box is aligned to bottom of text-box and has an extra new-line in it.

Current behavior:
LO imports and renders text at the bottom of the vertical text-box and renders an extra new-line.

Expected behavior:
LO should import and render the text at the middle of the vertical text-box without any extra new-line.
              
Operating System: All
Version: 4.2.0.0.alpha0+ Master
Comment 1 Adam CloudOn 2013-10-03 14:30:00 UTC
Created attachment 87045 [details]
Screenshot comparison between MS Word and LibreOffice
Comment 2 Jorendc 2013-10-07 22:21:22 UTC
New right away
Comment 3 Tamás Zolnai 2014-03-06 14:42:39 UTC
Vertical alignment of Writer text frames was implemented on 4.3.0.0.alpha0+.

But Writer text frame doesn't support this kind of vertical direction (270°) and so the mentioned vertical alignment implementation handles the imported text frame as a horizontal one (import just changes character direction), so text content is placed middle not from right-to-left but from top-to-bottom.
Comment 4 Joel Madero 2015-05-02 15:42:54 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-06-21 10:24:52 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)
Comment 6 Hannes 2015-10-14 17:10:25 UTC
Created attachment 119617 [details]
comparison docx in MS Word 2007 to LO Writer 5.0.1.2
Comment 7 Hannes 2015-10-14 17:13:53 UTC
comment on file posted 2015-10-14 / 17:10:25:
vertical text in text box is displayed incorrectly; the file contains 2 screenshots with 1-line text box and 3-line text box, in MS Word 2007 and after opening in LO writer 5.0.1.2
Comment 8 QA Administrators 2016-11-08 11:04:13 UTC Comment hidden (obsolete)
Comment 9 NISZ LibreOffice Team 2019-10-03 14:38:51 UTC
Created attachment 154737 [details]
Screenshot of the document in Word 2013 and Writer

The example file looks like in Word in current master:

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 8ac95e67872d8834c12adf67f833d92b06dc3d70
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded
Comment 10 NISZ LibreOffice Team 2019-10-03 14:53:43 UTC
Bibisected with bibisect-win64-6.4, this commit fixed the alignment:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=9c945cdbe170104cbacafa2c37babec5210b9ca2

author	Miklos Vajna <vmiklos@collabora.com>	2019-06-06 21:32:07 +0200
committer	Miklos Vajna <vmiklos@collabora.com>	2019-06-07 09:05:08 +0200

sw btlr writing mode: DOCX drawingML import for fly frames