Bug 70154 - Writer crashes just before exiting (on closing) on Windows XP
Summary: Writer crashes just before exiting (on closing) on Windows XP
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected) release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
Whiteboard: BSA
Keywords: haveBacktrace, preBibisect, regression
: 73369 (view as bug list)
Depends on:
Reported: 2013-10-04 21:49 UTC by João Paulo
Modified: 2018-07-23 03:15 UTC (History)
17 users (show)

See Also:
Crash report or crash signature:

OS message explaining the program crash (PT-BR) (10.53 KB, image/png)
2013-10-04 21:49 UTC, João Paulo
backtrace (19.67 KB, text/plain)
2015-02-17 18:26 UTC, Aron Budea
DDE Error Message (17.69 KB, image/jpeg)
2015-02-25 20:51 UTC, libre-bugs-2015

Note You need to log in before you can comment on or make changes to this bug.
Description João Paulo 2013-10-04 21:49:30 UTC
Created attachment 87144 [details]
OS message explaining the program crash (PT-BR)

Problem description: 

Steps to reproduce:
1. Open any document in Writer, or create a new one.
2. Edit the document.
3. Close the document (saving is optional).
4. Exit LibreOffice.

Current behavior:

LibreOffice Writer crashes with the following message (attached image):

DDE Server Window: soffice.bin - Erro de aplicativo

A instrução no "0x01da65e3" fez referência à memória no "0x00000004". A memória não pôde ser "read".

Clique em 'OK' para encerrar o programa

Which can be translated as

DDE Server Window: soffice.bin - Application error
The instruction at "0x01da65e3" referenced memory at "0x00000004". The memory could not be "read".

Click 'OK" to finish the program

There aren't any data corruption on the documents I could be aware of. The crash only appears when exiting. One can open, edit, save and close many documents and the crash only occurs after exiting.

Expected behavior:

No crash at all.
Operating System: Windows XP
Version: release
Last worked in: release
Comment 1 tommy27 2013-10-05 14:21:07 UTC
try upgrading to LibO which was released just yesterday (by the way it's a recommended upgrade).

tell us if you still experience this bug or if this fixes the issue.
Comment 2 João Paulo 2013-10-22 01:43:57 UTC
Hi Tommy, sorry for being late to answer, but unfortunately, even after installing version (compilation ID 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38) the crashes still occur.

I never experienced anyd data loss, only the crashes after (and only after) exiting Writer.
Comment 3 tommy27 2013-10-22 01:50:37 UTC
set status back to UNCONFIRMED

as an additional test try downloading the portbale version here:

and tell us if it crashes the same way as the standard installation version.
Comment 4 João Paulo 2013-10-22 18:43:54 UTC
Hi Tommy, I downloaded the portable version and, after editing some documents, it also crashed with the same message, just the instruction address changed from "0x01da65e3" to "0x01db65ed", i.e., the message can be translated from PT-BR as:

DDE Server Window: soffice.bin - Application error
The instruction at "0x01db65ed" referenced memory at "0x00000004". The memory could not be "read".

Maybe the crash trigger is the PDF export function?
Comment 5 Jean-Baptiste Faure 2013-11-23 22:27:01 UTC
Hi João Paulo,

Did you try to clean your LibreOffice user profile ?

Best regards. JBF
Comment 6 João Paulo 2013-11-28 23:18:27 UTC
Hi Jean, thank you for your suggestion, but when I used the portable version tommy27 suggested me, I was using a new user profile as the portable version use an internal folder for loading and saving user settings.

Even so, I tried with an empty user profile and the result was the same: a crash.
Comment 7 QA Administrators 2014-06-01 21:30:35 UTC Comment hidden (obsolete)
Comment 8 Jean-Baptiste Faure 2014-06-02 04:10:32 UTC
comment #6 answered to question in comment #5. So set status back to unconfirmed.

Best regards. JBF
Comment 9 Yousuf Philips (jay) (retired) 2014-06-02 04:40:10 UTC
*** Bug 73369 has been marked as a duplicate of this bug. ***
Comment 10 Yousuf Philips (jay) (retired) 2014-06-02 04:40:52 UTC
As stated in the other bug, this issue is related to the sidebar.
Comment 11 Michael Stahl (allotropia) 2014-06-10 20:30:43 UTC
apparently this crash happens only on Windows, and for very few people.

it would probably be helpful if we had a backtrace of the crash.

Comment 12 Yousuf Philips (jay) (retired) 2014-06-10 21:44:53 UTC
Yes its limited to only Windows XP and it happens randomly. I would have like to send in a backtrace but couldnt get windbg installed on the OS and i tried to get it crash by opening it 10 or so times and it didnt crash once. It is quite strange this one.
Comment 13 João Paulo 2014-06-14 21:41:09 UTC
(In reply to comment #11)
> apparently this crash happens only on Windows, and for very few people.
> it would probably be helpful if we had a backtrace of the crash.
> https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg

Sorry, I can't help with that. Migrated my both computers to Windows Vista and not using Windows XP anymore.

Still, I think this bug is related to the PDF Export function, but as Windows XP is still being used on many places (I hope places without Internet connection), you should weight if is worth to investigate and fix it.
Comment 14 Björn Michaelsen 2014-10-11 12:28:06 UTC
very unlikely to be writer specific
Comment 15 Kevin Suo 2014-10-17 09:58:43 UTC
May be the same issue as in bug 84322. Try if you can reproduce following my steps in https://bugs.freedesktop.org/show_bug.cgi?id=84322#c0
Comment 16 João Paulo 2014-10-20 03:06:38 UTC
Hi, I am downloaded the WinDbg to try to get a backtrace (never did it before).

Followed the steps to try reproduce the crash (it only happened when used the PDF Export function), but had no success.

As I recall, after upgrading to version, build ID 3fd416d4c6db7d3204c17ce57a1d70f6e531ee21, never had the crash again.

Maybe the bug was fixed?
Comment 17 tommy27 2014-10-20 04:52:22 UTC
maybe has been fixed so let's mark this as RESOLVED WORKSFORME
feel free to revert status if you reproduce again
Comment 18 Stanislav Horacek 2015-02-03 20:02:22 UTC
We've received a message from submitter of the duplicate bug 73369 that he still experiences this problem in, Windows XP SP3 (more instances).

The previously reported error window with the title "DDE Server Window: soffice.bin - Application error" appears when closing Writer or Calc.
The bug occurs unpredictably, only if the sidebar is shown and more frequently if the sidebar is expanded.
Comment 19 Yousuf Philips (jay) (retired) 2015-02-04 00:17:58 UTC
@Stanislav: If the submitter of bug 73369 can get a backtrace for the crash with windbg ( https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg ) and submit it here, the devs can look into finding out where the source of the problem seems to be.
Comment 20 Stanislav Horacek 2015-02-05 17:11:22 UTC
Yes, I wrote him that this would be helpful (but I don't know how complicated getting backtrace on Windows is).
Comment 21 Yousuf Philips (jay) (retired) 2015-02-05 20:31:28 UTC
@Stanislav: I've personally rewrote the backtrace wiki and included screenshots of all the steps involved, so it should be very easy for him to get it done (you can give it a try to see how easy it is if you have windows). If he has any problems, please let me know.
Comment 22 Aron Budea 2015-02-17 18:26:26 UTC
Created attachment 113473 [details]

I managed to reproduce this in WinXP (inside a VM). Attaching the backtrace. The bug can be consistently reproduced using Bohumír Džubej's reproduction steps in duplicate bug 73369 .
Comment 23 libre-bugs-2015 2015-02-25 20:49:20 UTC
LibreOffice Portable v4.4.0.3 (English)

Windows XP Professional Service Pack 3

I have the same issue when using Writer.  After editing a document, saving it, and then clicking the Close windows button, I will see the following error:


DDE Server Window: soffice.bin - Application Error

The instruction at "0x7c910a19" referenced memory at "0xffffffff". The memory could not be "read".

Click 'OK" to terminate the program

Comment 24 libre-bugs-2015 2015-02-25 20:51:00 UTC
Created attachment 113685 [details]
DDE Error Message

A screenshot of the DDE error message.
Comment 25 zahra 2015-11-19 14:48:12 UTC
hi every one. 
yes. i confirm this bug in my system windows xp proffessional service pack 3. 
when i opened a document, read it, edit some point in it, or i wanted to close it without editing anything, and i pressed alt f4 to close the program i recieved this message exactly. 

DDE Server Window: soffice.bin - Application Error

The instruction at "0x7c910a19" referenced memory at "0xffffffff". The memory could not be "read".

Click 'OK" to terminate the program. 

its not different that which type of document i want to read or edit. 
in all of them, i recieved this message. 
in versions from version 4.3.04 and above until version that are accessible for blinds without need to install java and java access briedge, i tested this subject with the same error message. 
and also i tested installed and portable versions of libreoffice between versions 4.3 and 4.4 with the same result! 
but when i installed libreoffice version, the error reduced fortunately and i recieved it very rarely. 
i can say even not more than 5 percent in the time of my using of libreoffice.
Comment 26 Robinson Tryon (qubit) 2015-12-10 01:28:46 UTC Comment hidden (obsolete)
Comment 27 zahra 2016-01-14 08:38:51 UTC
i used libreoffice for test and when i downloaded and installed version and used it in my daily work and tried to edit my documents after closing libreoffice, the result was the same. 
i use windows xp professional service pack 3 and i tried in both fa-ir and also en-us locale. 
but in all versions that i used in my daily works and editing my documents, the result was the same and i am observing this error message in all versions. 

DDE Server Window: soffice.bin - Application Error

The instruction at "0x7c910a19" referenced memory at "0xffffffff". The memory could not be "read".

Click 'OK" to terminate the program
Comment 28 zahra 2016-01-14 08:49:43 UTC
i think that i back to the version in the near future and i think that this version was more simple and without need powerful hardware. 
but when i use versions of libreoffice before version 5, i faced a major error about microsoft visual c runtime library.
Comment 29 Julien Nabet 2016-06-05 14:31:29 UTC
Any better with last stable LO version 5.1.3?
Comment 30 Yousuf Philips (jay) (retired) 2016-06-05 15:06:35 UTC
Can a dev look into the submitted backtrace (attachment 113473 [details]) and see if it sufficient to track down the problem.
Comment 31 Michael Meeks 2016-06-06 08:25:05 UTC
Hi Aron; thanks for reproducing, and doing it with a symbols build. Unfortunately the trace is not so useful:


It means that somewhere before this trace someone did something bad to the memory. However - if you have that VM setup, what would be really useful is running 'drmemory' on the binary:

That should make the app run -much- slower (20x at least), but it should also produce a big log that shows where this memory corruption occurs [ with stack traces ].

Do you think you could run it under drmemory ?

Thanks !
Comment 32 Xisco Faulí 2016-09-13 10:49:51 UTC
This regression was introduced before branch 4.4, thus it can't be bibisected with the current bibisect repositories. Changing keyword 'notBibisectable' to 'preBibisect'
Comment 33 zahra 2016-09-13 12:18:01 UTC
(In reply to Yousuf Philips (jay) from comment #30)
> Can a dev look into the submitted backtrace (attachment 113473 [details])
> and see if it sufficient to track down the problem.

i tested libreoffice 5.1.4 and after exiting the result for me was crash.
Comment 34 zahra 2016-09-13 12:26:52 UTC
i completely confirm that the issue still persist in libreoffice 5.0.5 and also 5.1.4 which i tested and even 5.0.6.
but in 5.0.6 for me is less than the other versions.
Comment 35 tommy27 2016-11-30 06:11:10 UTC
I set status to NEW since there have been multiple independent confirmations.
I also ask those people to tell if issue persists in latest LibO release.
Comment 36 zahra 2017-02-06 10:47:45 UTC
yesterday, i downloaded version and
when i use 5.1.6 and maybe in all branches of 5.1, after exiting libreoffice writer via alt+f4 libreoffice becomes unresponsive and wants to report it to microsoft.
its not responsive famous bug which is appeares in many programs and even windows explorer!
and maybe this happen even using windows explorer because of using windows xp, but i am not sure completely.
and also i tested with 5.2 a little time and did not see such errors after exiting writer.
if i find new result for this, i comment it here.
with very little investigation, i think that all bugs related to exiting writer on windows xp is solved in 5.2 branche,
but as i mentioned i tested it little time and i report the changes if i face a new behaviour!
thanks so much for resolving bugs,
i pray for you in my five times daily prayers, request divine extreme mercy and blessings for you.
Comment 37 Chris Sherlock 2017-03-11 07:21:19 UTC
Zahra, I think that's a different issue to the one reported here.

Does this consistently occur for you? If so, please log a new bug report, and feel free to cc me in on it.

The DDE error can only really occur if Dynamic Data Exchange is being used, and if I had to hazard a guess we aren't closing the DDE link cleanly on exit.
Comment 38 QA Administrators 2018-03-12 03:35:39 UTC Comment hidden (obsolete)
Comment 39 Aron Budea 2018-07-23 03:15:08 UTC
The last version that supported Windows XP, 5.4, has reached EOL, therefore this ticket can now be closed as well.