Download it now!
Bug 81468 - Crash on exit LibreOffice
Summary: Crash on exit LibreOffice
Status: RESOLVED DUPLICATE of bug 84322
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-17 18:30 UTC by helplibreoffice
Modified: 2015-02-04 11:02 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description helplibreoffice 2014-07-17 18:30:06 UTC
LO Calc sometimes crashes when it is being closed.

The exact error is:

DDE Server Window: soffice.bin - Application Error

The instruction at "0x7c911689" referenced memory at "0xffffffff".  The memory could not be "read".

Click on OK to terminate the program

This occurs about 1 out of 10 times on a customer's computer.  They are running XP Pro, SP3.  Uninstalling and reinstalling LO v4.2.5.2 (release) does not resolve the issue.
Comment 1 tommy27 2014-07-17 18:59:47 UTC
did you reset user profile as well?
Comment 2 helplibreoffice 2014-07-17 19:45:17 UTC
If you mean deleting files in userdata folders, yes.

If you mean something else, let me know.
Comment 3 Kevin Suo 2014-07-18 00:38:13 UTC
I encountered the same problem in my WinXP SP3.
It happens radomly, I can not find the exact steps to reproduce.
Comment 4 Kevin Suo 2014-07-18 00:49:35 UTC
Added bug 65150 as see also.
It was an old bug but has very similar error msg.
Comment 5 tommy27 2014-07-18 05:27:11 UTC
@Kevin
do you get the exact error code as the bug reporter?
could we mark this as NEW?
Comment 6 Kevin Suo 2014-07-18 05:36:49 UTC
(In reply to comment #5)
> @Kevin
> do you get the exact error code as the bug reporter?
> could we mark this as NEW?

Yes I did, but it was some months ago. Now with version 4.2.6.1 and 4.3.1.0.0+, I do not get the crash anymore.

The error message shows randomly in the earlier versions, and I do not reproduce now. So I am not sure whether mark this as NEW is fine.
Comment 7 tommy27 2014-07-18 07:31:11 UTC
@helplibreoffice@mailcatch.com

ask your customer to note if there's some specific issue that triggers the error (i.e. specific file, etc. etc.)

random bags are the hardest to debug if there are no reproducible steps.
Comment 8 helplibreoffice 2014-07-18 19:40:44 UTC
I sent an inquiry, and they said that it happens very randomly, even on the simplest of spreadsheets.  They said they created a new spreadsheet with just 3 cells and no formulas and it happened.  That tells me it likely does not have to do with the content of the spreadsheet.  Given that their machines are slow, I'm guessing it's a timing issue of some sort.  Could be an interaction with an antivirus product as well.  They use Avast on their systems, and I confirmed it is the latest version.
Comment 9 Joel Madero 2014-07-19 01:52:17 UTC
With the current situation there just aren't any reproducible steps or anything actionable from anyone.

Marking as NEEDINFO

@Help - I suggest someone try to debug the problem a bit more, try to get reproducible steps - "random crashes" with nothing else really isn't sufficient for us to resolve the problem. Apologies for the inconvenience
Comment 10 helplibreoffice 2014-07-19 10:13:55 UTC
One thing that might help testing is if interested parties test it on slower computers.  Often times developers have the latest and greatest technology, whereas everyday users use slower equipment.

I'm always amazed at how much software is untested on slower computers, which comprise a majority of the computers used by our planet's office workforce.
Comment 11 tommy27 2014-07-19 10:51:52 UTC
I run LibO 4.2.5.2 under several PCs including one 2006 XP 32bit machine which is quite old and slow and I've never experienced the issue you describe, so the problem may be something else
Comment 12 Julien Nabet 2014-07-19 16:53:29 UTC
helplibreoffice:

1) Is the file opened in local hard disk or network shares?

2) What precise Java version do they use? LibreOffice on Windows needs Java 32 bits. 

3) Let's say a Calc file which we'll call "testFile" crashed. If they opened again this same file and close it without doing anything at all, does it crash too?

4) Do they have this problem with only 1 computer, several or all of them?

5) Did they try the raw method:
- uninstall
- rename (or delete if not necessary) user profile
https://wiki.documentfoundation.org/UserProfile#Windows
- clean Windows registry with a free tool (eg: ccleaner)
- install again
?
Comment 13 helplibreoffice 2014-07-22 02:46:27 UTC
@Julien:

1) Is the file opened in local hard disk or network shares?
A: Local hard disk

2) What precise Java version do they use? LibreOffice on Windows needs Java 32 bits.
A: At time of report, they were using v1.7.0_55-b14 (32 bits)

3) Let's say a Calc file which we'll call "testFile" crashed. If they opened again this same file and close it without doing anything at all, does it crash too?
A: Only about 10-20% of the time.  Hence my hypothesis it is a timing issue due to their slower computers or antivirus processing.  Pure speculation on my part.

4) Do they have this problem with only 1 computer, several or all of them?
A: Several computers

5) Did they try the raw method?
A: Yes
Comment 14 tommy27 2014-07-22 04:08:47 UTC
@helplibreoffice
thanks for answering Julien's questions. 
I have one more for you: you said they have slow computers, would you please give details of one of those machines? CPU, RAM etc. etc. I'd like to compare them with my 2006 machine.

regarding the antivirus suspicion the only test you could do is to uninstall Avast from one of those crashing PCs and replace it with another one (you could try free version of AVG http://free.avg.com/ ) and see if it solves the problem.

give us feedback.
Comment 15 helplibreoffice 2014-07-22 05:30:23 UTC
@tommy27

You're welcome.

I wrote down some of their average PC specs the last time I was there.  They use Pentium 4 desktop processors running at 1.8ghz to 2.8ghz.  Most of their machines have 1GB of RAM.  Their hard drives are very slow IDE (not SATA) drives.  They also have some SCSI drives.  I think all their drives are 4200-5400... no 7200 or 10K.  They do defragment regularly.

In the past, I have asked if I could modify any of their AV software, and I got a 'no'.  Never hurts to ask. ;)

BTW, I had provided the exact memory address of the crash.  Does that help, or is it basically useless?
Comment 16 Julien Nabet 2014-07-22 06:37:11 UTC
Thank you for your feedback.

What's the size of Calc files of the users in general? Some KB? some MB? More than 50MB?
Did you try to monitor memory consumption? (Any hint in Windows event viewer?)

While Tommy compares the config of your pcs with his, would it be possible you retrieve a backtrace? (see https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg)
Indeed I suppose it might take some time since you can't reproduce the crash at will.
Comment 17 helplibreoffice 2014-07-22 07:56:50 UTC
File sizes are less than 1MB in general, sometimes under 250KB.

Have monitored memory a bit... typically about 150MB-250MB free.  Their PC's run very few processes besides LO Calc when they are using it.  No disk thrashing at all.  But since the crashes are sporadic, it's possible memory use is different at those moments in time.

I honestly don't think I will be able to get a backtrace.  If it happened every time, then no problem.  I apologize, I just don't have the time right now.  I'm behind on a couple projects because I spent quite a bit of time on other LO bugs.
Comment 18 Julien Nabet 2014-07-29 17:32:42 UTC
Thank you helplibreoffice for your feedback, since I don't have more questions, I put it back to UNCONFIRMED
Comment 19 helplibreoffice 2014-08-16 20:01:21 UTC
This past Thursday, I installed a brand new installation of 4.3.0.4 (release) on another client's system.  Same specs as the other client previously mentioned.

I opened LO Calc with a spreadsheet, showed them a few features, and then closed Calc.  Worked fine.  The client then clicked on the default LO Calc shortcut to load LO Calc (with no spreadsheet).  Right as it was done loading, he closed it.  LO Calc crashed immediately on close.  He asked me to uninstall LO Calc and install something else.

The error was the same as reported before except was at 0x7c910a19.

I bumped the version number of this bug, to keep it current.
Comment 20 Joel Madero 2014-08-16 20:08:02 UTC
Version is the oldest version that the bug is confirmed on - resetting version.
Comment 21 Julien Nabet 2014-08-16 20:44:15 UTC
helplibreoffice: it could help if you could retrieve a backtrace.

In the meantime, by searching about 0x7c911689 in Bugtracker, I found several old bugtrackers, they're almost all RESOLVED/DUP of fdo#31494 (put in See Also)

Considering the old processor of the concerned pcs, I thought it could also be related to fdo#82430 (put in See Also too). Of course symptoms are different but the other one concerns Athlon K7 whereas here it's Intel Pentium 4. (ok, long shot...)

Caolan/Michael/Tor: any idea? (even if this one is not yet at NEW)
Comment 22 helplibreoffice 2014-08-17 19:58:29 UTC
Joel, thanks for correcting the version number so that it reflects the earliest version in which this bug was experienced.  How do devs know that it also occurs in later builds?  Is it best to add a note to the thread when people experience a bug in a later version than originally marked, or is there a better method?

Julien, I agree that a backtrace would be very useful.  I'll ask if I can reinstall LO Calc on one of their systems to try to get one.  But I doubt it as they have unfortunately decided to switch everything to another spreadsheet application.

If I take a guess, it is a timing issue: either something not loaded completely or a file is locked, when LO Calc is closed to soon.  But that's just a guess.
Comment 23 Heinz Repp 2014-08-25 08:55:46 UTC
This bug bytes me also, specs: Win XP SP3, Athlon Sempron 3100+, Radeon 9250, a fairly old system, with LibreOffice Version: 4.3.0.4 Build-ID 62ad5818884a2fc2e5780dd45466868d41009ec0.

It happens also when only Writer has been uses, small documents (less than one page) saved, and then Writer closed. The error message is exactly the same as reported in the bug description, only the address differs.

So this clearly shows that not the spreadsheet component is in error, it is the main application exit that throws the error. Maybe this surfaces now as quickstarter is broken and the application terminates every time. With previous versions I always used quickstarter, so application exit happened only on computer shutdown.

Change:
Component Spreadsheet -> LibreOffice
Status Unconfirmed -> New
Comment 24 Kevin Suo 2014-09-25 09:56:19 UTC
I am lucky to find some simple steps to reproduce the crash with "The memory could not be "read"" message, see Bug 84322.

Not sure whether it's the same issue as this bug.
Comment 25 Caolán McNamara 2015-02-04 11:02:17 UTC
Lets assume that it is because the other one had steps of how to reproduce.

*** This bug has been marked as a duplicate of bug 84322 ***