Bug Hunting Session
Bug 70302 - FILESAVE: FORMCONTROLS: The forms aren't saved in docx.
Summary: FILESAVE: FORMCONTROLS: The forms aren't saved in docx.
Status: RESOLVED DUPLICATE of bug 50097
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: DOCX-ActiveX-Legacy
  Show dependency treegraph
 
Reported: 2013-10-09 01:54 UTC by FDF
Modified: 2017-05-14 05:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Original file as per the process discribed (9.41 KB, application/vnd.oasis.opendocument.text)
2013-10-09 07:58 UTC, FDF
Details
Same file once saved as docx (3.68 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-10-09 07:59 UTC, FDF
Details

Note You need to log in before you can comment on or make changes to this bug.
Description FDF 2013-10-09 01:54:56 UTC
Problem description: 

Steps to reproduce:
1. open a new writer doc
2. with the form control tool bar, create a check box
3. save normally in ods
4. Save as docx
5. Fully close libreoffice
6. open the docx document

Current behavior:
The checkbox is not here anymore


Expected behavior:
The check box should still be here…

Don't hesitate to ask for more details, but I suspect I am not the first one…
Starting with other documents lead to the same result of losing all the form componant.

              
Operating System: Debian
Version: 4.0.5.2 release
Comment 1 retired 2013-10-09 07:18:31 UTC
Hi FDF, thanks for the report. Can you please attach the ods file in question so this can be tested?
Comment 2 FDF 2013-10-09 07:58:34 UTC
Created attachment 87320 [details]
Original file as per the process discribed

This is the writter file obtained from the process. I'll enclose later the same file once saved as docx.
Comment 3 FDF 2013-10-09 07:59:06 UTC
Created attachment 87321 [details]
Same file once saved as docx
Comment 4 Thomas van der Meulen 2013-10-22 08:02:28 UTC
Thank you for your bug report, I can reproduce this bug running 
Version: 4.1.3.1
Build ID: b42498da0e3f91b17e51b55c8295ec4f8f22087
Also tested with Version 3.6.7.2 (Build ID: e183d5b) to check if it wasn't as regression but no. 
OS: Mac osx 10.8.5. 

I am going to give it an higher priority I also going to set the version to the first version that it was spotted and set the OS to ALL.
Comment 5 Matthew Francis 2014-10-15 17:33:20 UTC

*** This bug has been marked as a duplicate of bug 50097 ***