Download it now!
Bug 70335 - TABLE: Can't properly paste cells from Calc to table in Writer
Summary: TABLE: Can't properly paste cells from Calc to table in Writer
Status: RESOLVED DUPLICATE of bug 37223
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-10 08:34 UTC by sunweb
Modified: 2014-12-24 17:35 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sunweb 2013-10-10 08:34:42 UTC
Problem description: 
Can't properly paste the table contents from Calc to table in Writer

Steps to reproduce:
1. open Calc and fill data in A1 and B1 cells.
2. select both cells and copy them
3. open Writer and create the table with 2 columns
4. select both cells and paste special "unformatted text"

Current behavior:
pastes data in the first cell and symbols in the second

Expected behavior:
pastes data from A1 to the first cell and B1 to the next cell

Select 1 cell and paste 2 cells copied from Calc in this very cell = ok
Select 2 cells and paste 2 cells copied from Calc in one cell = not ok
Select 2 cells and paste 2 cells copied from Calc in two cells = ok

Thats very handful feature and MSO does it quite well.

Another not top priority but useful feature is used with the one i desribed. When you pasted more data from Calc to Writer in which table is too small you have a 1 click option to create additional table cells already filled with your data.

It would be really great to have it in LO.
Operating System: Ubuntu
Version: 4.1.1.2 release
Comment 1 ign_christian 2013-10-10 10:18:49 UTC
Hi.. Please see Bug 61329 & you could join there, perhaps these issues had same root.

I'm also marking NEW since I can confirm this bug with LO 4.0.6.1 (Win7 32bit).

> Another not top priority but useful feature is used with the one i desribed.
> When you pasted more data from Calc to Writer in which table is too small
> you have a 1 click option to create additional table cells already filled
> with your data.
But I think this enhancement request should be separated to different report. (please do searching first, maybe someone had reported)
Comment 2 sunweb 2013-10-10 10:51:49 UTC
Yes, it seems to be the same problem with the exception that i also added a feature suggestion. Strange but i didn't find this bug when searching through bug tracker, sorry.
Comment 3 Timur 2014-02-03 10:25:52 UTC
While there exists Bug 61329 (with good steps to reproduce and a solution to use extension Paste as value) I suggest this be marked as a duplicate of an older Bug 37223 and then Bug 37223 be added to MAB.
Comment 4 Timur 2014-12-24 17:35:40 UTC

*** This bug has been marked as a duplicate of bug 37223 ***