Bug 70337 - uninserted spurious object appearing in document
Summary: uninserted spurious object appearing in document
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Images
  Show dependency treegraph
 
Reported: 2013-10-10 09:56 UTC by Paolo Benvenuto
Modified: 2019-08-21 20:46 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
odt document in which writer inserted a spurious object (60.53 KB, application/vnd.oasis.opendocument.text)
2013-10-10 09:56 UTC, Paolo Benvenuto
Details
screenshot of the doc with the spurious object (259.56 KB, image/png)
2013-10-10 09:56 UTC, Paolo Benvenuto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo Benvenuto 2013-10-10 09:56:15 UTC
Created attachment 87378 [details]
odt document in which writer inserted a spurious object

I'm seeing quite often that when I open a odt document saved with LO (same version), a spurious object appears, usually at the beginning of the 2nd page.

However, this object isn't listed in the navigator tool, but it influence the text flow.

I'm attacching a doc where I'm seeing this weird thing: it's a 2 page A5 doc.

I'm attacching a screen shot of what I see: the spurious text flow is visible at the beginning of the 2nd page. You can see it's anchor this way:
- click on the star at the beginning
- hit tab -> you reach the spurious object

With this sample doc, writer freezes when you reach the spurious object. Other times that didn't happen.
Comment 1 Paolo Benvenuto 2013-10-10 09:56:57 UTC
Created attachment 87379 [details]
screenshot of the doc with the spurious object
Comment 2 QA Administrators 2015-04-19 03:22:47 UTC Comment hidden (obsolete)
Comment 3 Paolo Benvenuto 2015-04-20 09:28:41 UTC
Still present in 4.4.2 ubuntu from ppa:libreoffice/ppa
Comment 4 QA Administrators 2016-09-20 09:33:13 UTC Comment hidden (obsolete)
Comment 5 Paolo Benvenuto 2016-09-20 13:15:07 UTC
already present in 3.3

presente in 5.1
Comment 6 Xisco Faulí 2017-09-29 08:52:42 UTC Comment hidden (obsolete)
Comment 7 Paolo Benvenuto 2017-09-29 12:03:45 UTC
confirmed in 5.4.1.2 ubuntu
Comment 8 QA Administrators 2018-09-30 02:48:54 UTC Comment hidden (obsolete)
Comment 9 Thomas Lendo 2019-08-21 20:44:09 UTC
The object still exists in the canvas but isn't 
available via mouse or Navigator.

Version: 6.3.0.4
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-AT (de_AT.UTF-8); UI-Language: en-US
Calc: threaded

I found three png pictures in the odt file. 100000000000000800000008913C8356.png is a small white rectangle. Maybe this picture is part of the visible file.

But I doubt this issue will ever be fixed. Paolo, I suggest to use a fresh new profile and test it with an actual version of LibreOffice and new files again.

Otherwise you have to wait another six or twelve years if a developer or someone else dig into the problem. If the issue isn't reproducible with another installation of LibreOffice (by creating a defected file) it's hardly possible to fix it.