Bug 70344 - Space added to end of text string
Summary: Space added to end of text string
Status: RESOLVED DUPLICATE of bug 70275
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-10 13:06 UTC by my_wong
Modified: 2013-11-22 12:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
upon opening this file, the text already have a space at the end (38.48 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-10-10 13:06 UTC, my_wong
Details
this file has one more space at the end of the text (34.15 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2013-10-10 13:07 UTC, my_wong
Details
this file has another one more space at the end of the text (34.08 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2013-10-10 13:08 UTC, my_wong
Details

Note You need to log in before you can comment on or make changes to this bug.
Description my_wong 2013-10-10 13:06:19 UTC
Created attachment 87392 [details]
upon opening this file, the text already have a space at the end

Whenever I save the file, when I re-open the file again a space " " had been added to the end of the text strings. I attached a few files saved in progression. The text data in the respective cell has more and more blank spaces.
I first noted this when I build a pivot table. When I build a pivot table, the pivot table already shows additional space. Even when I removed the pivot table, the problem did not go away.
Comment 1 my_wong 2013-10-10 13:07:27 UTC
Created attachment 87393 [details]
this file has one more space at the end of the text
Comment 2 my_wong 2013-10-10 13:08:28 UTC
Created attachment 87394 [details]
this file has another one more space at the end of the text
Comment 3 m.a.riosv 2013-10-11 00:39:43 UTC
Hi Wong, thanks for reporting.

The issue is that you a space at the last of the cell format after @.
A reported bug.
https://bugs.freedesktop.org/show_bug.cgi?id=70275

*** This bug has been marked as a duplicate of bug 70275 ***
Comment 4 my_wong 2013-11-22 12:30:02 UTC
Thanks Mariosv, I will remove the space.