Bug 70355 - DATALOSS: Graph data tables swapping data in x and y axis in writer documents resulting in incorrect graphs.
Summary: DATALOSS: Graph data tables swapping data in x and y axis in writer documents...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-10-10 20:05 UTC by Brian
Modified: 2015-12-15 11:03 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of bug described. (379.78 KB, application/vnd.oasis.opendocument.text)
2013-10-10 20:05 UTC, Brian
Details
Screenshot of data table from 3rd bar graph in document (Bad, version 4.0-4.2) (20.43 KB, image/png)
2013-10-11 20:09 UTC, Brian
Details
Screenshot of data table from 3rd bar graph in document (Good, version 3.6) (20.33 KB, image/png)
2013-10-11 20:10 UTC, Brian
Details
Screenshot of 3rd bar graph in document (Bad, version 4.0-4.2) (25.99 KB, image/jpeg)
2013-10-11 20:20 UTC, Brian
Details
Screenshot of 3rd bar graph in document (Good, version 3.6) (34.93 KB, image/jpeg)
2013-10-11 20:21 UTC, Brian
Details
Screenshot in Version 4.0.6.1 (139.35 KB, image/png)
2013-10-11 23:44 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian 2013-10-10 20:05:21 UTC
Created attachment 87413 [details]
Example of bug described.

See attached document.

Open the document in LibreOffice 3.6 to see the graphs as they should be. Open the document in versions 4.0, 4.1, or 4.2 and the x/y axis of the data tables will be reversed causing the graphs to show incorrect data.

For example, if you were looking at it as if it were a spreadsheet, everything from Row 1 is put into Column A, everything from Row 2 is put into Column B, and so on.
Comment 1 Brian 2013-10-10 20:57:33 UTC
After further testing, exporting the document to pdf or saving as a doc also seems to distort the graphs (even in 3.6).
Comment 2 Jorendc 2013-10-11 20:02:06 UTC
Is it possible to show a screenshot showing the difference between both LibreOffice versions?

I can't see anything wrong using Mac OSX 10.8.5 with LibreOffice Version: 4.1.2.3
Build ID: 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38
All charts/graphs looks correct (and logical) to me.

Kind regards,
Joren
Comment 3 Brian 2013-10-11 20:09:35 UTC
Created attachment 87480 [details]
Screenshot of data table from 3rd bar graph in document (Bad, version 4.0-4.2)

Screenshot of data table from 3rd bar graph in document (Bad, version 4.0-4.2)
Comment 4 Brian 2013-10-11 20:10:28 UTC
Created attachment 87481 [details]
Screenshot of data table from 3rd bar graph in document (Good, version 3.6)

Screenshot of data table from 3rd bar graph in document (Good, version 3.6)
Comment 5 Brian 2013-10-11 20:12:15 UTC
Screenshots of an example data table added. No edits have been made, this is the same document, just opened in different LibreOffice versions.
Comment 6 Brian 2013-10-11 20:20:53 UTC
Created attachment 87482 [details]
Screenshot of 3rd bar graph in document (Bad, version 4.0-4.2)

Screenshot of 3rd bar graph in document (Bad, version 4.0-4.2)
Comment 7 Brian 2013-10-11 20:21:36 UTC
Created attachment 87483 [details]
Screenshot of 3rd bar graph in document (Good, version 3.6)

Screenshot of 3rd bar graph in document (Good, version 3.6)
Comment 8 Brian 2013-10-11 20:22:33 UTC
Added screenshots of the bar graph itself. Notice that the bar graph remains valid; however, the data has been rearranged as described in the original post.
Comment 9 Jorendc 2013-10-11 20:41:06 UTC
Thanks for your extra screenshots and information!

I can reproduce this behavior, tested using LibreOffice 4.1.2.3 in comparison with Version 3.6.0.4 (Build ID: 932b512); Using Mac OSX 10.8.5

Adding Calc/chart experts, because I think this is a regression in the Chart-component.

@Joel: what do you think about the priority of this bug? Looks to me definitely MAB4.0, not sure about the priority.

Kind regards,
Joren
Comment 10 m.a.riosv 2013-10-11 23:44:27 UTC
Created attachment 87494 [details]
Screenshot in Version 4.0.6.1

This is what I see in
Win7x64 Ultimate
Version 4.0.6.1 (Build ID: 7168152d13aa529ba3718c9ae3700216a574137)

I am not in an error is the same as in 3.6
Comment 11 Joel Madero 2013-10-12 01:06:12 UTC
Hm since it's been around since 4.0.0.3 and we've had releases since then, IMHO not a blocker but I'm happy with it being a critical bug since it's affecting a very common feature + it's a regression. 

Markus - let us know if you want a bibisect
Comment 12 Michael Meeks 2013-10-16 09:49:08 UTC
An interesting issue - of course a bisect is always useful for a regression; Muthu has done most work in the chart world in recent times though Markus is now doing a chunk of work there ...
Comment 13 Muthu 2013-10-18 08:14:01 UTC
There is no change on top of my mind that could bring this regression.

Yes, a bisect would be really helpful.
Comment 14 Markus Mohrhard 2013-10-18 09:18:58 UTC
There is one change in the embedded object handling coming from the AOO rebase that is most likely related.

Sadly we can't revert this patch but it changes the initialization order of chart objects which makes some of the import hacks in the chart uno implementation fail. I have looked into it before and fixed one that was similar for calc but there are surely more issues related to this change out there.
Comment 15 Terrence Enger 2013-10-18 17:31:09 UTC
From `git bisect`:

    305763174e4eed88f03bba7df1276cdf26be9a0c is the first bad commit
    ...
        commit bb5196b40cc5f8f2d4f221e61a20d572ce504558
        ...

and from `git bisect log`:

    # bad: [d31848bf3b700a22d127d7c775a0f910a7e133d0] source-hash-86cbe18a6143bf054c31f69dc97368dfdd3ad374
    # good: [3e7462bd65e692bf0592d5b080b7716341b62a47] source-hash-1eddfce9894fd05315173744f495619189093dc7
    git bisect start 'latest' 'oldest'
    # good: [578fb08152ad11454e2f09ad6f8c8e527da817de] source-hash-4e3e171262aed0e52fa76158950d5be770249e80
    git bisect good 578fb08152ad11454e2f09ad6f8c8e527da817de
    # bad: [efb04c1c794ef7fc4cda1eb80880d333ca969a5e] source-hash-7908692490120350f2ad45241f7b19ba52dc0489
    git bisect bad efb04c1c794ef7fc4cda1eb80880d333ca969a5e
    # good: [b46b5a58fcaec85eefb31b23afb0fc389a0c5334] source-hash-34c1b7bdd0bca4753f66a7d17ef46647a64a319e
    git bisect good b46b5a58fcaec85eefb31b23afb0fc389a0c5334
    # good: [3791268ce3e6f9e570f02c09d586fd8e9f2485c3] source-hash-51daa4de4fbb86903aeb9cdfefbb089e8d00c001
    git bisect good 3791268ce3e6f9e570f02c09d586fd8e9f2485c3
    # bad: [8f14f077f5faef9b7660ddf5ebcd188eb3042372] source-hash-dd5c0b2db451ff4d6fac7a72770758513583d468
    git bisect bad 8f14f077f5faef9b7660ddf5ebcd188eb3042372
    # good: [f066d428aeb365ac57d1863b9a574d82cddec974] source-hash-c99b97d306211fe346a7d0a5208aa99118208fc5
    git bisect good f066d428aeb365ac57d1863b9a574d82cddec974
    # bad: [a2f22aae2d4c64e7426980214bc9e63237223647] source-hash-83f77ab0661df992f241e5f9ecb1aa8f8eaeafec
    git bisect bad a2f22aae2d4c64e7426980214bc9e63237223647
    # bad: [305763174e4eed88f03bba7df1276cdf26be9a0c] source-hash-bb5196b40cc5f8f2d4f221e61a20d572ce504558
    git bisect bad 305763174e4eed88f03bba7df1276cdf26be9a0c
    # good: [08a8f062763014582190ae8742fabc657cfa9078] source-hash-e67c21ee0696cde7538016a813a5cbf39fb803b0
    git bisect good 08a8f062763014582190ae8742fabc657cfa9078
Comment 16 Jorendc 2013-12-08 18:54:39 UTC
Thanks Terrence :)!

Range: http://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=e67c21ee0696cde7538016a813a5cbf39fb803b0..bb5196b40cc5f8f2d4f221e61a20d572ce504558

(In reply to comment #14)
> There is one change in the embedded object handling coming from the AOO
> rebase that is most likely related.
This one? : http://cgit.freedesktop.org/libreoffice/core/commit/?id=14fa5488a829936275f79a7693b13da55114220e

Looks indeed very related (title = transpose, what actually happened here).

> Sadly we can't revert this patch but it changes the initialization order of
> chart objects which makes some of the import hacks in the chart uno
> implementation fail.
Dangit :)

Kind regards,
Joren
Comment 17 Xisco Faulí 2014-02-13 11:20:56 UTC
Commit 14fa5488a829936275f79a7693b13da55114220e was reverted by Markus in 	2013-11-02 19 --> http://cgit.freedesktop.org/libreoffice/core/commit/?id=68e39b840d6fbfc7cd9c12791d1c1a64cf60ec96

Not reproducible in 4.1.4 nor 4.2.0

Should we close it?
Comment 18 Joel Madero 2014-02-13 15:04:29 UTC
Since the commit that was reverted was identified - going to mark as FIXED.
Comment 19 Robinson Tryon (qubit) 2015-12-15 11:03:44 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]