Bug 70449 - StartCenter: it is not possible to easily navigate through recent used files with the keyboard
Summary: StartCenter: it is not possible to easily navigate through recent used files ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.2.0.0.beta1:Ubuntu
Keywords: accessibility, regression
Depends on:
Blocks: Start-Center-Accessibility mab4.2
  Show dependency treegraph
 
Reported: 2013-10-14 11:24 UTC by Jean-Baptiste Faure
Modified: 2016-10-25 19:56 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2013-10-14 11:24:43 UTC
In the new StartCenter (in the master version ≥ 4.2) the only available method to select a file in the StarCenter is to use the mouse. 
Please implement or fix the keyboard navigation (arrow keys).

Best regards.
JBF
Comment 1 Arnaud Versini 2013-10-14 11:27:10 UTC
Confirmed on master 12b1ca3236aa167c007c6c87e0d2f2d06c495821
Comment 2 manj_k 2013-10-14 14:30:56 UTC
I can use <Tab>/<Shift+Tab>, then the arrow keys, then <Enter>.

Version: 4.2.0.0.alpha0+
Build ID: 4badcfda55996891d99b1f0a8cc47028acd1c0c1
TinderBox: Win-x86@39, Branch:master, Time: 2013-10-14_04:13:30
Comment 3 Jean-Baptiste Faure 2013-10-14 17:52:53 UTC
Indeed, I tried it:
- you need to hit the <Tab> key 8 times (yes 8 times) before to select the first file
- if you select a file with the mouse, you can't select the previous/next with the arrow keys.

So, from user point of view, arrow keys are not usable to choose the recent used file to open.

Best regards. JBF
Comment 4 V Stuart Foote 2013-10-14 21:45:07 UTC
The <TAB> and cursor <U,D,L,R> keys are all functional in the GTK UI Wigets, but have not been implemented the same as their VCL assignments. There are no keyboard traps. But keyboard accelerators/shortcuts have not yet been implemented.

The <F6> key has also not been mapped, which I would expect could be used to traverse into the thumbnail view list and there allow use of cursor or tab key movement for object selection.

It seems like the XML configured GTK UI Widgets could/should fully support all legacy VCL functional keyboard navigation assignments--to match legacy documentation, or be published as UX changes.

QA/Dev work is needed on fully implementing keyboard UX. 

Have adjusted title as it is possible to navigate with keyboard only.
Comment 5 Jean-Baptiste Faure 2013-10-15 04:57:15 UTC
Hi (In reply to comment #4)
> [...]
> Have adjusted title as it is possible to navigate with keyboard only.

I disagree with your title change because it is not only a UX problem. When you open the StartCenter and select a recent used file with the mouse, you can't navigate with the keyboard. You need to select a file with multiple <Tab> hits first. There is a technical bug here.


Best regards. JBF
Comment 6 Jean-Baptiste Faure 2013-10-15 05:00:00 UTC
Added UX-advise mailing list in CC.

Best regards. JBF
Comment 7 Eike Rathke 2013-10-16 10:47:48 UTC
In the old StartCenter I could hit Alt+S to open a new spreadsheet. In the new StartCenter this takes 4 Tab moves and Enter, and there is no indication except the small icons what file type would be opened. This is not accessible for sight impaired people.

Furtheremore, in English-US the _Templates button shares shortcut with menu's _Tools but immediately executes the action as soon as Alt+T is pressed, instead of cycling between _Templates and _Tools.
Comment 8 Urmas 2013-10-31 11:38:52 UTC
For some reason you cannot move between open/template and applications button groups with arrows.
Comment 9 Eike Rathke 2013-11-07 15:00:54 UTC
I take the freedom to up Importance to high/blocker. The StartCenter is the first impression a user gets from LibreOffice, it should work in all aspects, be accessible and leave a satisfactory over-all user experience.
Comment 10 Adolfo Jayme 2013-11-09 22:42:21 UTC
(Removing UX-advise from CC, what kind of advise do you need for this?! It is an obvious a11y bug.)
Comment 11 Robinson Tryon (qubit) 2013-11-24 05:31:59 UTC
Confirmed on LO 4.2.0.0.beta1 + Ubuntu 12.04.3
Comment 12 Robinson Tryon (qubit) 2013-12-16 21:18:38 UTC
(In reply to comment #7)
> In the old StartCenter I could hit Alt+S to open a new spreadsheet. In the
> new StartCenter this takes 4 Tab moves and Enter, and there is no indication
> except the small icons what file type would be opened. This is not
> accessible for sight impaired people.

That sounds like a regression to me.
Comment 13 Eike Rathke 2013-12-16 23:11:33 UTC
But that's already fixed on current 4-2 (to-be 4.2.0.1), there are working shortcuts again.

Also, it's now possible to navigate the recent documents with cursor keys once reached the pane with a Tab sequence.

I call this fixed.
Comment 14 Jean-Baptiste Faure 2013-12-17 08:17:49 UTC
(In reply to comment #13)
> But that's already fixed on current 4-2 (to-be 4.2.0.1), there are working
> shortcuts again.
> 
> Also, it's now possible to navigate the recent documents with cursor keys
> once reached the pane with a Tab sequence.
> 
> I call this fixed.

I disagree. I see nothing changed here since I reported this bug. Tested in 4.2.0.0.beta2+ Build ID: 8a459f969d20ba3f77db58493c45819429996e67.

The important word in the summary is "easily" and you still need to hit 10 times the TAB key before to reach the recent files area. 
Because of the single click use to open recent files, you can't jump directly in the recent files area with the mouse and then navigate in the list with the keyboard.
More, when using the TAB key it is not clear which button has the focus or if you reached the recent files area.
Is there a shortcut to access directly to the recent files area? It seems that Alt+U does nothing.

Best regards. JBF
Comment 15 retired 2013-12-17 11:05:52 UTC
Agree with JBF taht 11 tab clicks are too much to get to the file selection. I made a suggestion in another bug which might solve this: https://bugs.freedesktop.org/show_bug.cgi?id=70637

Those bugs are overlapping and party cover the same glitch.

So for this here bug I think the remaining issue we are discussing is: too many clicks to get to the recent files list with keyboard. 11 tab clicks is just too much. Can we find a solution? Also I really think StartCenter should receive more attention. It needs to be solid when 4.2 is shipped. Many eyes will see the startcenter and judge LO upon that very first impression. If it shows documents in wrong manner, or behaves quirky this will give as the according feedback. I find 19 entried when searching the bug database for startcenter (some are minor, others should be looked into).

Sorry for getting a little off-topic, but I think this should be dealt with *before* the 4.2 release.
Comment 16 V Stuart Foote 2014-01-04 17:50:51 UTC
Aside from the need for 10 <TAB>s, or one <Shift><TAB> to reach the ThumbNail View list of recent documents--keyboard navigation issues are corrected. Setting resolved fixed.

Would still suggest refactoring of the GTK UI to group GtkBox(s) for <TAB> movements and GtkButton(s) movement with cursor (U,D,L,R), and look at implementing legacy <F6> movements--but those enchantments could be post 4.2.0 release.
Comment 17 Robinson Tryon (qubit) 2015-12-18 09:33:51 UTC Comment hidden (obsolete)