Bug Hunting Session
Bug 70460 - StartCenter: module icons are too small
Summary: StartCenter: module icons are too small
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: UX-Advise
Keywords:
: 70050 (view as bug list)
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2013-10-14 18:10 UTC by Jean-Baptiste Faure
Modified: 2014-07-24 18:45 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
screencopy of the new StartCenter (22.59 KB, image/png)
2013-10-14 18:10 UTC, Jean-Baptiste Faure
Details
alternate mockup of StartCenter using composite icon and text button (77.06 KB, image/jpeg)
2013-10-14 22:46 UTC, V Stuart Foote
Details
screencopy of the new new StartCenter (57.73 KB, image/png)
2013-11-16 21:13 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2013-10-14 18:10:05 UTC
Created attachment 87617 [details]
screencopy of the new StartCenter

Please have a look at attached screencopy.
The six module icons do not follow the option defined in manu Tools > Options > LibreOffice > View.
The icons should have at least the same size as in the current StartCenter

There is a very large not used room in the toolbar containing these icons

The fact that the words Open and Templates are buttons should be made more clear.

Best regards. JBF
Comment 1 Arnaud Versini 2013-10-14 18:26:01 UTC
Confirmed on Ubuntu
Comment 2 V Stuart Foote 2013-10-14 22:46:24 UTC
Created attachment 87634 [details]
alternate mockup of StartCenter using composite icon and text button

Not too small, just the size last selected by dev to match UX white board.
https://wiki.documentfoundation.org/Design/Whiteboards/Start_Center

And comments on the UX-Advise forum
https://wiki.documentfoundation.org/Design/Whiteboards/Start_Center

Some substantive work still to be done on the UI, notably ability to toggle between the recent documents thumbnail view list and a "details" listing.

And on the Design forum had a solid Design mockup posted today that I think looks better than the icon based buttons that Krisztian has used for his GSoC project based on UX white board mockup.

http://nabble.documentfoundation.org/Welcome-graphics-for-the-Startcenter-in-4-2-tc4077497.html

I've uploaded the mockup JPEG submitted by Mateusz Zasuwik here. It shows an alternative with the UI Widget buttons implemented as other than icons.
Comment 3 V Stuart Foote 2013-10-14 23:00:01 UTC
Sorry, copied one of the links twice.  Second should have been this UX-Advise thread for discussion thus far on the Widget layout for StartCenter:

http://nabble.documentfoundation.org/Libreoffice-ux-advise-GSoC-Use-Widget-Layout-for-the-Start-Center-tt4067078.html
Comment 4 Thomas Arnhold 2013-10-20 09:57:29 UTC
*** Bug 70050 has been marked as a duplicate of this bug. ***
Comment 5 Thomas Arnhold 2013-10-20 09:59:57 UTC
I totally with Mateusz Zasuwiks idea. This would merge the old and new design and solve the problem with the tiny icons. This would look great!
Comment 6 Jean-Baptiste Faure 2013-11-16 21:13:13 UTC
Created attachment 89338 [details]
screencopy of the new new StartCenter

The new new StartCenter fixes this problem.

Best regards. JBF