Download it now!
Bug 70491 - FILESAVE: Cell-anchored drawing objects do not stay put after save, close, open
Summary: FILESAVE: Cell-anchored drawing objects do not stay put after save, close, open
Status: RESOLVED DUPLICATE of bug 67712
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-15 10:52 UTC by Ekki
Modified: 2014-03-05 12:46 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ekki 2013-10-15 10:52:38 UTC
Problem description: 
When drawing a line into a spreadsheet _and_ anchoring this line to the cell (not the page as is default), this line does not stay at this place when saving, closing and reopening the document.


Steps to reproduce:
1. Start a new spreadsheet
2. draw a line from one cell to another
3. change anchoring of this line to "Cell" (instead of "page")
4. Save
5. Close
6. Reopen
7. Try finding your line. If your lucky it's still on the page, up in the left upper corner. But sometimes they are even entirely gone.


Current behavior:
Line does not stay anchored to cell after save/close.

Expected behavior:
Line or any drawing object marked as "anchored to cell" should stay where it is after saving,closing.


              
Operating System: Linux (Other)
Version: 4.1.2.3 rc
Comment 1 Stephan van den Akker 2013-10-15 11:18:12 UTC
Confirmed on openSuSE 11.4 (64-bit) in:

LO Version: 4.1.2.3
Build ID: 40b2d7fde7e8d2d7bc5a449dc65df4d08a7dd38

LOdev Version: 4.2.0.0.alpha0+
Build ID: e5c370e53d8701d863d231c26ce8e5c46385e5eb

Problem does not occur in:

OpenOffice.org 3.3.0 OOO330m20 (Build 9567) on Windows XP (32-bit)

In this older version Calc seems to default to anchor to cell. (Step 3 can be skipped).
Comment 2 Mohamed-Ali BEN MANSOUR 2014-03-05 12:46:09 UTC

*** This bug has been marked as a duplicate of bug 67712 ***