Download it now!
Bug 70496 - Other: Native mySQLConnector for windows against 4.1 code base
Summary: Other: Native mySQLConnector for windows against 4.1 code base
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.3.1 rc
Hardware: All All
: medium normal
Assignee: Lionel Elie Mamane
URL:
Whiteboard: BSA target:4.2.0 target:4.1.4
Keywords:
: 82336 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-15 14:11 UTC by Fernand
Modified: 2014-09-05 07:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
mySQL dumps of 2 tables (144 bytes, text/plain)
2013-10-15 14:39 UTC, Fernand
Details
MySQL connector for the 4.0 code base (442.56 KB, application/vnd.openofficeorg.extension)
2013-10-15 14:42 UTC, Fernand
Details
mySQL connector for 4.1 code base (442.21 KB, application/vnd.openofficeorg.extension)
2013-10-15 14:43 UTC, Fernand
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fernand 2013-10-15 14:11:33 UTC
The connector build against 4.1.3 craches with XP
works for win7 and win8 but chrash when opening some tables who are opening without problem with 4.0 and his Connector

1. win XP Trye to open a connection with the joined Connector 1.0.2
2. Win7 or Win8 Make a odb document and connect to a MySQL server with the joined table dumps installed....
3. Try to open the smalest table "agendas" who do crash LO
4. Try to open the bigest table "Jobactions" who makes LO waiting forever...




              
Operating System: Windows (other)
Version: 4.1.3.1 rc
Last worked in: 4.0.5.2 release
Comment 1 Fernand 2013-10-15 14:39:07 UTC
Created attachment 87669 [details]
mySQL dumps of 2 tables
Comment 2 Fernand 2013-10-15 14:42:17 UTC
Created attachment 87670 [details]
MySQL connector for the 4.0 code base
Comment 3 Fernand 2013-10-15 14:43:42 UTC
Created attachment 87671 [details]
mySQL connector for 4.1 code base
Comment 4 Fernand 2013-10-15 15:16:23 UTC
using ODBC as connector lets opens both tables

so the problem is probably due to the Native Connector
Comment 5 Lionel Elie Mamane 2013-10-19 05:11:06 UTC
Reproduced on GNU/Linux. The crash is in libmariadb...
Comment 6 Lionel Elie Mamane 2013-10-19 05:21:32 UTC
Yup, replacing libmariadb by libmysql solves the crash. Trying to update to newer version of libmariadb...
Comment 7 Lionel Elie Mamane 2013-10-19 14:20:40 UTC
So, this looks to me like a libmariadb bug. Updating to latest bzr checkout does not help. I'm considering switching back to libmysql.
Comment 8 Lionel Elie Mamane 2013-10-19 21:04:36 UTC
(In reply to comment #7)
> I'm considering switching back to libmysql.

I just did that in master.
Comment 9 Commit Notification 2013-10-19 21:13:27 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=02a11749da521e8e2099b464c0fcbebce9e95e22

fdo#70496 revert to using libmysqlclient



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Julien Nabet 2013-10-19 21:30:34 UTC
Lionel: just for my info, does it mean we abandon MariaDB or just for the moment because of this bug?
Comment 11 Jesus Corrius 2013-10-20 08:39:02 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > I'm considering switching back to libmysql.
> 
> I just did that in master.

@Lionel, what about 4.1?
Comment 12 Fernand 2013-10-20 08:58:30 UTC
Jésus, and others,
This weekend is worked with the 1.0.2 (build for 4.1) using LO 4.0.5.3 flawlesly ?
Comment 13 Commit Notification 2013-10-22 09:21:30 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f4d728ab649f0f743e09a744a63565f1cbdf6e88&h=libreoffice-4-1

fdo#70496 revert to using libmysqlclient


It will be available in LibreOffice 4.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Lionel Elie Mamane 2014-09-05 07:44:50 UTC
*** Bug 82336 has been marked as a duplicate of this bug. ***