Bug 70499 - FILEOPEN Cannot select unprotected cells in XSLX sheet with worksheet protection
Summary: FILEOPEN Cannot select unprotected cells in XSLX sheet with worksheet protection
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: All All
: highest major
Assignee: Noel Power
QA Contact:
URL:
Whiteboard: target:4.3.0 target:4.2.0.0.beta2 tar...
Keywords: bibisected, regression
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-10-15 16:09 UTC by Liam Brennan
Modified: 2015-12-15 22:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Spreadsheet showing problem (8.56 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-10-15 16:09 UTC, Liam Brennan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Liam Brennan 2013-10-15 16:09:44 UTC
Created attachment 87673 [details]
Spreadsheet showing problem

When a protected [No Password]excel (2007) worksheet having unprotected cells is saved as xslx and opened in LibreOffice 4.1.2.3 it is not possible to select the unprotected cells or to make any changes to protected cells.

The problem does not arise in 4.0.3 or if the worksheet is saved as xls.


How to recreate problem

Create sheet in excel 2007 range d4:g9 formatted as unprotected and rest of cells protected. Fill with yellow to make it clear which cells are unprotected.
Save sheet as xslx.
Open sheet in LibreOffice 4.1.2 as released.
try and select yellow (unprotected) cell - not possible.
Select protected cell - it is possible, though it should not be since protection set to allow selection of unprotected cells and not of protected cells.

Workaround
None identified.
Comment 1 ign_christian 2013-11-12 02:15:56 UTC
Confirm reproducible with LO 4.0.6.2 (Win7 32bit). Perhaps related to fix in Bug 64753.
Comment 2 stragu 2013-11-20 06:19:24 UTC
I am also affected by this in 4.1.2.3 on Ubuntu 13.10.
This is extremely disruptive as a lot of forms come as partially protected xlsx documents.

I confirm it with two different spreadsheets I got from two different suppliers, as well as with the first attachment in this bug.

Here is a related question in AskLibreOffice:
http://ask.libreoffice.org/en/question/21430/partially-protected-excel-spreadsheets-import-completely-protected/
Comment 3 Joel Madero 2013-11-20 07:02:39 UTC
quite nasty - updating some info + bibisected

de07cd3f6a04dff5ba9658ed605a714f04cca8be is the first bad commit
commit de07cd3f6a04dff5ba9658ed605a714f04cca8be
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Oct 17 21:37:45 2013 +0000

    source-hash-7e07a45500dcbb891a85f0bc9b7049cf4d50bba1
    
    commit 7e07a45500dcbb891a85f0bc9b7049cf4d50bba1
    Author:     Artur Dryomov <artur.dryomov@gmail.com>
    AuthorDate: Thu Aug 1 19:44:47 2013 +0300
    Commit:     Artur Dryomov <artur.dryomov@gmail.com>
    CommitDate: Thu Aug 1 19:47:07 2013 +0300
    
        Change search timeouts from milliseconds to seconds.
    
        Makes things readable and should prevent potential typing bugs.
    
        Change-Id: Ifcb90568859e94896f5c2a313546fe1fdd6fa4bc

:100644 100644 5dd3a54ff8a0364d75d843b397692a430fd8124a 544cfd9548d69bff9c9c30be50cabc81766fd9f7 M	ccache.log
:100644 100644 7f39d8595243d10cc0b50016a8efe85fc89792f6 16838b727072451a7bbd7767c24c8cab8ead5ed9 M	commitmsg
:100644 100644 af2806fff308118fbd9c7a1a1b5c5a9ebd529e67 050f3df863d18d040a06f6423129222022821ad4 M	dev-install.log
:100644 100644 9c9052d1fda326cbdcff4c1e0d6e0a2eb9a53c5b 80a335232f0e4d8dba90aa5be0f2103d9911a05c M	make.log
:040000 040000 7caa41f13849d0812e76436d5beb27b231cb4316 6cc9fdeec9a2baa02eed680eca8f8f5d319c2148 M	opt


# bad: [25428b1e953636f74986622c5df614f04c150ed1] source-hash-cb4e009c4539c535108021934e545194b35cad9d
# good: [f0f6c65eb764f0303f59c58d320e9b0d5a894377] source-hash-4b9740b4ec3987e1d4d2ad6d20b4dcf996a4fa2e
git bisect start 'latest' 'oldest'
# good: [a72833796a7e527d9efc9ca6d8fe9b579e469105] source-hash-1472b5f87314fe660ef1a7b254e51272669f12f6
git bisect good a72833796a7e527d9efc9ca6d8fe9b579e469105
# good: [b21386bf459ae47bd6e461ea94cea6a06729a1ff] source-hash-570fe620e9d573cfc9fc260e6518563c6a6c1a3c
git bisect good b21386bf459ae47bd6e461ea94cea6a06729a1ff
# bad: [091d742e82f2b4608690c697d14f846ffc9164c7] source-hash-349c91c8ec6afc1f5c8499529d559af34d115a76
git bisect bad 091d742e82f2b4608690c697d14f846ffc9164c7
# bad: [8f9ca7d8ab2e98061706d2fae7501b75a902d93a] source-hash-3cf0b5cdb05e1d77610431b1b1328102bf05b602
git bisect bad 8f9ca7d8ab2e98061706d2fae7501b75a902d93a
# good: [465574e6f80fc8ee8b25af11b723c599a35321f2] source-hash-a38f09fec16f24886414c3e9f9574a06b56d8077
git bisect good 465574e6f80fc8ee8b25af11b723c599a35321f2
# bad: [a3fcb4751e6dc8cfe81dd45192706bd7ac5345de] source-hash-ae0493ccfe7c232557fb87eef4d0444709d8b729
git bisect bad a3fcb4751e6dc8cfe81dd45192706bd7ac5345de
# bad: [de07cd3f6a04dff5ba9658ed605a714f04cca8be] source-hash-7e07a45500dcbb891a85f0bc9b7049cf4d50bba1
git bisect bad de07cd3f6a04dff5ba9658ed605a714f04cca8be
# good: [058bad5cab9e4959a625631e718b95e713676a59] source-hash-83ff6c0f4101fe4f25c2b4a58c70b40de8cc2ff2
git bisect good 058bad5cab9e4959a625631e718b95e713676a59
Comment 4 stragu 2013-11-21 00:38:56 UTC
I can confirm that this is not present in 4.0.5.2

I had to downgrade to this version to be able to fill in forms.

Anyone needing to do that: http://downloadarchive.documentfoundation.org/libreoffice/old/4.0.5.2/deb/
Comment 5 Noel Power 2013-11-21 14:33:40 UTC
I'll take a quick look
Comment 6 Markus Mohrhard 2013-11-24 17:00:33 UTC
That is already fixed in master.
Comment 7 Markus Mohrhard 2013-11-24 17:01:17 UTC

*** This bug has been marked as a duplicate of bug 70315 ***
Comment 8 stragu 2013-11-24 22:25:03 UTC
Brilliant, thanks everyone :)
Comment 9 Noel Power 2013-11-25 11:18:00 UTC
this is NOT a duplicate bug# 70315
Comment 10 Commit Notification 2013-11-25 11:18:16 UTC
Noel Power committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5728a56b20e01d6c9e86a23f20af64a1b68ad604

fdo#70499 selectn of lock/unlocked cells with worksheet protection reversed



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 stragu 2013-11-26 00:18:00 UTC
Noel, is this going to be in 4.1.4, or does the whiteboard target mean that it is only going to be a fix available in 4.3? (to be released in July 2014!)
Comment 12 Joel Madero 2013-11-26 01:02:32 UTC
Until it's marked as FIXED it means that we're still working on it :) The target just means that it's been committed to 4.3 already, but it'll need additional testing to make it into other releases.
Comment 13 Commit Notification 2013-11-27 23:32:20 UTC
Noel Power committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bf35ce3f91c8ee3f06a7a6c7a10dd17f05198ce5&h=libreoffice-4-2

fdo#70499 selectn of lock/unlocked cells with worksheet protection reversed


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 stragu 2013-11-28 01:10:03 UTC
Thanks Noel for this.
Is this too heavy/risky to include in the 4.1 cycle?
As I said, it is a pretty serious flaw that administrations and businesses will suffer from (in the form-filling case). They would need to wait for a stable enough version of 4.2, and that would not be an option for some. (4.2.3 is supposed to be out in May 2014!)
Comment 15 Commit Notification 2013-12-13 16:09:24 UTC
Noel Power committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ed0f9df37cac6c2e8d886488b2dbbe1034e0d385&h=libreoffice-4-1

fdo#70499 selectn of lock/unlocked cells with worksheet protection reversed


It will be available in LibreOffice 4.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Kohei Yoshida 2013-12-13 16:10:15 UTC
Backported to 4.1.x.  I call it fixed.
Comment 17 Ryan K 2014-01-24 14:20:33 UTC
I am still experiencing this bug in LibO 4.1.3.2 (official Ubuntu 13.10 version). Has the patch been backported to this version?
Comment 18 Ryan K 2014-01-24 14:33:22 UTC
...also on 4.1.4.2 from the Libreoffice PPA
Comment 19 retired 2014-01-24 15:05:47 UTC
I see "It will be available in LibreOffice 4.1.5." so please wait or try http://www.libreoffice.org/download/pre-releases/
Comment 20 stragu 2014-01-24 15:06:32 UTC
I just tested this with 4.1.5 RC1 and it is fixed.
4.1.5 final is supposed to be released in the week Feb 3, 2014 - Feb 9, 2014.
It is also apparently fixed in 4.2.0, which should be out in the week Jan 27, 2014 - Feb 2, 2014, athough you might want to opt for the more stable option (4.1.5).
Comment 21 stragu 2014-01-24 15:09:10 UTC
If you can't wait, here are the pre-releases:
https://www.libreoffice.org/download/pre-releases/
Comment 22 Joel Madero 2014-01-24 15:10:57 UTC
IMHO unless you are working on a work machine or something - no reason why you can't use 4.2.0 rc as it's stable, I've been using it since rc1 and it's stable for me to use for daily use
Comment 23 stragu 2014-01-24 15:23:22 UTC
Hi Joel

It's probably not the best place to discuss this, but I gave this recommendation as it is not uncommon to see bugs like the one described here take quite a bit of time to get fixed (fifth bugfix version for this one).
In my case, this particular bug is a show-stopper as it would not let me fill in a simple business or admin form.
From my experience, I just expect to see a few MAB showing up with 4.2.0 that would make it just a bit annoying to use for some people, depending on what their needs are.
Might be a language issue though: I said "stable", but maybe I should have used another term - I did not mean that I expected 4.2.0 to keep crashing on us :)

Cheers
Comment 24 Robinson Tryon (qubit) 2015-12-15 22:21:06 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
Remove redundant 'ConfirmedRegression'
[NinjaEdit]