Download it now!
Bug 70512 - FILTER: Function ISOWEEKNUM in MS Excel returns an error in a spreadsheet saved to .ODS and re-opened.
Summary: FILTER: Function ISOWEEKNUM in MS Excel returns an error in a spreadsheet sav...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-15 22:01 UTC by John Smith
Modified: 2016-01-05 15:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
An ODT document, illustrating with screenshots, the steps described above. (77.47 KB, application/vnd.oasis.opendocument.text)
2013-10-15 22:01 UTC, John Smith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Smith 2013-10-15 22:01:06 UTC
Created attachment 87702 [details]
An ODT document, illustrating with screenshots, the steps described above.

Problem description: 
Importing an Excel spreadsheet containing the ISOWEEKNUM function, saving it to ODS format, then re-opening it causes an error.
Steps to reproduce:
1. Import the Excel 2013 spreadsheet from the location given in the attached document, selecting to view it in Calc.
2. The spreadsheet displays as i the first graphic of the attachment.
3. Save the spreadsheet as an ODS format spreadsheet.Close the open document.
4. Re-open it in Calc.
Current behavior: The error as shown in the second graphic in the attachment is displayed

Expected behavior: That an import filter would permit a correct display.

              
Operating System: Windows XP
Version: 4.1.1.2 release
Comment 1 John Smith 2013-10-15 22:03:53 UTC
Bug report 50488 and bug report 50950 also have comments relating to this function and are probably relevant.
Comment 2 Joel Madero 2014-07-20 19:51:31 UTC
Hi John Smith - please attach the original xlsx sheet (or a new one) so that we can actually save it as an ODT and then see the problem. Note that many of our users (and QA) don't own or use Microsoft Office so recreating xlsx sheets on MS 2013 can be rough.

Marking as NEEDINFO - once you attach the original (or a new XLSX) sheet please set to UNCONFIRMED and I'll try to confirm the problem.
Comment 3 Winfried Donkers (retired) 2014-10-24 15:40:28 UTC
I confirm that importing ISOWEEKNUM function from Excel produces an error.

If all goes according to plan, this bug will be fixed with the patch for bug 50950.
Comment 4 QA Administrators 2015-12-20 16:13:00 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)
   https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 

4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-12-20
Comment 5 Eike Rathke 2016-01-05 15:05:23 UTC
Should be fixed with bug 50950 for 5.1