Download it now!
Bug 70520 - Enter, Autocorrection and Undo
Summary: Enter, Autocorrection and Undo
Status: RESOLVED DUPLICATE of bug 44062
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-16 07:10 UTC by Urmas
Modified: 2016-09-28 14:19 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2013-10-16 07:10:28 UTC
When Enter key is pressed to form a new paragraph and that action causes autocorrection, like capital letter insertion, this action precedes the creation of the paragraph in Undo stack.

In normal software, the autocorrection is undone first, then Enter key effect.
Comment 1 Tomaz Vajngerl 2013-10-16 07:39:03 UTC
Confirmed. But still - how does this bug make LO not-normal software? :)
Comment 2 Jean-Baptiste Faure 2013-12-22 14:25:31 UTC
I do not understand what you mean because it is not hitting Enter key which causes "capital letter insertion" autocorrection but the insertion of a space after the first word of the new paragraph. 

I tried this:
1/ open a new empty text document
2/ type dt+F3 (autotext "dummy text")
3/ click at the end of the text and hit the Enter key
4/ type some word like "example"
5/ press the space bar example becomes Example
6/ press ctrl+Z ==> Example becomes example
7/ press ctrl+Z ==> space after "example" removed
8/ press ctrl+Z ==> the word example is removed
9/ press ctrl+Z ==> the new paragraph is removed

Tested with versions 4.0.6, 4.1.4 and 4.2.0.1+ under Ubuntu 13.10 x86-64 with each time the same result.

I propose to close this bug report as WorksForMe

Best regards. JBF
Comment 3 Urmas 2013-12-22 16:20:27 UTC
Do not press Space, press Enter, as described.
Comment 4 Jean-Baptiste Faure 2013-12-22 17:20:48 UTC
(In reply to comment #3)
> Do not press Space, press Enter, as described.

Do you mean press Enter key after the first word in the new paragraph ? 

Best regards. JBF
Comment 5 patheticcockroach 2014-05-11 15:39:39 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > Do not press Space, press Enter, as described.
> 
> Do you mean press Enter key after the first word in the new paragraph ? 
> 
> Best regards. JBF

Yes, that's what he meant: press enter in your step 5)

This bug is really quite annoying, and resulted in my disabling most of auto-corrections, as it makes them do more harm than good. I understand that you could argue this behavior works "as intended", except that if it is so, the behavior should be the same with both "space" and "enter", which is not the case. So it's definitely a bug (not an enhancement as suggested in Bug 44062).
Comment 6 QA Administrators 2015-09-04 02:48:09 UTC Comment hidden (obsolete)
Comment 7 patheticcockroach 2015-09-04 06:39:12 UTC
Hello,

I confirm that the bug is still present in LibO 5.0.1.2 on Win 7 x64. The behavior seems actually _worse_. For instance:

CASE 1: bad behavior (bug)
1) create a new document
2) type www.example.com
3) press ENTER
4) => auto correct = the text is turned into a URL
5) press CTRL+Z
6) => the new line is removed but the text still is a URL
7) press CTRL+Z again
8) => nothing happens (document flickers slightly) (_that's new as far as I remember!_)
9) press CTRL+Z yet again
10) => the URL finally turns back into a text

CASE 2: good behavior
1) create a new document
2) type www.example.com
3) press SPACE
4) => auto correct = the text is turned into a URL
5) press CTRL+Z
6) => the URL turns back into a text and the new space remains
7) press CTRL+Z again
8) => the space is removed
Comment 8 patheticcockroach 2015-10-22 10:30:24 UTC
As suggested in comment #6, I just tested the bug on LibO 3.3.0.4 on Windows XP:
- the bug is already here
- what I described as probably new in CASE 1 part 8) is indeed not here

So setting version to "inherited from OOo"
Comment 9 Buovjaga 2016-09-28 14:17:00 UTC
*** Bug 90645 has been marked as a duplicate of this bug. ***
Comment 10 Buovjaga 2016-09-28 14:19:24 UTC

*** This bug has been marked as a duplicate of bug 44062 ***