Bug 70525 - EDITING: Problem with scroll content of LibreOffice spreadsheet cell on big cell height.
Summary: EDITING: Problem with scroll content of LibreOffice spreadsheet cell on big c...
Status: RESOLVED DUPLICATE of bug 34689
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-16 09:20 UTC by stulovd
Modified: 2018-09-18 12:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
A spreadsheet doc with merged cells big enough to really "feel" the problem. (9.27 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-12-21 13:42 UTC, eriolloan@gmail.com
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stulovd 2013-10-16 09:20:02 UTC
Problem description: 

Steps to reproduce:
1. Make cell with many lines of text in it(not fit in one screen by height)
2. Try to scroll to end of text


Current behavior: You don't view and of cell. After try to scrol to end of cell you see next cell, so no way to see part of content not fit in one page.

Expected behavior:
On scroll big cell scroll cell to end before switch to next cell
              
Operating System: Windows 7
Version: 4.1.1.2 release
Comment 1 Dominique Boutry 2013-10-24 12:34:05 UTC
Reproduced with LibO 4.1.2.3 on Win7.

A precision : after "Try to scroll to end of text", add "with the main panel right scrollbar" ; the scroll in the formula field is OK, it permits to see the end of big cells content, one at a time.

About the proposed "expected behavior" : to deal with very very big contents, I propose the rewording "On big cell scroll, before switching to next cell, scroll cell to next vertical hidden slice of data".

Why not the same proposal along the horizontal axis (pb probably more frequent) ?

In any case, that involves the ability to go beyond the current characteristic "always the left-high corner of a cell at the left-high corner of the main grid". Some thinking of the consequence still to conduct. IMHO enhancement.
Comment 2 Joel Madero 2014-07-21 01:46:54 UTC
Please attach a test document where we can see this problem so we are sure we're seeing the same issue.

Marking as NEEDINFO - once an attachment is added mark as UNCONFIRMED and we'll go from there. Thanks!
Comment 3 QA Administrators 2015-02-19 04:35:10 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2015-04-01 14:51:48 UTC Comment hidden (obsolete)
Comment 5 eriolloan@gmail.com 2017-12-21 13:42:13 UTC
Created attachment 138567 [details]
A spreadsheet doc with merged cells big enough to really "feel" the problem.

I can confirm that this issue is still here. See the linked file features merged cells that block the scrolling until the user has scrolled enough for the view to change.

Come on, you're about to update LO version number to 6. I've been testing the beta and this annoyance is still something we have to deal with, while most other spreadsheets are using smooth scrolling for a while now.
Comment 6 eriolloan@gmail.com 2017-12-21 13:46:24 UTC
You can reproduce it on mac, linux and windows (I've tested on 7 and 10), with a mouse or a trackpad, no difference. 

It most certainly has to do with the way Calc handles the view.
Comment 7 Olivier Tilloy 2018-09-18 12:52:06 UTC

*** This bug has been marked as a duplicate of bug 34689 ***