Download it now!
Bug 70614 - EDITING: Calc freezes when moving cells
Summary: EDITING: Calc freezes when moving cells
Status: RESOLVED DUPLICATE of bug 67011
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
: 70649 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-18 12:05 UTC by prymeroot
Modified: 2013-10-20 11:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample (6.46 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-10-18 12:05 UTC, prymeroot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description prymeroot 2013-10-18 12:05:00 UTC
Created attachment 87821 [details]
Sample

Problem description: 

So, when I try
to move cells using drag-and-drop method, Calc freezes almost everything
– I can only move the cursor (everything else to do in X is impossible,
so it's necessary to kill the process from TTY). I'm forced to move
cells through cut and paste, which is not very handily. It's connected with libreoffice-kde4 package in Arch Linux. Without that package everything works.

Steps to reproduce:
Just select any cell and try to move it by drag-and-drop.

KDE version: 4.11.2, Qt version: 4.8.5.
Operating System: Linux (Other)
Version: 4.1.2.3 release
Comment 1 tommy27 2013-10-19 16:02:57 UTC
*** Bug 70649 has been marked as a duplicate of this bug. ***
Comment 2 tommy27 2013-10-19 16:07:10 UTC
Set status to NEW since issue has been confirmed by another user in Bug 70649.
according to that report it worked fine in 4.1.0.4, hence regression.

No issue with Win7 64bit so bug is probably Linux specific.
Mac user feedback appreciated.

adding Calc expert to CC List
I raise importance to major
Comment 3 Maxim Monastirsky 2013-10-19 17:08:07 UTC

*** This bug has been marked as a duplicate of bug 67011 ***
Comment 4 cassius1898 2013-10-19 19:21:54 UTC
I reported same in another bug, and was requested to discuss here. I am using Kubuntu 13.10 with LibreOffice 4.1.2.3. The problem did not exist with Kubuntu 13.04, but I am unsure of the version of LibreOffice it was using.
Comment 5 prymeroot 2013-10-19 21:22:03 UTC
(In reply to comment #2)
> Set status to NEW since issue has been confirmed by another user in Bug
> 70649.
> according to that report it worked fine in 4.1.0.4, hence regression.
> 
> No issue with Win7 64bit so bug is probably Linux specific.
> Mac user feedback appreciated.
> 
> adding Calc expert to CC List
> I raise importance to major

As I mentioned, it's connected with libreoffice-kde4, which is responsible for integration into KDE. And I wrote that problem doesn't occur without this package.
Comment 6 tommy27 2013-10-20 03:50:31 UTC
it's better that we continue discussion in Bug 67011 which is the first report of this issue.
Comment 7 cassius1898 2013-10-20 11:26:00 UTC
OK


On Sat, Oct 19, 2013 at 11:50 PM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 6 <https://bugs.freedesktop.org/show_bug.cgi?id=70614#c6> on bug
> 70614 <https://bugs.freedesktop.org/show_bug.cgi?id=70614> from tommy27<barta@quipo.it>
> *
>
> it's better that we continue discussion in Bug 67011 <https://bugs.freedesktop.org/show_bug.cgi?id=67011> which is the first report
> of this issue.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You are on the CC list for the bug.
>
>