Download it now!
Bug 70641 - No connection to KDE address book possible (see comment 10)
Summary: No connection to KDE address book possible (see comment 10)
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2013-10-19 08:46 UTC by Robert Großkopf
Modified: 2019-06-14 03:18 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2013-10-19 08:46:12 UTC
Open LO, File → New → Database → Connect to an existing database → KDE adress book → Next → No, do not register → open the database for editing → Finish and Save: Connection could not be established.

With Base you could connect (under Linux) to the addressbook of KDE. Up to the last Version 3.5.* the connection could be established, but no content is shown with my special addressbook - don't know why.

Same system, since LO 3.6.*, an error occured:
SQL Status: HY000
The connection to the external data source could not be established. No SDBC driver was found for the given URL.
A connection for the following URL was requested "sdbc:address:kab".

It's the same behavior with all versions up to 4.2.0.0 master from 2013-10-18.
Comment 1 Robinson Tryon (qubit) 2014-11-11 06:53:38 UTC
(In reply to robert from comment #0)
> Open LO, File → New → Database → Connect to an existing database → KDE
> adress book → Next → No, do not register → open the database for editing →
> Finish and Save: Connection could not be established.

TESTING with LO 4.4.0.0.alpha1 + Ubuntu 14.04

I tried the repro steps and did not get an error message about the connection, but LibreOffice did crash and provide the following information:

qubit@lo:~/lo$ terminate called after throwing an instance of 'com::sun::star::loader::CannotActivateFactoryException'

(Note: It's possible that I don't have any entries in the KDE Address book)

So while I didn't exactly confirm your behavior, I managed to crash LibreOffice using the same repro steps, which is pretty interesting. I'll get a 3rd set of eyes to take a look here.
Comment 2 Daniel Pastushchak 2014-12-12 18:22:53 UTC
Bug reproduced. I'm using Ubuntu 14.10 with KDE(4.14.1) and LibreOfficeDev Version: 4.5.0.0.alpha0+
Build ID: dad173d9588e6abc2a465198b7d2881d4629246a
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2014-12-10_22:53:28
Comment 3 Daniel Pastushchak 2014-12-12 18:24:12 UTC Comment hidden (obsolete)
Comment 4 Robinson Tryon (qubit) 2014-12-12 18:40:33 UTC
(In reply to Daniel Pastushchak from comment #3)
> Bug reproduced. 

Thanks for the repro!

Status -> NEW

Did you get the same error as Robert, or did LO crash for you?
Comment 5 Alex Thurgood 2015-01-03 17:40:12 UTC Comment hidden (no-value)
Comment 6 Julien Nabet 2015-10-11 17:57:36 UTC
Any update with recent LO versions? (I'm on Gnome not KDE so can't test myself).

It could be interesting to launch LO from console to retrieve all possible error/warn logs.
Comment 7 Robert Großkopf 2015-10-12 06:39:36 UTC
Tested this with LO 5.0.3.1. Error is the same:
No SDBC driver was found for the given URL. "sdbc:address:kab"

My system: openSUSE 20150319 (Tumbleweed), 64bit rpm Linux.
Comment 8 Buovjaga 2015-10-12 09:28:23 UTC
So let's keep this as NEW.
Comment 9 Julien Nabet 2015-10-15 20:52:57 UTC
On a laptop where I installed Kubuntu 15.04 to give it a try (I usually use XFCE with Gnome on my main laptop with Debian), I tried to reproduce with master sources updated today.

I used --enable-kde4 but didn't even have KDE Adressbook.
Discussing a bit on IRC, I've been advised to try "--disable-tdeab", but no success (I runned ./autogen.sh && make && make postprocess.clean && make postprocess + clean LO profile)

Then I searched about tde that I didn't know, Googling a bit indicated me that it was Trinity Desktop Env, a fork of kde 3.5. But "kab" isn't it the addressbook of kde4 too?

I noticed some commits related to kab:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=e382d3782c171bb7962d21662d86669a76ffc8d0
or http://cgit.freedesktop.org/libreoffice/core/commit/?id=4d4835cc55561b7ccdd628fa3a40d71fc9e9ff9e
but it seems only related to TDE's integration, not kab in general.

Michael: noticing http://cgit.freedesktop.org/libreoffice/core/commit/?id=72699595aaa3ecb8975050b6dfc6fde437770493
remove KDE3 support, --enable-kde and --enable-kdeab
With the new RHEL6-era baseline TDF can finally ship KDE4 support.
thought you might have some hints.
Comment 10 Michael Stahl (CIB) 2015-10-20 19:43:36 UTC
the KDE address book driver in connectivity only supports KDE3, and was removed on master since KDE3 is obsolete.

the TDE address book driver still exists (for now) and is in fact the same code as the KDE3 one, but only supports TDE.

there has not ever been support for KDE4 or later address books

=> setting this to "enhancement" and CC: some KDE folks
Comment 11 Julien Nabet 2015-10-21 07:19:40 UTC
Thank you Michael for the detailed explanation!
Comment 12 Xisco Faulí 2019-06-13 15:46:22 UTC
Dear Robert Großkopf,
KDE4 support has been dropped in LibreOffice 6.3.
Could you please try to reproduce it with LibreOffice 6.3 Beta1 from https://wiki.documentfoundation.org/QA/GetInvolved#Test_Pre-releases ?
You can install it alongside the standard version.
I have set the bug's status to 'NEEDINFO'. Please change it back to 'NEW' if the bug is still present in the master build
Comment 13 Robert Großkopf 2019-06-13 18:38:25 UTC
I have tried to create a new connection to KDE adress book. There is no possibility to choose a connection to KDE adress book in all LO-versions since LO 5.1.*.

Seems the possibility to connect to this adressbook has been removed.

Tested with LO 6.3.0.0.beta1 and KDE 5.12.8 on OpenSUSE 15.

Don't know if we should closed this bug as WONTFIX. I'm not using this adressbook - doesn't use adressbooks at all. Have only detected the wrong behaviour while writing the Base-Handbook.
Comment 14 Buovjaga 2019-06-13 18:42:43 UTC
Comment 10 explains things, so let's make it clear in the summary.
Comment 15 Julien Nabet 2019-06-13 19:27:15 UTC
(In reply to Buovjaga from comment #14)
> Comment 10 explains things, so let's make it clear in the summary.

Comment 10 is from 2015. Since we dumped kde4, I don't think we should try to implement kde4 address book management.
So I'd be ok with Robert for WONTFIX
(just my personal opinion)
Comment 16 Jan-Marek Glogowski 2019-06-13 22:04:45 UTC
IMH(In reply to Julien Nabet from comment #15)
> (In reply to Buovjaga from comment #14)
> > Comment 10 explains things, so let's make it clear in the summary.
> 
> Comment 10 is from 2015. Since we dumped kde4, I don't think we should try
> to implement kde4 address book management.
> So I'd be ok with Robert for WONTFIX
> (just my personal opinion)

This is not about a particular KDE version. IMHO KDE PIM in KDE3 was quite popular, so someone implemented a DB driver to access its address book from LO. In KDE4 - still IMHO - PIM was a disaster to use; I gave up on it. Now there is KDE5. I have no idea about the quality of PIM in there.

As it stands some functionality was removed from LO, as it became obsoleted and nobody was interested in porting it to a newer version of KDE. Somebody might want to implement a DB driver for KDE5, so I think an enhancement report is still valid.
Comment 17 Buovjaga 2019-06-14 03:18:20 UTC
(In reply to Jan-Marek Glogowski from comment #16)
> IMH(In reply to Julien Nabet from comment #15)
> > (In reply to Buovjaga from comment #14)
> > > Comment 10 explains things, so let's make it clear in the summary.
> > 
> > Comment 10 is from 2015. Since we dumped kde4, I don't think we should try
> > to implement kde4 address book management.
> > So I'd be ok with Robert for WONTFIX
> > (just my personal opinion)
> 
> This is not about a particular KDE version. IMHO KDE PIM in KDE3 was quite
> popular, so someone implemented a DB driver to access its address book from
> LO. In KDE4 - still IMHO - PIM was a disaster to use; I gave up on it. Now
> there is KDE5. I have no idea about the quality of PIM in there.
> 
> As it stands some functionality was removed from LO, as it became obsoleted
> and nobody was interested in porting it to a newer version of KDE. Somebody
> might want to implement a DB driver for KDE5, so I think an enhancement
> report is still valid.

Yep, was coming here to say KDE5 is still valid.

https://userbase.kde.org/KAddressBook

PIM is still being actively worked on: https://www.dvratil.cz/2019/05/march-and-april-in-kde-pim/

Quote:
"KAddressBook

Volker also worked on preparing the KContacts library, a vCard standard implementation, to be moved to KDE Frameworks alongside KCalCore. You can read about this on his blog as well.
Improvements

As part of his code cleanup, Volker has removed the DataMatrix from contact display, so we only display the QR code now (Volker Krause, KDE Applications 19.08), and did massive clean up of the contact display code. When displaying contact address on a map, KAddressBook now defaults to OpenStreetMaps (Volker Krause, KDE Applications 19.08).

Thanks to Laurent Montel it is now also possible to send SMS messages from KAddressBook through KDE Connect (KDE Applications 19.08).
Bugfixes

    Fixed dialing contact’s phone-number from KAddressBook through KDE Connect (Volker Krause, D20353)"