Bug 70657 - FORMATTING: some pictures squashed or lost upon file save
Summary: FORMATTING: some pictures squashed or lost upon file save
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-19 23:40 UTC by leeksoup
Modified: 2015-04-21 04:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Testcase original Impress file (263.40 KB, application/vnd.oasis.opendocument.presentation)
2013-10-27 00:42 UTC, leeksoup
Details
Testcase PPTX file from Impress (298.44 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2013-10-27 00:44 UTC, leeksoup
Details

Note You need to log in before you can comment on or make changes to this bug.
Description leeksoup 2013-10-19 23:40:14 UTC
Problem description: 

Steps to reproduce:
1. Starting with a pptx presentation with images.
2. Modify something, e.g. add notes
3. Save, still in pptx format.
4. Reload.

Current behavior:
Some of the images disappear but there is a "box" with resize handles in the right places. Sometimes, instead the image is present but squashed vertically into a short, wide strip of colors.

Expected behavior:
Pictures remain unchanged upon save.

Operating System: Fedora
Version: 4.1.1.2 release
Comment 1 ign_christian 2013-10-20 01:21:51 UTC
Please try again with LO 4.0.2.3 & resetting user profile. If it doesn't work please attach your sample file & exact steps to reproduce the problem.

Then mark this bug UNCONFIRMED
Comment 2 ign_christian 2013-10-20 01:22:54 UTC
> Please try again with LO 4.0.2.3 & resetting user profile.
Ups..I meant LO 4.1.2.3
Comment 3 leeksoup 2013-10-20 05:02:54 UTC
Bug is still there with 4.1.2.3. I notice same behavior.

Will need to get hold of windows box to make test case but will try to do soon. Thanks.
Comment 4 leeksoup 2013-10-27 00:42:29 UTC
Created attachment 88162 [details]
Testcase original Impress file

The bug also appears if I begin with an odp (Impress) file with an image and then save it to pptx format. Not all images are affected. This test case shows the bug on my computer.
Comment 5 leeksoup 2013-10-27 00:44:25 UTC
Created attachment 88163 [details]
Testcase PPTX file from Impress

This is the PPTX file I get when saving the testcase into pptx format. When I open / reload the picture is gone, though there is still handles for it in the area where it used to be.
Comment 6 ign_christian 2013-10-28 03:02:34 UTC
I can partially reproduce with LO 4.0.6.2 (Win7 32bit). 

After saving as pptx, closing & reopening, image still there but resized. The others (background, etc) is the same with attachment 88163 [details]
Comment 7 Jean-Baptiste Faure 2013-11-24 13:03:29 UTC
Reproducible with version 4.1.4.0.0+ and 4.2.0.0.beta1+.

I think the problem is with jpeg images. If I extract the image, convert it in png format and replace the jpeg image with the png one, then the pptx export works as expected.

Best regards. JBF
Comment 8 QA Administrators 2015-04-19 03:20:33 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 9 Jean-Baptiste Faure 2015-04-21 04:57:35 UTC
Image problem is no longer reproducible with LibreOffice 4.4.4.0.0+ built at home under Ubuntu 14.10 x86-64.

Saving the pptx bugdoc with a small modification under the same pptx format reveals the image which was not visible in the original pptx bugdoc.
Saving the odp bugdoc as pptx keeps the image.

Closing as WorksForMe. Please, feel free to reopen if you disagree.

Best regards. JBF