Download it now!
Bug 70670 - FILESAVE: Secondary axis text rotation not saved
Summary: FILESAVE: Secondary axis text rotation not saved
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Markus Mohrhard
URL:
Whiteboard: BSA odf target:4.3.0 target:4.2.5
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-10-20 13:56 UTC by fldrivers
Modified: 2014-05-05 20:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file with some data and graph with two axis where secondary axis is saved with 0 degree rotation (38.32 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-10-20 13:56 UTC, fldrivers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fldrivers 2013-10-20 13:56:58 UTC
Created attachment 87875 [details]
Test file with some data and graph with two axis where secondary axis is saved with 0 degree rotation

Problem description: Secondary axis text rotation is not saved and after file save, close and load have default 90 degree rotation.

Steps to reproduce:
1. Set second axis text label rotation to 0 degrees
2. Save and close file
3. Open file

Current behavior: Text rotation is after load default 90 degrees

Expected behavior: Second axis could have saved 0 degree rotation

              
Operating System: Windows 7
Version: 4.1.2.3 release
Comment 1 Owen Genat (retired) 2013-11-23 10:14:22 UTC
Confirmed. Status set to NEW. Platform to All/All. The version could possibly be set back to v4.0.6.2, although the problem may stem from earlier in the v4.0.x series as this appears to be a regression in the v4.x series. Added Keyword regression. 

I have loaded the provided attachment under Ubuntu 10.04 x86_64 in these versions:

- v3.3.0.4 OOO330m19 Build: 6
- v3.4.6.2 OOO340m1 Build: 602
- v3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
- v3.6.7.2 Build ID: e183d5b
- v4.0.6.2 Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24
- v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

Only v4.0.6.2 and v4.1.3.2 display the text "t [°C]" at top right of the chart rotated at 90deg (it should be 0deg). Under both v4.0.6.2 and v4.1.3.2 setting it to 0deg, saving, exiting, and reloading shows it once again displayed with 90deg rotation. Object 1/content.xml shows:

<style:style style:name="ch11" style:family="chart">
   <style:text-properties fo:font-size="11pt" fo:font-weight="bold" style:font-size-asian="9pt" style:font-size-complex="9pt"/>
</style:style>
...
<chart:title svg:x="22.207cm" svg:y="0.831cm" chart:style-name="ch11">
   <text:p>t [°C]</text:p>
</chart:title>

By comparison the "[E Wh]" legend at bottom right of the graph has this XML:

<style:style style:name="ch6" style:family="chart">
   <style:chart-properties style:rotation-angle="0"/>
   <style:text-properties fo:font-size="10.5pt" fo:font-weight="bold" style:font-size-asian="9pt" style:font-size-complex="9pt"/>
</style:style>
...
<chart:title svg:x="21.539cm" svg:y="13.193cm" chart:style-name="ch6">
   <text:p>E [Wh]</text:p>
</chart:title>

I thought the style:chart-properties element with style:rotation-angle attribute might be missing from the first title, but opening the attachment under v3.6.7.2 and saving it under this version does not change the listed XML at all. The older versions simply seem to render the title in correct orientation.
Comment 2 Michael Stahl (CIB) 2014-02-04 12:18:00 UTC
bugdoc imported with 90° rotation since 4.0.0 release
Comment 3 Markus Mohrhard 2014-03-30 14:23:29 UTC
Looks like some UNO problem. The secondary axis seems to be handled differently than the primary axis despite using the same class.
Comment 4 Commit Notification 2014-05-01 00:36:41 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e0dcb2260e75935fcebd0774ea51568666874e95

be explicit about text rotations, fdo#70670



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2014-05-05 20:04:33 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=22d18dfa05e159c7f298e5eb49d8c89356cc5efb&h=libreoffice-4-2

be explicit about text rotations, fdo#70670


It will be available in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.