Bug Hunting Session
Bug 70692 - [Template manager] event not handled or dropped after child process/window returns: often difficult selection with actions not available ..
Summary: [Template manager] event not handled or dropped after child process/window re...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.1 rc
Hardware: Other All
: high major
Assignee: marc.parrish
URL:
Whiteboard: Confirmed:4.2.0.0.beta1:Ubuntu
Keywords:
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2013-10-20 19:29 UTC by Cor Nouws
Modified: 2014-07-24 18:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
raw GDB output --- (5.55 KB, text/plain)
2013-11-09 14:18 UTC, marc.parrish
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2013-10-20 19:29:08 UTC
- Start template manager
- click New folder
- hit Escape to close popup
- click on folder/category
 > no sign of selection
- now click again on folder/category
 > now the folder is selected


this happens with other actions too
Comment 1 marc.parrish 2013-10-27 04:25:18 UTC
came upon this while attempting to submit this as new.  I have replicated this bug as well.  after an action the window seems to remain in focus, but it does not process the next input whether on folder selection or even to close window. Clicking anywhere in the window allows the next input event to be processed.
Comment 2 marc.parrish 2013-10-29 00:49:47 UTC
trying to look into this some more.  I'm somewhat crippled because I'm new to LO and I have not yet set up a proper debugging env.   my guess is that this may be a development process glitch that is already known to those working on the template manager.  At the moment this glitch appears to be endemic to the template manager.  I'll note that this may be a dispatch / transaction manager issue -- but that is only my intuition , perhaps someone more familiar will jump in here
Comment 3 marc.parrish 2013-11-09 14:01:56 UTC
elevating status to high.  The glitch seems to be caught and handled by SfxDispatcher under normal run of program; under GDB: breaking at function SfxTemplateManagerDlg::OnTemplateImport causes OS (Ubuntu 12.04) to flag process as unresponsive -- issuing wait/kill dialog 

Will run debugger again with same break point and attach output.
Comment 4 marc.parrish 2013-11-09 14:18:30 UTC
Created attachment 88931 [details]
raw GDB output ---

Some raw debugging output stepping through the process in question
Comment 5 marc.parrish 2013-11-09 14:47:13 UTC
Comment on attachment 88931 [details]
raw GDB output ---

it appears that upon the function SfxTemplateManagerDlg::TBXViewHdl breaks and returns, it is handed off to Link::Call and then to Toolbox::Click and then Toolbox::MouseButtonDown 

<snip>
(gdb) n
SfxTemplateManagerDlg::TBXViewHdl (this=0x7fffffffc280) at /home/marc/libreoffice/sfx2/source/doc/templatedlg.cxx:497
497	        break;
(gdb) n
514	    return 0;
(gdb) n
515	}
(gdb) n
Link::Call (this=0xe5af28, pCaller=0xe5aad0) at /home/marc/libreoffice/include/tools/link.hxx:124
124	}
(gdb) n
ToolBox::Click (this=0xe5aad0) at /home/marc/libreoffice/vcl/source/window/toolbox2.cxx:455
455	}
(gdb) n
ToolBox::MouseButtonDown (this=0xe5aad0, rMEvt=...) at /home/marc/libreoffice/vcl/source/window/toolbox.cxx:4016

<snip>

so , I think this is the cause of this glitch, that upon returning, the process is handed off and falls through to the Toolbox::MouseButtonDown function which is waiting for a MouseButtonDown event before proceeding ... that explains the behaviour I have observed that any 'mousedown' event returns normal control to the child and parent window process ...
Comment 6 Robinson Tryon (qubit) 2013-11-24 23:06:12 UTC
CONFIRMED on LO Version: 4.2.0.0.beta1 + Ubuntu 12.04.3

Following repro steps in Comment #0.

Status -> NEW
Comment 7 Cor Nouws 2014-02-04 13:09:23 UTC
setting summary back to readable for 'normal humans' ;)

(Marc changed it to " hangs on function SfxTemplateManagerDlg::TBXViewHdl, which, upon returning tumbles through Link::Call; Toolbox::Click; Toolbox::MouseButtonDown "  earlier )
Comment 8 Cor Nouws 2014-05-16 18:40:47 UTC
@Cor, 
Can you pls check in the alpha version for 4.3.0:
  http://dev-builds.libreoffice.org/pre-releases/
@Cor:
Done: works there :)