Download it now!
Bug 70705 - PDF: Trying to open password-less file gives "PDF file is encrypted" error
Summary: PDF: Trying to open password-less file gives "PDF file is encrypted" error
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-20 21:29 UTC by Robinson Tryon (qubit)
Modified: 2017-09-07 09:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robinson Tryon (qubit) 2013-10-20 21:29:54 UTC
Testing  on Ubuntu 12.04.3 + LO 4.1.2.3

REPRO STEPS:
1) Try to open PDF of slides from the LibreOffice 2013 conference (see bug 70704)

RESULTS:
Get error "This PDF file is encrypted and can't be opened."

EXPECTED:
File should open without a password.


I filed Bug 70704 - "Password required on document that opens without using Acrobat" against poppler.
Comment 1 Arnaud Versini 2013-10-20 21:45:56 UTC
Confirmed on LibreOffice 4.1.2.3. PDF doesn't work on Evince, but works on Acrobat for Android.
Comment 2 tommy27 2014-11-02 09:45:03 UTC
please retest with LibO 4.3.3.2 and give feedback about the bug status
Comment 3 Arnaud Versini 2014-11-02 10:01:29 UTC
Still on 4.3.2, and Poppler bug report still opened.
Comment 4 Robinson Tryon (qubit) 2015-01-25 11:02:32 UTC
Now that LO and Poppler are on separate Bugzilla installs, re-linking these two bugs together.
Comment 5 QA Administrators 2016-02-21 08:36:16 UTC Comment hidden (obsolete)
Comment 6 Aron Budea 2016-08-04 00:23:21 UTC
Still occurring as of LibreOffice 5.2.0.4.
Comment 7 QA Administrators 2017-09-01 11:17:48 UTC Comment hidden (obsolete)
Comment 8 Arnaud Versini 2017-09-07 09:20:38 UTC
Works perfectly with LibreOffice 5.4.0.3 and poppler 0.57.
Comment 9 Aron Budea 2017-09-07 09:34:32 UTC
Thanks for testing. Let's use WORKSFORME, since the change fixing the issue is not known.