Download it now!
Bug 70753 - FILESAVE: "Export Directly to PDF or save as PDF both result in a pdf file which shows all checkboxes as checked in OS X preview while not all are checked
Summary: FILESAVE: "Export Directly to PDF or save as PDF both result in a pdf file wh...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-22 08:38 UTC by retired
Modified: 2015-10-19 11:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
test file (15.16 KB, application/zip)
2013-10-22 08:38 UTC, retired
Details
checkbox bug - odt test file (11.30 KB, application/vnd.oasis.opendocument.text)
2015-09-02 10:30 UTC, steve -_-
Details
checkbox bug - exported pdf (5.66 KB, application/save)
2015-09-02 10:30 UTC, steve -_-
Details
screenshot showing the problem (144.67 KB, image/jpeg)
2015-09-02 10:30 UTC, steve -_-
Details

Note You need to log in before you can comment on or make changes to this bug.
Description retired 2013-10-22 08:38:30 UTC
Created attachment 87972 [details]
test file

Problem description: checkboxes in exported pdf are all checked, despite not all being checked in writer document.

Steps to reproduce:
1. open example odt file
2. use LO own pdf export option to create a pdf

Current behavior: when opening exported pdf, all checkboxes are checked

Expected behavior: only boxes checked, that are checked in original odt file

              
Operating System: Mac OS X
Version: 4.2.0.0.alpha0+ Master
Comment 1 retired 2013-10-22 08:41:14 UTC
Happens with LO 4.1.2.3.

Already fixed in Version: 4.2.0.0.alpha0+
Build ID: f4d3954fc6106b3ae0ee16ab0fcde15d8cb945e3

so setting worksforme.

Excuse the noise.
Comment 2 retired 2013-10-22 08:43:02 UTC
Just happened even with nightly build. So reopening.
Comment 3 retired 2013-10-22 08:45:34 UTC
This is getting interesting. Seems to be a bug with the OS X QuickLook plugin. In the quicklook plugin all checkboxes are checked, but when opening the pdf with a pdf viewer they are correct (when exported via nightly build). Interesting.

Would that mean create a separate bug or change title? QA?
Comment 4 oscar valenzuela 2014-10-26 18:59:34 UTC
No repro in LibreOffice (Dev) 4.4.0 alpha1 under Mac OS X 10.10 (Yosemite) x86-64. Marked as resolved, feel free to reopen and leave your comment.
Comment 5 retired 2014-10-27 10:32:53 UTC
4.3.3.1 persisting. can't test 4.4 nightly because it crashes like crazy on 10.10 for me.
Comment 6 steve -_- 2015-09-02 10:30:02 UTC
Why was this marked WORKESFORME?

This has never been fixed and is persisting on

OS X 10.10.5
LO Version: 5.1.0.0.alpha1+
Build ID: fd3d1bbaa9ab338f374fd20798fca71a888c9ab7
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-09-02_07:12:47
Locale: de-DE (de.UTF-8)

Attaching better test files.
Comment 7 steve -_- 2015-09-02 10:30:16 UTC
Created attachment 118331 [details]
checkbox bug - odt test file
Comment 8 steve -_- 2015-09-02 10:30:37 UTC
Created attachment 118332 [details]
checkbox bug - exported pdf
Comment 9 steve -_- 2015-09-02 10:30:55 UTC
Created attachment 118334 [details]
screenshot showing the problem
Comment 10 steve -_- 2015-09-02 10:33:37 UTC
This might be NOTOURBUG and related to OS X preview and apple doing a bad job at correctly rendering the preview of the exported PDF file. But before setting to that state, it would be great to get some dev feedback on this.
Comment 11 steve -_- 2015-10-19 11:44:34 UTC
NOTOURBUG

This is Apples bug to fix. Report about this problem sent via their feedback website http://www.apple.com/feedback/ (for OS X).

Let's hope they'll deal with this soon.

Sadly no tracking ID from apple so cross fingers is all we can do here.