Bug 70762 - using non-Hebrew font with Hebrew text, letters displayed (using a fallback font) but not niqqud
Summary: using non-Hebrew font with Hebrew text, letters displayed (using a fallback f...
Status: RESOLVED DUPLICATE of bug 70741
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: Other Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2013-10-22 13:19 UTC by Uwe Brauer
Modified: 2015-12-15 22:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
odt file containg hebrew text with niqqud in 2 fonts (8.67 KB, application/vnd.oasis.opendocument.text)
2013-10-22 13:19 UTC, Uwe Brauer
Details
pdf file generated by LO 4.0 all niqqud are displayed (20.66 KB, application/pdf)
2013-10-22 13:20 UTC, Uwe Brauer
Details
pdf file generated by LO 4.1 NOT all niqqud are displayed (20.67 KB, application/pdf)
2013-10-22 13:20 UTC, Uwe Brauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Brauer 2013-10-22 13:19:13 UTC
Created attachment 87983 [details]
odt file containg hebrew text with niqqud in 2 fonts

Hello

from another application I can copy the word 
בָּדַקְתִּי
into writer and it gets displayed correctly, however when I chose a font such as 
Ubuntu, the niqqud are not displayed nor can I type/write/input them. 

This problem does not appear in 4.0 (OO 3.3 OO 4.0)
I attach the odt and the two pdf files.
Comment 1 Uwe Brauer 2013-10-22 13:20:13 UTC
Created attachment 87984 [details]
pdf file generated by LO 4.0 all niqqud are displayed
Comment 2 Uwe Brauer 2013-10-22 13:20:45 UTC
Created attachment 87985 [details]
pdf file generated by LO 4.1 NOT all niqqud are displayed
Comment 3 Maxim Monastirsky 2013-10-22 19:43:22 UTC
Hi,

In fact Ubuntu font doesn't contain any Hebrew letters\niqqud, so what you see is a substitution by DejaVu Sans font. So basically you except that the niqqud will be also shown using DejaVu Sans. But I would say that LibreOffice should not allow choosing a font which doesn't contain Hebrew letters, when the active language is Hebrew.

I can reproduce this problem using 4.1.1.2 under Ubuntu 13.04 (64-bit) & using 4.1.2.3 under Ubuntu 13.10 (64-bit). It's reproducible with every non-Hebrew font. But I can't reproduce using 4.1.2.3 under Fedora 19 (64-bit). So looks like Ubuntu specific bug.
Comment 4 Björn Michaelsen 2013-10-24 00:03:29 UTC
Likely NOT an Ubuntu-specific bug, but a duplicate of fdo#70741:

 https://bugs.freedesktop.org/show_bug.cgi?id=70741
 https://gerrit.libreoffice.org/#/c/6393/
 https://gerrit.libreoffice.org/#/c/6398/
Comment 5 Maxim Monastirsky 2013-10-27 16:30:21 UTC
(In reply to comment #4)
> Likely NOT an Ubuntu-specific bug, but a duplicate of fdo#70741:
Indeed, fixed by the same commit.

*** This bug has been marked as a duplicate of bug 70741 ***
Comment 6 Robinson Tryon (qubit) 2015-12-15 22:05:12 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]