Download it now!
Bug 70842 - EDITING: Large document with many pictures causes freezing in Writer when scrolling with scroll bar
Summary: EDITING: Large document with many pictures causes freezing in Writer when scr...
Status: RESOLVED DUPLICATE of bug 63433
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-10-24 14:24 UTC by Gene
Modified: 2014-01-05 20:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gene 2013-10-24 14:24:11 UTC
Problem description: 
When editing a large, photo-heavy document, Writer continually freezes for 2-30 seconds at a time when paging through the document.
Steps to reproduce:
Edit http://www.geneb.org/rostock-max/Rostock-MAX-Assembly-Guide.odt (Roughly 30MB, 202 pages)

Page up and down through the document for a short period of time.  You'll notice the freezing.  If you do it enough, the main window will vanish for seconds at a time.

This behavior makes it nearly impossible to get any work done with this document.

              
Operating System: Windows 7
Version: unspecified
Comment 1 Cor Nouws 2013-10-24 17:46:29 UTC
Hi Gene,

thanks for posting the issue.
I do not have that problem. Maybe there it helps if you set more memory for graphics cache ? (Tools > Options > LibreOffice ... memory )

I tried in 4.1.3rc1 on Ubuntu by the way. 4Gig memory for the system.
Cheers,
Cor
Comment 2 Gene 2013-10-24 17:55:58 UTC
Cor, I'm using the current "release" version for Windows.  I've bumped up the cache to 400MB+ and I've seen no difference.  The machine I use most often is Win7x64 with 16GB of RAM.

You might try grabbing the scroll bar, going to the bottom of the document and start paging/cursoring up from there.  Change some text, etc.  This is VERY repeatable on my machine. :(

Thanks for the quick response!

g.
Comment 3 Cor Nouws 2013-10-24 19:20:09 UTC
Hi gene,

Ah, I tried just Page-up/down, Home and End. That works fine, just as the Navigator.
But using the mouse and scroll bar.. Hmm.

(I would not be surprised if it is related to bug 70809 too)

thanks!
Comment 4 Gene 2013-10-24 19:51:01 UTC
I'm not in a position to test keyboard-only navigation at this point (horrifyingly slow network makes it impractical at the moment).

It doesn't appear to me that the bug you referenced is anything like what's going on here. :)

Try scrolling through the document by clicking in the scroll bar tray to make it page down/up and see if that triggers it for you - it does for me.

tnx.

g.
Comment 5 Gene 2013-10-24 19:54:30 UTC
Ok, this is weird.  When I see your change email to this bug, it references the title to #70809 as being "EDITING: Large document with many pictures causes freezing in Writer when scrolling with scroll bar", but when I got to the link in your comment, it reads: "[EDITING] Selecting with mouse: too fast changing to next/previous page"

*confused*

g.
Comment 6 Cor Nouws 2013-10-24 20:44:52 UTC
(In reply to comment #4)

> It doesn't appear to me that the bug you referenced is anything like what's
> going on here. :)

Both show troublesome behaviour when using the mouse to scroll.

> Try scrolling through the document by clicking in the scroll bar tray to
> make it page down/up and see if that triggers it for you - it does for me.

I did. Therefore I confirmed the problem ;)
Comment 7 Gene 2013-10-24 20:47:17 UTC
Bug # 63433 is basically the same issue I'm having. :(

g.
Comment 8 Kevin Suo 2013-10-25 02:32:08 UTC
I can confirm this a little bit:
Ubuntu 13.10 x86, 2G RAM, 3GHz*2 CPU, default ubuntu build libreoffice 4.1.2.3.

* Open your file from the link, try to scroll with the scroll bar as fast as possible down to the last page (or from the last page to the fist page). LO freezes for about 10s sometimes.

It's the same after I changed the memory for graphics cache settings.
Comment 9 tommy27 2013-11-24 18:24:07 UTC
(In reply to comment #7)
> Bug # 63433 is basically the same issue I'm having. :(
> 
> g.

reproduced with LibO 4.1.3.2 under Win7 64bit

I experience freezes when doing "mad scrolling" with the test document either using the scrollbar or the page-up/page-down keys.

I think this is exactly the same bug as # 63433 so I'm marking this as a DUPLICATE.

*** This bug has been marked as a duplicate of bug 63433 ***
Comment 10 tommy27 2014-01-05 20:09:28 UTC
works fine with Version: 4.2.0.0.beta2+
Build ID: 039dadf3b48484ba5d1fc71de5561288e6b7c5cb
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2013-12-06_22:54:58