Download it now!
Bug 70872 - Calc very slow with charts with large numbers
Summary: Calc very slow with charts with large numbers
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 80677 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-25 18:37 UTC by migilenik
Modified: 2015-10-23 17:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file with chart (185.74 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-10-25 18:37 UTC, migilenik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description migilenik 2013-10-25 18:37:41 UTC
Created attachment 88122 [details]
Example file with chart

If i wanna change position of chart or add text or whatever, Calc is (i think) recalculating values over and over again. I have 10 000 numbers, values between cca 30 to 35 thousands and do something with document like that, is very complicated.
Calc is almost freezing every time I click.
Comment 1 Dominique Boutry 2013-10-27 15:56:41 UTC
Sur un ordinateur AMD Athlon(tm) II X2 220 Processor 2.80 GHz sous Win7 (mémoire RAM de 4 Go), sur un copier/coller du graphique :
- LibO 4.1.2.3 présente des temps de 30 secondes pour le "copier" et 30 secondes pour le "coller",
- A00 4.0.0 copie très vite mais met 40 secondes pour le "coller",
- Excel 97 répond immédiatement, sur tout ce que j'ai essayé.
Comment 2 Maxim Monastirsky 2013-10-27 20:43:20 UTC
Confirmed using 4.1.2.3 under Fedora 19 (64-bit).

@Dominique Boutry: Please post comments in English only.
Comment 3 Dominique Boutry 2013-10-27 22:11:46 UTC
Sorry...

On a computer AMD Athlon(tm) II X2 220 Processor 2.80 GHz under Win7 (4 Gb of RAM memory), for a copy/paste of the graphics :
- LibO 4.1.2.3 shows a 30 seconds duration to copy and 30 seconds duration to paste,
- AOO 4.0.0 takes a second to copy and 40 seconds to paste,
- Excel 97 makes the whole quasi instantaneously, for every task I tried.
Comment 4 m.a.riosv 2014-06-29 20:11:00 UTC
*** Bug 80677 has been marked as a duplicate of this bug. ***
Comment 5 QA Administrators 2015-07-18 17:44:45 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-07-18
Comment 6 Buovjaga 2015-10-23 17:23:50 UTC
No such perf problems anymore. 1 sec delay tops when manipulating chart. If you discover a longer delay, please give exact steps to reproduce and set back to NEW.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: fcc2415ade6ae93710bbbda9f7e163045e323105
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-21_16:55:13
Locale: fi-FI (fi_FI)