Bug 80677 - UI: Very sluggish with larger data sets
Summary: UI: Very sluggish with larger data sets
Status: RESOLVED DUPLICATE of bug 70872
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-29 13:45 UTC by michaelsonrw
Modified: 2015-01-18 01:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description michaelsonrw 2014-06-29 13:45:22 UTC
Problem description: 

Steps to reproduce:
1. Using and graphing large blocks of data
2. ....
3. ....

Current behavior:  Incredibly sluggish performance

Expected behavior:  Workable real-time behavior when graphing and issuing commands or modification to data or formats.
While manipulating large amounts of data (the current set has over 15000 points), graphing and manipulation within the spreadsheet is so slow as to be unworkable.  I have used the same data in MS Office on a similar vintage Windows machine with MS office and it handles the data just fine.  In Libre office, the performance is so slow, I pretty much cannot use Libre Office Calc for the task.

              
Operating System: Linux (Other)
Version: 4.2.5.2 release
Comment 1 m.a.riosv 2014-06-29 14:20:29 UTC
Hi Michael, thanks for reporting.

Please can you attach a sample file to test.
Comment 2 michaelsonrw 2014-06-29 14:42:13 UTC
Just auto fill some cells with 15000 or so x.-y pairs and try to make an x.y plot and see how slow it is.
Comment 3 m.a.riosv 2014-06-29 20:11:00 UTC
I think this is a duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=70872

Please if you are not agree, reopen it.

*** This bug has been marked as a duplicate of bug 70872 ***