Download it now!
Bug 70977 - Saving with Chart active is confusing and can lead to data loss in an unsaved spreadsheet, because flag Modified is set to false
Summary: Saving with Chart active is confusing and can lead to data loss in an unsaved...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.1 rc
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: dataLoss
: 85839 90179 103853 (view as bug list)
Depends on:
Blocks: Chart
  Show dependency treegraph
 
Reported: 2013-10-29 01:04 UTC by Hernan
Modified: 2019-10-22 09:03 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hernan 2013-10-29 01:04:27 UTC
Steps

1. Open a new LO spreadsheet. Fill some data, select and make a chart.

2. While the chart is active, go to File->Close . 
"Your changes will be lost if you don't save them" -> Press "Save"

3. The save dialog saves as type "ODF chart" (and no alternative). Fill some filename and save.

4. The document gets closed. 
Go to Open->Recent: only the chart is available, the spreadsheet is lost!

If the document had already been saved, it works. However, while the chart is activate, one cannot save (Ctrl-S fails silently, and so a user might believe that the document has been saved, while it hasn't)
Comment 1 Cor Nouws 2013-10-30 15:44:28 UTC
Hi Hernan,

Thanks for the issue. I can confirm the problem.

Saving a chart from a not saved spreadsheet, should not set the files flag Modified to false.

Best,
Cor
Comment 2 Matthew Francis 2014-12-18 05:54:40 UTC
*** Bug 85839 has been marked as a duplicate of this bug. ***
Comment 3 Matthew Francis 2015-04-07 06:51:56 UTC
*** Bug 90179 has been marked as a duplicate of this bug. ***
Comment 4 tommy27 2016-04-16 07:25:27 UTC Comment hidden (obsolete)
Comment 5 bruno.binet 2016-06-07 18:59:20 UTC
The bug is still present in 5.0 branch (tested here on linux mint 17.3), but it depends on the way we create the chart (I work with X-Y chart).

If the data cells are selected "before" I click the chart button (typical), I have the bug directly.

However, if I manually select the X and Y cell ranges (in the chart assistant), the "save" (or save as) function in chart mode then saves the spreadsheet (correct). But if I return in chart mode to edit the chart, I still have the bug.

Very nasty...
Comment 6 Hernan 2016-06-07 19:12:29 UTC
Bug still present, as originally described.

Tested on Version: 5.1.2.2 Build ID: d3bf12ecb743fc0d20e0be0c58ca359301eb705f, win7-64
Comment 7 Mark_T2016 2016-10-26 02:21:32 UTC
Bug verified in 5.2.2.2 64 bit on Windows 8.1.

Seems quite high risk of data loss.

Open LibreOffice, create a new Calc document. Enter data into the spreadsheet. Create a chart from some of the data (example using bar chart). Double click on chart to change some formats etc. Use File, Save while chart is still in edit mode, saves only the chart into .odc file. User probably not going to notice that it is saved as .odc file. Close spreadsheet document, no warnings are given. Reopen the document and the user finds only the chart. Only data that was in the chart data table can be recovered, but not easily.
Comment 8 Aron Budea 2016-10-26 07:21:02 UTC
Let's adjust severity to critical, because this issue can lead to data loss.
Comment 9 m.a.riosv 2016-11-11 16:27:02 UTC
*** Bug 103853 has been marked as a duplicate of this bug. ***
Comment 10 peekaa 2016-11-13 16:48:06 UTC
I am teacher. Even if you say to students "pls before saving you have to click somewhere to table, you dont need to stay in chart", some of them forget to do it. And when they come next week, half of them forget again. You have to tell this them each time, each week. Its really unpleasant. All their work has just gone. There is always one or two of them....  Pls change this behaviour. 

File  - Save should always save all the work, all the table with all lists.
Comment 11 bruno.binet 2017-03-08 00:51:32 UTC
With version 5.2.5.1 (Linux), bug as described in comment#7. Actually, the spreadsheet is correctly saved if I save before exiting the chart mode for the first time. However, if I quit this mode and then return to edit, then saving at this point leads to the bug (if no saving has been done before).
Comment 12 bruno.binet 2017-03-08 00:58:03 UTC
(In reply to bruno.binet from comment #11)
> With version 5.2.5.1 (Linux), bug as described in comment#7. Actually, the
> spreadsheet is correctly saved if I save before exiting the chart mode for
> the first time. However, if I quit this mode and then return to edit, then
> saving at this point leads to the bug (if no saving has been done before).

Correction: bug at this point even if a saving has been done before.
Comment 13 Laurent BP 2017-03-29 11:35:07 UTC
Another way to show the bug:
1. Open an existing spreadsheet
2. Modify some data
=> Save icon shows that file needs to be saved
3. Open a chart or create one
4. While chart is open, File > Save
=> As described (and expected) only chart is saved
5. Exit chart

Actual behavior:
Save icon shows that file does NOT need to be saved

Expected behavior:
LibO should know that only chart has been saved but not the entire spreadsheet which has been modified in step 2. Save icon must indicate that file needs to be saved.
Comment 14 Jean-Francois Nifenecker 2017-08-02 16:30:43 UTC
Confirmed.

I add some more information about usability.

Another problem having to see with this one and that occurred today to a user: 1. she created the chart within an existing ods
2. she then saved while the chart was selected.
3. As discussed, LibreOffice asks to save (as odc).
4. She sees the "odc" thing then changes it manually to "ods" so that the underlying calc spreadsheet be saved
5. She confirms the replacement message ("of course I want to update my ods!")
6. The save process completes and she closes the document.

-> When opening it back, surprise! It's the odc (made-up to ods by herself unknowingly) which appears.

The original ods is gone and unrecoverable: the .bak in the backup directory is also the made-up odc.

Clearly, to me, to the data loss possibility, there's a usability problem here. Most people don't know anything about what an odc is. They think they did something wrong then want to correct manually, thus defeating the software original intend.

I think some kind of *very* clear message should be displayed in this situation so that the user can realize what is at stake.
Comment 15 QA Administrators 2018-08-03 02:51:26 UTC Comment hidden (obsolete)
Comment 16 Hernan 2018-08-03 20:31:44 UTC
Bug still present in latest version of LibreOffice.

Same behaviour as in description (also comments #13 #14).

Version: 6.0.5.2 (x64)
Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
CPU threads: 4; OS: Windows 6.1; UI render: default; 
Locale: es-AR (en_US); Calc: group
Comment 17 pa 2018-08-06 13:08:25 UTC
Bug still present, (Ver 6.0.1.1, Windows10 as this was latest at term start), still CRITICAL and still causing trouble to students in the middle of exams, when their files are lost, except for one chart.

It seems to be very difficult to solve.
Comment 18 Markus Mohrhard 2018-11-30 02:19:17 UTC
Fixed by removal of the chart export feature.