Download it now!
Bug 70989 - Output range only shows the first cell in Statistic Sampling dialog
Summary: Output range only shows the first cell in Statistic Sampling dialog
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: All Linux (All)
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: Confirmed:4.2.0.0.alpha0+:Linux targe...
Keywords:
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2013-10-29 11:10 UTC by sophie
Modified: 2013-12-13 15:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sophie 2013-10-29 11:10:15 UTC
In the dialog of Statistic > Sampling, the Output Range field only indicate the first selected cell and not the selected range.
Using Version: 4.2.0.0.alpha0+
Build ID: 051731bbcaa79b6428c8ebee6c114c9b28220cc8
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2013-10-21_01:09:11
Sophie
Comment 1 Joel Madero 2013-11-15 02:56:52 UTC
Confirmed.

New feature so I think it deserves some love on the 4.2 mab list
Comment 2 Tomaz Vajngerl 2013-11-20 17:24:28 UTC
This is actually how it is meant to be - for output you select only the first cell as the actual output range depends on the sampling parameters (random: first cell + sample size, periodic: first cell + input size / period). The same is also true for every other statistics function. This is not ideal - suggestions how to improve this are welcome.
Comment 3 Joel Madero 2013-11-20 18:57:20 UTC
I thought the same but then when output can be over a range. I think either 

a) don't allow someone to select a range for output
b) allow selecting a range and show this range in the dialog

Having a person be able to highlight a range but then one value appears seems confusing
Comment 4 Tomaz Vajngerl 2013-11-20 20:30:52 UTC
Well in solver you also have "target cell" where you also can select a range but only the first one is the target. Similar in "Multiple Operations" - Row input cell, Column input cell. Looks like you can't just select one cell - at least not with this input box. I will take a look if I can change this.
Comment 5 Robinson Tryon (qubit) 2013-11-24 05:26:33 UTC
Add repro status to whiteboard
Comment 6 Kohei Yoshida 2013-12-12 15:54:22 UTC
IMO this is not a bug. As Tomaz said it's working as expected.  Since the size of the output range is fixed, and the user cannot specify as it depends on the characteristics of the input parameters, I don't see a point of allowing the user to select a range.

The one thing I might suggest changing the wording from "Output Range" to something else that does not give the user an impression that he/she can select a range.  Something like "Output Position", "Result to", "Result" etc may flow better?  Pivot table, which also outputs a "range" uses "Result to" wording.
Comment 7 sophie 2013-12-12 15:58:42 UTC
(In reply to comment #6)
> IMO this is not a bug. As Tomaz said it's working as expected.  Since the
> size of the output range is fixed, and the user cannot specify as it depends
> on the characteristics of the input parameters, I don't see a point of
> allowing the user to select a range.
> 
> The one thing I might suggest changing the wording from "Output Range" to
> something else that does not give the user an impression that he/she can
> select a range.  Something like "Output Position", "Result to", "Result" etc
> may flow better?  Pivot table, which also outputs a "range" uses "Result to"
> wording.

Thanks Kohei for your input, I think using the same terminology than for Pivot table is good: Result to - 
And Tomaz thanks for your great work :) - Sophie
Comment 8 Commit Notification 2013-12-13 14:22:31 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6df78d1a4c9bf5e0e182d5cdc0a300e3c84e6d86

fdo#70989: Change wording from "Output Range" to "Results to".



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2013-12-13 15:54:40 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bb4406c326315d3e1864f7dd9aaf286086ea0701&h=libreoffice-4-2

fdo#70989: Change wording from "Output Range" to "Results to".


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Kohei Yoshida 2013-12-13 15:55:17 UTC
Taking ownership.
Comment 11 Kohei Yoshida 2013-12-13 15:56:16 UTC
I changed all the "Output Range" labels used in the new statistical analysis dialogs to "Results to".  I call it fixed.