Bug Hunting Session
Bug 71211 - EDITING: Linux Libertine G:nfsp=1 option does not work correctly with abbreviations
Summary: EDITING: Linux Libertine G:nfsp=1 option does not work correctly with abbrevi...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2013-11-04 10:19 UTC by Jonathan Haas
Modified: 2019-08-14 05:21 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Haas 2013-11-04 10:19:51 UTC
Steps to reproduce:

- Create a new Writer document, use "Linux Libertine G:nfsp=1" as main font

- Enter the some random text with abbreviations, for example:

I like geom. figures. They are extr. nice.

Expected result: 
- Text displayed correctly.

Actual result:
- LibreOffice duplicates characters after abbreviations and displays:

I like geom.ffigures. They are extr.nnice.
Comment 1 Joel Madero 2013-11-09 05:32:45 UTC
Can you link to the font? Marking as NEEDINFO, once you link mark as UNCONFIRMED.


Thanks!
Comment 2 Jonathan Haas 2013-11-09 10:04:17 UTC
The font is here:
http://numbertext.org/linux/

But as far as I know this font should be bundled with LibreOffice.
Comment 3 Joel Madero 2013-11-09 17:15:56 UTC
Interesting - the only thing is I have Linux Libertine but not Linux Libertine G, when I put in the G in the font box it shows that I don't have the font installed. Furthermore, trying to download from the site fails every time
Comment 4 Jonathan Haas 2013-11-09 17:18:11 UTC
Download works fine for me. If you want me to send you the file, please tell me so.
Comment 5 Jean-Baptiste Faure 2013-11-24 16:26:20 UTC
Joel: Linux Libertine G and Linux Biolinum G are graphite fonts bundled in the generic Linux version of LibreOffice since 4.0.

Jonathan: I reproduce the problem. It seems there is some weird interactions between several options like frsp=0 and auto-correction (capitalize first letter of a sentence).

Laszlo: something for you ?

Best regards. JBF
Comment 6 László Németh 2013-11-25 09:22:40 UTC
I will check it, but I'm afraid, it's not possible to fix it for LibreOffice 4.2. Unfortunately, Graphite 2 integration of LibreOffice hasn't handled space matching GDF rules, yet. They work only on word-level. A solution to switch off this rule or use it with LibreOffice 3.2. Thanks for your bug report and your comments!

Joel: http://www.numbertext.org/linux/e7a384790b13c29113e22e596ade9687-LinLibertineG-20120116.zip,
Comment 7 QA Administrators 2015-04-19 03:23:47 UTC Comment hidden (obsolete)
Comment 8 Jonathan Haas 2015-04-19 09:05:27 UTC
Still reproducable in 4.2.7.2 and 4.4.2.2
Comment 9 martin_hosken 2015-04-20 01:53:38 UTC
In testing against trunk, when typing the sequence "This. is ". We get:
T
Th
Thi
This
This.
This. 
This.ii
This.iis
This. Is 
(with a final space).

Looking at the GDL for LinuxLibertineG. This line stands out as being buggy:

u(0x0020) > @3 {user6 = 1} / sentenceend ^ _ {user6 == 0} csc1;

Note @3 here refers to the csc1 character. I suggest that changing @3 to @2 will fix the font and solve this bug (in conjunction with the changes in the code now in trunk for 4.5 fixing bug #52540)
Comment 10 QA Administrators 2016-09-20 09:34:10 UTC Comment hidden (obsolete)
Comment 11 Jonathan Haas 2016-09-20 10:15:00 UTC
Still reproducible on 5.2.0.0.beta1 / Fedora 24
Comment 12 Xisco Faulí 2017-07-13 10:07:05 UTC
Setting Assignee back to default. Please assign it back to yourself if you're still working on this issue
Comment 13 QA Administrators 2018-07-14 02:47:12 UTC Comment hidden (obsolete)
Comment 14 Thomas Lendo 2019-08-11 14:20:43 UTC
Adding Khaled Hosny to CC list. As font specialist maybe he knows something helpful.
Comment 15 Khaled Hosny 2019-08-14 05:21:55 UTC
Font bug per comment 9.