Bug 71237 - insert new comment shortcut (Ctrl+Alt+C) failure
Summary: insert new comment shortcut (Ctrl+Alt+C) failure
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-05 00:57 UTC by Humberto Elizondo
Modified: 2013-11-12 21:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Humberto Elizondo 2013-11-05 00:57:58 UTC
In Writer 4.0 User Guide (English) it is stated that the keystroke combination Alt+Ctrl+C inserts a new comment (page 102).

Actually, the keystrokes are ignored.
Comment 1 tommy27 2013-11-05 03:28:27 UTC
tested with 4.1.2.3 under Win7 64bit.
the Ctrl+Alt+C combination works as expected in my PC.

which LibO version are you using? which O/S?
if you click the "insert" do you see "Ctrl+Alt+C" next to the "Comment" item?
Comment 2 Humberto Elizondo 2013-11-05 14:43:04 UTC
O/S:  Win 7 64 bit, running on an i5, 4-core processor (Intel).
LibO Version: 4.1.3.2.

And yes, "Ctrl+Alt+C" is shown next to the "Comment" option in the "Insert" menu.  Works as it should if I click over there with the mouse; but the keyboard sequence fails to do its assigned task.


Regards.

 

Humberto Elizondo.




El Lunes, 4 de noviembre, 2013 21:29:01, "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org> escribió:
 
 
tommy27  changed bug 71237 

What
Removed
Added
Status UNCONFIRMED  NEEDINFO  
CC    barta@quipo.it  
Summary Keyboard shortcut failure  insert new comment shortcut (Ctrl+Alt+C) failure  
Ever confirmed    1  
Comment # 1 on bug 71237 from tommy27  
tested with 4.1.2.3 under Win7 64bit.
the Ctrl+Alt+C combination works as expected in my PC. which LibO version are you using? which O/S?
if you click the "insert" do you see "Ctrl+Alt+C" next to the "Comment" item?
________________________________
 You are receiving this mail because: 
	* You reported the bug.
Comment 3 tommy27 2013-11-05 15:12:30 UTC
what if you click menu "tools / customize / keyboard" and try locating that key combination? do you see it assigned to the "insert comment" action?
Comment 4 Humberto Elizondo 2013-11-05 16:01:51 UTC
Affirmative; that particular keystroke combination is assigned.  Just it it reads "comment", not "insert comment"; but I think that should not make any difference.


 

Humberto Elizondo.




El Martes, 5 de noviembre, 2013 9:12:30, "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org> escribió:
 
 
tommy27  changed bug 71237 

What
Removed
Added
Status NEEDINFO  UNCONFIRMED  
Version unspecified  4.1.3.2 rc  
Ever confirmed 1     
Comment # 3 on bug 71237 from tommy27  
what if you click menu "tools / customize / keyboard" and try locating that key
combination? do you see it assigned to the "insert comment" action?
________________________________
 You are receiving this mail because: 
	* You reported the bug.
Comment 5 Jorendc 2013-11-05 18:56:44 UTC
@bug reporter: please do not reply the emails you receive with every new comment made in this bug report, but browse to it (https://bugs.freedesktop.org/show_bug.cgi?id=71237) and leave a comment over there. This reduces the noise :). Thanks

Ontopic on the report:
A possibility is the fact this interrupt (keystrokes) is already associated with something related to your OS (or at least a 'higher application then LibreOffice'). Easy explained: that key stroke can't pass to LibreOffice because it is taken by another service of/in Windows.

Not sure how to fix it, or what service/application interfere.

Kind regards,
Joren
Comment 6 Humberto Elizondo 2013-11-12 16:12:32 UTC
Thanks, Joren.

I guess you are right; Windows must be intercepting this keystroke combination, so it is not available to LibreOffice.  Regrettably, I have not been able to prove this conclusively.  Anyhow, it became clear that this is not a bug in LibreOffice.

I have been trying, meanwhile, to reach a conclusion on this matter, but sadly I have to say I've not succeeded.  I tested the {Ctrl+Alt+C} combination on another machine, and worked as expected.  This had an earlier release of LibO, 4.0.0.3, running under Windows 7 Home Basic.

For a while, I thought I had found the trouble, for I am using the US International keyboard setting.  For the most part, it behaves as a standard US keyboard; however, it includes additional characters not available in the standard keyboard.  For instance, æ, ö, ø, ñ, ß, ç, to name a few.  Most of these characters are displayed onscreen after some keystroke combination is struck.  {Ctrl+Alt+Z}, for example, yields æ.

It occurred to me that perhaps {Ctrl+Alt+C} was being used by Windows for the ç character to show up.  Not so; actually, this is done with {Ctrl+Alt+,} (that's a comma, at the end).  {Ctrl+Alt+C} doesn't seem to do anything; I got suspicious, all the same, and turned over to the standard US keyboard, to no avail.  This same keystroke sequence is used in Calc to insert a comment in a cell, and of course it doesn't work, either.

Since Tommy27 reported that the combination worked allright for him, having tested it on LibO 4.1.2.3, I downgraded to that version to see if that cleared the trouble; it was not so.  Finally, I ended assigning a different keystroke combination to this function.

I have few programs installed on my machine, for it is relatively new; there's no other program that could be regarded as a "higher application" than LibreOffice,  to my knowledge.  Personally, I still think my keyboard setting has some connection to the problem.  Pressing {Alt+C} makes a brief, tinkling sound.  It doesn't happen so with {Ctrl+Alt+C}, nevertheless.

Best regards,

Humberto Elizondo.
Comment 7 tommy27 2013-11-12 16:26:53 UTC
I mark this ad RESOLVED NOTOURBUG.
feel free to reopen if you do not agree with this decision.
Comment 8 Humberto Elizondo 2013-11-12 16:49:40 UTC
No, I won't challenge your decision.  I'm grateful to you as well, 
Tommy.

Regards.
Comment 9 Jorendc 2013-11-12 17:51:32 UTC
A last and not likely possibility is to reset your user profile of LibreOffice. This is quite 'machine-specific' and as far I know there are some personal settings stored. So, long story short, it _might_ help but is really unlikely in my honest opinion.

See https://wiki.documentfoundation.org/UserProfile#Resolving_corruption_in_the_user_profile (the location of your user profile folder is explained a little higher on that page).

Kind regards,
Joren
Comment 10 Humberto Elizondo 2013-11-12 21:03:30 UTC
Thanks again, Joren.

I'll give it a try, as soon as I get acquainted with the LibreOffice Profile.


Regards.

H. Elizondo